VirtualBox

Ticket #2210 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Text copy/paste broken when run headless (only)

Reported by: jbl1 Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I am running headless an XP client in VB 2.0.0 on an XP host and accessing it from yet another XP with the MS standard RDP client (6.0.6001.18000). All XPs are SP2 or SP3.

When in a text editor (e.g., notepad.exe), pasting of a (just) copied chunk of text produces garbage. The garbage, seemingly non-text, seems to be same across various clients (XP) and in a clean (rebooted) machine, checked for small chunks of text. Note that this effect does not show when the VM is displayed locally.

Attachments

VBox.zip Download (7.0 KB) - added by jbl1 5 years ago.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to RDP

comment:2 follow-up: ↓ 3 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Try again with 2.0.4. Several clipboard fixes are included in 2.0.2 and 2.0.4.

comment:3 in reply to: ↑ 2 Changed 5 years ago by jbl1

  • Status changed from closed to reopened
  • Resolution fixed deleted

Replying to sandervl73:

Try again with 2.0.4. Several clipboard fixes are included in 2.0.2 and 2.0.4.

Sorry to say this, but the person closing this ticket didn't bother to check either the changelog for 2.0.2. or 2.0.4 (no mention of fixes for headless mode, save clipboard in headless mode) or do the real test: copy-pasting btw two apps in headless mode.

For the sake of user trust this is not good. I'd rather accept the devel/fix team not doing anything with a problem than reporting falsely :-(

comment:4 follow-up: ↓ 6 Changed 5 years ago by sandervl73

I asked you to verify with a later version, since you didn't bother to report if 2.0.2 worked. We close bugs reports when the reporter doesn't provide feedback as you can't possibly expect us to check everything people report.

Thank you for confirming it is still broken, but there's no need to overreact.

comment:5 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.0.0 to VirtualBox 2.0.4
  • Summary changed from Text copy/paste broken in 2.0.0 when run headless (only) to Text copy/paste broken when run headless (only)

comment:6 in reply to: ↑ 4 Changed 5 years ago by jbl1

Replying to sandervl73:

I asked you to verify with a later version, since you didn't bother to report if 2.0.2 worked. We close bugs reports when the reporter doesn't provide feedback as you can't possibly expect us to check everything people report.

Thank you for confirming it is still broken, but there's no need to overreact.

Please don't take me for a troll even if I am going to not agree with you. Nowhere at the bug tracker page ( http://www.virtualbox.org/wiki/Bugtracker) is there a mention of a bug reporter's duty to check if the symptom went away with a new release (perhaps a good point to add if you thinks so, but I doubt this would be a good thing). Also, I have a mixed feeling about your statement "you can't possibly expect us to check everything people report" -- how are things fixed then? By sticking a wet finger into the air? This is not my notion. I think my report was good enough to pinpoint the issue, well, I might be spoiled by the way e.g., the Django project handles bug fixing ( http://www.djangoproject.com/).

Whatever said it does not mean that I do not appreciate the work you are doing, it's rather that I'd like the product to be even better, otherwise I wouldn't bother to report.

Thanks for reopening the issue and good luck with it. And -- apologies for "reporting falsely" -- should have been phrased in a not insulting way.

comment:7 follow-up: ↓ 8 Changed 5 years ago by sunlover

Please attach the VBox.log. How do you start the headless VM? Clipboard works fine here with headless XP guest on XP host and MS RDP client.

Changed 5 years ago by jbl1

comment:8 in reply to: ↑ 7 Changed 5 years ago by jbl1

Replying to sunlover:

Please attach the VBox.log. How do you start the headless VM? Clipboard works fine here with headless XP guest on XP host and MS RDP client.

This is how I start the VM:

C:\Program Files\Sun\xVM VirtualBox>VBoxHeadless.exe -p 3989 -s "Django"
VirtualBox Headless Interface 2.0.4
(C) 2008 Sun Microsystems, Inc.
All rights reserved

Listening on port 3989

Attaching the current log.

comment:9 follow-up: ↓ 10 Changed 5 years ago by sunlover

Thanks for the log. No obvious problems there for the host part.

Have you updated the guest additions to 2.0.4 level? What is the File Version of the \windows\system32\VBoxTray.exe in the guest?

comment:10 in reply to: ↑ 9 Changed 5 years ago by jbl1

Replying to sunlover:

Thanks for the log. No obvious problems there for the host part.

Have you updated the guest additions to 2.0.4 level? What is the File Version of the \windows\system32\VBoxTray.exe in the guest?

Yes, guest additions weren't updated, i.e., vBoxTray.exe was at 2.0.0.0. Now it is at 2.0.4.0 (guest additions updated) but the problem persists, though in a bit different way: the pasted text seems now to be of length zero whereas before the update some fixed length garbage was pasted.

Sorry for not having updated the additions. Is there a way Vbox could detect such a situation and warn the user?

Thanks for you quick replies. What other data/tests should I make?

comment:11 Changed 5 years ago by jbl1

Update/correction: it seems that the problem went away with 2.0.4 *and* the proper guest additions; the only explanation I have for the experiment from my previous posting failing is that there was no reboot after the guest addition install. The RDP clients I tried were 5.1.2600.2180 (XP SP2) and 6.0.6001.18000 (both from XP SP3 and Vista).

But, not all is lost ;) in the following setup: XP SP3 host running XP (SP3) headless, an RDP (6001) client on the host accessing the headless plus the host accessed with RDP client (6001) both from XP and Vista. The symptom in the headless is as described in the previous posting -- pasting zero length.

I will try the same experiment tomorrow but accessing the host locally, not via RDP. sunlover - I wonder if this is reproducible.

Thanks

comment:12 Changed 5 years ago by jbl1

Apologies

The "pasting zero length" as described in the previous msg does not occur -- I cannot confirm it and have no explanation.

Thanks for fixing the issue, it seems that it should be closed.

Best regards.

comment:13 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use