VirtualBox

Ticket #2191 (closed defect: worksforme)

Opened 6 years ago

Last modified 5 years ago

Problem using more than 1 network interface on machine

Reported by: KeyzerSuze Owned by:
Priority: critical Component: network
Version: VirtualBox 2.0.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi

I have a guest where I have presented 2 nic. The system was on first boot of the host machine and first boot of the guest machine, both network cards would work. Nic A would be acctached to brVB and Nic B would be attached to brXcat. Upon reboot of the guest machine, the first nic to try an talk to the realworld would fail, it never receives any packats (looking at ifconfig), I have tcdumped the tap interface on the host and I can see packets entering the tap, but I can't seem them entering the guest. On the reverse path I can see packets leave the guest, and entering the host.

I add another Nic C and attached it to brVB and it works. if I reboot the guest with Nic A not on auto start then Nic B has the problems :)

I am seeing these problems on a SMP box (I make not of this because of my other ticket I have open which has a problem with this box)

Alex

Change History

comment:1 Changed 6 years ago by KeyzerSuze

I have tried this with 2.0.2 and the problem still persists

comment:2 Changed 5 years ago by jurabonn

I can confirm the problem of hostif networking with more than one nic on a ubuntu 8.04 64bit server host with ubuntu jeos clients.

we use a virtual maschine as a dhcp server for two different networks. it has a third nic for maintainance in an other network, too.

sometimes you have to reboot the client up to 15 times to bring all interfaces up. It seems to be a virtualbox problem, though nothing is changed on the clients configuration.

Can anybody else confirm that problem? It is very annoying...

comment:3 Changed 5 years ago by frank

May I ask which Linux distribution runs as guest? I would also like to see a VBox.log file because this file contains your VM configuration and perhaps some hints why the guest was not able to find it's network cards ...

comment:4 Changed 5 years ago by KeyzerSuze

I was running rhel5

sorry I have moved on since then and don't have access to the machine :(

comment:5 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

So I will close that bug. Before re-open it make sure you check the latest release (2.2.2).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use