VirtualBox

Ticket #219 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Guest Mouse Integration doesn't work with openSUSE

Reported by: Technologov Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords:
Cc: Guest type: other
Host type: other

Description

I have just installed a new openSUSE 10.2 guest on Windows 2000 Server SP4 Host. VirtualBox 1.3.8.

After installing the guest additions, mouse integration doesn't seem to be working.

-Alexey

Change History

comment:1 Changed 7 years ago by frank

We just saw this problem on an other openSUSE installation. The problem is that the X server is initialized very early, that is before the vboxadd module is loaded. I've fixed that problem in svn but to get your mouse integration work again, just make sure that vboxadd is loaded before earlykdm is started:

Please edit the file /etc/init.d/vboxadd and remove the word $syslog in line 16 just behind 'Required-Start:'. Then

  chkconfig --del vboxvfs vboxadd-timesync vboxadd
  chkconfig --level 35 vboxadd on
  chkconfig --level 35 vboxadd-timesync on
  chkconfig --level 35 vboxvfs on

Then reboot the guest. The mouse integration should work again.

comment:2 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:3 Changed 7 years ago by Technologov

Fix verified.

Works on Win XP host, VBox 1.4.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use