VirtualBox

Opened 11 months ago

Last modified 11 months ago

#21796 new defect

unable to build kernel modules with Kernel 6.4.10 => fixed in svn

Reported by: joeAverage Owned by:
Component: other Version: VirtualBox-7.0.10
Keywords: kernel modules Cc:
Guest type: Windows Host type: Linux

Description (last modified by joeAverage)

on Fedora 38 I'm unable to build vbox kernel modules with Kernel 6.4.10. elder Kernel 6.4.9 was fine.

environment:

  • WERROR is not set in the kernel .config
  • GDS_FORCE_MITIGATION=y
  • new microcode is on the box

no fix running the Test Build "VirtualBox-7.0.11-158681"

Attachments (1)

vbox-setup.log (15.7 KB ) - added by joeAverage 11 months ago.
vbox-setup.log

Download all attachments as: .zip

Change History (20)

by joeAverage, 11 months ago

Attachment: vbox-setup.log added

vbox-setup.log

comment:1 by joeAverage, 11 months ago

Description: modified (diff)

comment:2 by joeAverage, 11 months ago

Description: modified (diff)

comment:3 by joeAverage, 11 months ago

Description: modified (diff)

comment:4 by tekstryder, 11 months ago

Just ran into this on Arch as well:

Error! Bad return status for module build on kernel: 6.4.10-1-stable (x86_64)

Virtualbox 7.0.10 version on kernel 6.4.8 built without issue.

VB modules for kernel 6.4.10 fail to build

comment:5 by tekstryder, 11 months ago

I should have checked the official packaging first.

Already fixed by the Arch package maintainers.

Patch is here: https://gitlab.archlinux.org/archlinux/packaging/packages/virtualbox/-/commit/5711067e6a052c2f6a2a3078254f8e7bdcef0bd7

Kernel modules for 6.4.10 build without issue now

comment:6 by joeAverage, 11 months ago

above patch works in Fedora with WERROR set too

THX tekstryder !

Version 0, edited 11 months ago by joeAverage (next)

comment:7 by galitsyn, 11 months ago

Summary: unable to build kernel modules with Kernel 6.4.10unable to build kernel modules with Kernel 6.4.10 => fixed in svn

Hi joeAverage,

Thank you for pointing out. Fix looks correct to me. It will be addressed in the next release.

comment:8 by joeAverage, 11 months ago

THX galitsyn

comment:9 by Didier, 11 months ago

Same problem with kernel-6.4.10-200.fc38.x86_64 on Fedora 38.

It will be nice if you could provide a development snapshots with this fix.

comment:10 by pgndvb, 11 months ago

Same problem with kernel-6.4.10-200.fc38.x86_64 on Fedora 38.

ditto fail,

https://www.virtualbox.org/ticket/21802#ticket

looks like my duplicate :-/

comment:11 by joeAverage, 11 months ago

you mean *your* duplicate looks like my initial report !

;-)

comment:12 by galitsyn, 11 months ago

Hi guys,

Test builds page now updated as well. Feel free to pick up either 6.1.x, 7.0.x or Development snapshot.

comment:13 by Andre Robatino, 11 months ago

Confirmed that the kernel modules build when using VirtualBox-7.0.11-158813-Linux_amd64.run. Thanks.

comment:14 by galitsyn, 11 months ago

Thank you for give it a try.

comment:15 by Didier, 11 months ago

VirtualBox-7.0.11-158813-Linux_amd64.run works fine with kernel-6.4.11-200.fc38.x86_64

Thanks for your job.

in reply to:  16 ; comment:17 by galitsyn, 11 months ago

Replying to fth0:

@galitsyn: Please check Re: VBox 7.0.10 kernel 6.4.10 Fedora 38 /sbin/vboxconfig failed.

Hi fth0,

The issue has been fixed and test builds are in place. Forum thread also confirms that. What should I check there?

Last edited 11 months ago by galitsyn (previous) (diff)

in reply to:  17 ; comment:18 by fth0, 11 months ago

Replying to galitsyn:

The issue has been fixed and test builds are in place. Forum thread also confirms that. What should I check there?

My bad! I meant the post by marios101 that my link points to. But I didn't see/know that marios101's statement matches the patch you probably applied.

in reply to:  18 comment:19 by galitsyn, 11 months ago

Replying to fth0:

Replying to galitsyn:

The issue has been fixed and test builds are in place. Forum thread also confirms that. What should I check there?

My bad! I meant the post by marios101 that my link points to. But I didn't see/know that marios101's statement matches the patch you probably applied.

No problem. Thank you for pointing to the forums thread.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use