VirtualBox

Opened 13 months ago

Closed 8 months ago

#21725 closed defect (wontfix)

Unable to DnD, Shared Clipboard, Shared folders on Windows 11 Host and multiple Linux Guests

Reported by: tracesofnuts Owned by:
Component: guest additions Version: VirtualBox-7.0.8
Keywords: Cc: tracesofnuts
Guest type: Linux Host type: Windows

Description

Have had multiple issues with Guest Additions being unable to mount/install/work properly

Various issues:

  • unable to bidirectional DnD, shared clipboard
  • able to mount shared folder but unable to access files within guest VMs

Host: Windows 11, version 22H2 Guest: Multiple Linux guests:

  • Ubuntu (32-bit)
  • Debian (64-bit)
  • Ubuntu (64-bit)

Steps taken so far:

  • mounted Guest Additions (unable to mount on 1 out of 4 VMs)
  • Installed Guest Additions
  • Reinstalled Virtual Box
    • have tried 6.1.44 and 7.0.8
    • confirmed hashes to be ok
  • installed fresh copy of Ubuntu-22 still not working
  • rebooted hosts multiple times
  • rebooted the different guests multiple times
  • mounted shared folders but unable to access the contents
  • run as admin/without admin
  • installed as admin/without admin

I have attached the logs of 4 different Linux guests each of which is unable to do DnD. Shared clipboard is also unable to work but I am unable to show the error in the logs.

I am now somewhat convinced that it is my host system since all my VMs are affected.

If it helps, my system is a Lenovo P15v. The bios settings are as follows:

  • Config → CPU → Intel(R) Hyper-Threading Technology → Enabled
  • Security → Memory Protection → Execution Prevention → Enabled
  • Security → Memory Protection → Intel(R) Total Memory Encryption → Disabled
  • Security → Virtualization → Kernel DMA Protection → Enabled
  • Security → Virtualization → Intel(R) Virtualization Technology → Enabled
  • Security → Virtualization → Intel(R) VT-d Feature → Enabled
  • Security → Virtualization → Enhanced Windows Biometric Security → Disabled
  • Security → Device Guard → Device Guard → Disabled

Attachments (1)

logs.zip (80.9 KB ) - added by tracesofnuts 13 months ago.

Download all attachments as: .zip

Change History (3)

by tracesofnuts, 13 months ago

Attachment: logs.zip added

comment:1 by galitsyn, 13 months ago

Hi tracesofnuts,

What is the guest's Desktop Environment you are running? I have suspicion it might be one of the Wayland compositors which is not yet supported. In this case Shared Clipboard and DnD will not work, but Shared Folders should be functioning. If it is a case, a workaround would be to switch to XWayland.

comment:2 by galitsyn, 8 months ago

Resolution: wontfix
Status: newclosed

Closing due to no activity.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use