VirtualBox

Ticket #2161 (closed enhancement: fixed)

Opened 6 years ago

Last modified 4 years ago

Report true CD-ROM drive name

Reported by: A20_user Owned by:
Priority: minor Component: DVD
Version: VirtualBox 2.0.0 Keywords: CD-ROM name
Cc: Guest type: Windows
Host type: Windows

Description

The name of CD-ROM drive is reported as VBOXCD-ROM1.0 (the are 0x00 bytes) and is fix. This is very bad for OEM software which expects to find a specific drive. Please report either the name of the real hardware device of Host, or make this name here a config option (please as hex string, because 0-bytes seem to be required sometimes), or allow both.

Change History

comment:1 Changed 6 years ago by A20_user

Sorry, the special character I used screwed things up. Name is: VBOX####CD-ROM##1.0 think the # as 0-bytes.

comment:2 Changed 6 years ago by sandervl73

Why should we? The whole point is that we virtualize the hardware. Which OEM software depends on the cdrom name?

comment:3 Changed 6 years ago by A20_user

The CD-Burner soft Nero 6 OEM checks the name. No, you do not virtualize this hardware but directly pass thru commands (same as for USB devices). This is why the name should be the true one. VMware Player reports the true name, too.

comment:4 Changed 6 years ago by frank

Of course we virtualize the hardware. We just make a subset of the real functionality available for the guest. The ID string was fixed mainly for the reason to ensure that guests don't get confused if the same VM is executed on a different hardware. And it is not unlikely that the name of the CDROM device is one criterion for Windows to decide if reactivation is required or not. Anyway, making this string configurable is not a bug effort.

comment:5 Changed 6 years ago by A20_user

A "bug" or a "big" effort? :-)

Because you seem to care about Win activation issues, let me add another suggestion and observation. The DMI strings can be configured, but as far as I see Win XP does care about BIOS name and date strings directly found in ROM the old way. These are still not configurable and clearly mark VirtualBox.

I would like to see that VirtualBox can hide it's nature from the Guest as far as possible, if the user likes it. One application would be to run an OS like XP or Vista either natively or under VirtualBox, directly from harddisk partition.

comment:6 Changed 6 years ago by frank

You might have noted that 'u' and 'i' are direct neighbors.

And you will be possibly surprised that it is still possible to run a guest directly from a hard disk, see the user manual section 9.9. We don't have much feedbar what is needed to keep Windows from reactivation but this is a story for another ticket.

comment:7 Changed 6 years ago by A20_user

I did know that a Guest can access physical harddisk partitions directly.

Regarding the Windows activation, there is a paper freely available on the web ( http://www.licenturion.com/xp/) describing behavior of XP prerelease versions in great detail. XP SP3 behaves differently and I feel the Vista description made available by Microsoft itself applies here. Use google to search for "Product Activation for Windows Vista and Windows Server 2008", it will find a *.doc at MS, for official download. There remains some uncertainty because the weighting factors are not disclosed, but you get a feeling what to care about.

I see that it might be a difficult task, depending on actual weighting factors.

comment:8 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

The vendor product data is configurable for some time now. See chapter 9.7.2 of the manual. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use