VirtualBox

Ticket #2149 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Arch Linux -> VM assertion (pVM->patm.s.pGCStateHC->fPIF == 1) -> fixed in SVN/3.0.6

Reported by: xwisdom Owned by:
Priority: major Component: VMM
Version: VirtualBox 3.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

I was successful in setting up Virtualbox to run on ubuntu LTSP server 8.04. All was working fine until I recently noticed that the VM would get stuck or sometime abort without any warning.

After the VM aborts the session this is the message I'm getting inside the log:

00:07:21.742 !!Assertion Failed!!
00:07:21.742 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:07:21.742 Location  : /home/vbox/vbox-2.0.0/src/VBox/VMM/PATM/PATM.cpp(6083) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
00:07:21.814 Crash in patch code ed70284b (81a6e254) esp=770b03f4
00:07:21.814 Patch state=4 flags=30c1023 fDirty=0
00:07:21.814 <NULL>

The strangest thing is that if I were to remove the virtualbox network adapters then it appears to work normally.

Attachments

VBox-Logs.tar.gz Download (78.8 KB) - added by xwisdom 6 years ago.
XP-2009-04-13.log Download (46.1 KB) - added by julie 5 years ago.
XP-2009-04-14.log Download (43.7 KB) - added by julie 5 years ago.
VBox.log Download (39.1 KB) - added by vsaveris 5 years ago.
VBox.2.log Download (35.6 KB) - added by ndrewpj 5 years ago.
VBox.log ArchLinux 2009.08

Change History

Changed 6 years ago by xwisdom

comment:1 Changed 6 years ago by frank

  • Component changed from other to VMM
  • Description modified (diff)
  • Summary changed from VM getting Aborted to VM assertion (pVM->patm.s.pGCStateHC->fPIF == 1)

comment:2 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if this problem persists with the latest release (2.2.0).

comment:3 Changed 5 years ago by julie

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have the same problem. Have installed Windows XP on my Linux. All works fine until windows suddenly gets aborted or stucks.

comment:4 Changed 5 years ago by julie

VBox 2.2 by the way.

Changed 5 years ago by julie

comment:5 Changed 5 years ago by frank

julie, the logfile you attached doesn't indicate any problem. Wrong VBox.log file?

Changed 5 years ago by julie

comment:6 Changed 5 years ago by julie

I'm sorry about that. Wasn't the right file. I attached a new one.

comment:7 follow-up: ↓ 8 Changed 5 years ago by frank

  • Version changed from VirtualBox 2.0.0 to VirtualBox 2.2.4

#4293 has been marked as duplicate of this ticket. A host kernel upgrade to 2.6.30 apparently triggered the problem there.

comment:8 in reply to: ↑ 7 Changed 5 years ago by Marcus Schätzle

Replying to frank:

#4293 has been marked as duplicate of this ticket. A host kernel upgrade to 2.6.30 apparently triggered the problem there.

it was a guest kernel upgrade though, my host is Windows XP, the guest is Linux, so actually vice versa to this ticket. I can see the log file gives the same error message though, but since this problem is from a totally different host/guest combination and appears in a different context I don't know if I can add something substantial here.

comment:9 Changed 5 years ago by dbb

I'm seeing the same thing in 2.2.4 with a Windows Vista SP2 host and a Arch Linux (kernel 2.6.30) guest. VirtualBox would crash consistently when udev was run at bootup. When run in VirtualBox 3 Beta 2 for the first time VirtualBox didn't crash immediately and I got the following output:

:: Loading udev...BUG: soft lockup - CPU#0 stuck for 61s! [load-modules.sh:55]}}}
Modules linked in: <snip>

This output would repeat periodically, I couldn't capture it all as I couldn't copy and paste. Subsequent tries lead to VirtualBox crashing like it did with version 2.2.4

comment:10 Changed 5 years ago by HumanoidSam

Same issue here, Archlinux with kernel 2.6.30 just upgraded as guest and debian (2.6.26) as host.
I got an other vm running Archlinux (2.6.29) running fine.

Running VirtualBox 2.2.4 or 2.1.4ose

00:00:12.724 !!Assertion Failed!!
00:00:12.724 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:00:12.724 Location  : /home/vbox/tinderbox/2.2-lnx32-rel/src/VBox/VMM/PATM/PATM.cpp(6137) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
00:00:12.724 Crash in patch code ff0616ef (c0307c18) esp=cfbafd08
00:00:12.724 Patch state=4 flags=10c0081 fDirty=4
00:00:12.724 <NULL>

comment:11 Changed 5 years ago by dark_ray

Trying to install Archlinux with kernel 2.6.30 as guest under OpenSuse 11.0 (2.6.25) as host. VirtualBox 3.0.2 crash at udev scan:

00:00:14.544 !!Assertion Failed!!
00:00:14.544 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:00:14.544 Location  : /home/vbox/vbox-3.0.2/src/VBox/VMM/PATM/PATM.cpp(6148) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
00:00:14.544 Crash in patch code ff17547f (c0307aa8) esp=df057d58
00:00:14.544 Patch state=4 flags=10c0081 fDirty=4
00:00:14.544 <NULL>

comment:12 Changed 5 years ago by rysiek

I can confirm this with Linux host and guest:

  • host: Ubuntu Dapper, kernel 2.6.15
  • guest: Arch Linux, kernel unknown (unable to check it as I am unable to start the VM!).

VirtualBox version 2.1.0_OSE

comment:13 Changed 5 years ago by rysiek

confirming the same thing with VirtualBox 2.2.4_OSE, too.

comment:14 Changed 5 years ago by rysiek

and confirming for 3.0.2_OSE! Log below.

VirtualBox Headless Interface 3.0.2_OSE
(C) 2008-2009 Sun Microsystems, Inc.
All rights reserved.


!!Assertion Failed!!
Expression: pVM->patm.s.pGCStateHC->fPIF == 1
Location  : /home/rysiek/downloaded/VirtualBox-3.0.2_OSE/src/VBox/VMM/PATM/PATM.cpp(6148) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
Crash in patch code ff16594f (c0307aa8) esp=dfaffd58
Patch state=4 flags=10c0081 fDirty=4
<NULL>
Trace/breakpoint trap

Logfile:

Log created: 2009-07-20T18:51:14.839763000Z
Executable: /usr/lib/virtualbox/VBoxHeadless
Arg[0]: /usr/lib/virtualbox/VBoxHeadless
Arg[1]: -s
Arg[2]: LwB
Crash in patch code ff16594f (c0307aa8) esp=dfaffd58
Patch state=4 flags=10c0081 fDirty=4
<NULL>

comment:15 Changed 5 years ago by rysiek

I was able to recover my VM to a booting state. The problem is related to kernels at version 2.6.30 (and possibly 2.6.29), after downgrading to 2.6.28 all works AOK.

comment:16 Changed 5 years ago by scusack

Still getting bitten by this with virtualbox 2.2.4 host Vista and Guest Arch Linux with kernel-2.6.30, does upgrading to virtualbox 3 help?

comment:17 Changed 5 years ago by tomk

...and confirming the same for Arch 2.6.30 as both guest and host with VB 3.0.2

00:01:39.781 !!Assertion Failed!!
00:01:39.781 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:01:39.781 Location  : /home/vbox/tinderbox/3.0-lnx32-rel/src/VBox/VMM/PATM/PATM.cpp(6148) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
00:01:39.781 Crash in patch code ff0753b7 (c0307aa8) esp=cf897d08
00:01:39.781 Patch state=4 flags=10c0081 fDirty=4
00:01:39.781 <NULL>

It seems it's related to having new kernels (2.6.30) as guest. I had the same error with Ubuntu 9.04 (2.6.28) as host and Arch 2.6.30 as guest. With 2.6.28 as both guest and host, it was alright.

comment:18 in reply to: ↑ description Changed 5 years ago by anmt

I can also reproduce the issue on Linux as guest and host. 64-bit Gentoo host and 32-bit Arch Linux guest:

00:00:29.113 !!Assertion Failed!!
00:00:29.113 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:00:29.113 Location  : /home/vbox/tinderbox/3.0-lnx64-rel/src/VBox/VMM/PATM/PATM.cpp(6148) int PATMR3HandleTrap(VM*, CPUMCTX*, RTRCPTR, RTGCPTR*)
00:00:29.113 Crash in patch code ff074404 (c0308188) esp=d00e7d08
00:00:29.113 Patch state=4 flags=10c0081 fDirty=0
00:00:29.113 0060:ff074404 cc                      int3

My CPU is too old to support AMD-V (it's an old 64-bit Sempron 3300+). Booting the live cd worked (had an older kernel). Just not booting the actual installed system.

comment:19 Changed 5 years ago by danielkza

I can confirm this, Windows 7 x64 host (VBox 3.0.2 PUEL x64), Arch Linux with kernel 2.6.28 works, but the VM crashes after I update it to 2.6.30.

I can also attest the problem goes away if I disable networking support.

comment:20 Changed 5 years ago by beachcoder

I have to confirm this bug. I'm running an Arch Linux, Kernel 2.6.30 Guest on a Windows XP SP3 32-Bit Host.

My VirtualBox version is 3.0.0 r49315 says:

00:00:17.712 
00:00:17.712 !!Assertion Failed!!
00:00:17.712 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:00:17.712 Location  : E:\tinderbox\win-rel\src\VBox\VMM\PATM\PATM.cpp(6148) PATMR3HandleTrap
00:00:17.712 Crash in patch code feaa718c (c0305dc8) esp=ef14bd0c
00:00:17.712 Patch state=4 flags=10c0081 fDirty=0
00:00:17.712 <NULL>

Then I tested with version 3.0.2 r49928, same error:

00:00:28.293 !!Assertion Failed!!
00:00:28.293 Expression: pVM->patm.s.pGCStateHC->fPIF == 1
00:00:28.293 Location  : C:\vbox\branch\win-3.0\src\VBox\VMM\PATM\PATM.cpp(6148) PATMR3HandleTrap
00:00:28.293 Crash in patch code feaa2814 (c0305dc8) esp=ef12bd0c
00:00:28.293 Patch state=4 flags=10c0081 fDirty=0
00:00:28.293 <NULL>

regards,

beachcoder

comment:21 Changed 5 years ago by beachcoder

oh yes, before I forget this: Removing network cards or connections did not solve the problem. I can't boot at all, tested several options.

comment:22 Changed 5 years ago by vsaveris

Same problem with Windows 7 Host and ArchLinux (Kernel 2.6.30) as guest. The problem was not evident with previus kernel (2.6.28). Please check below the output of the windows event viewer:

Log Name:      Application
Source:        Application Error
Date:          5/8/2009 11:54:55 πμ
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      test
Description:
Faulting application name: VirtualBox.exe, version: 3.0.4.0, time stamp: 0x4a788269
Faulting module name: VBoxVMM.dll, version: 0.0.0.0, time stamp: 0x4a78822c
Exception code: 0x80000003
Fault offset: 0x00054c46
Faulting process id: 0x4a4
Faulting application start time: 0x01ca15aa5b0af853
Faulting application path: C:\PROGRA~1\Sun\XVMVIR~1\VirtualBox.exe
Faulting module path: C:\PROGRA~1\Sun\XVMVIR~1\VBoxVMM.dll
Report Id: a4d2d7d8-819d-11de-91fa-005056c00008

Changed 5 years ago by vsaveris

comment:23 Changed 5 years ago by ndrewpj

Confirmed on ArchLinux 2009.08 guest with stock 2.6.30.4 kernel

Changed 5 years ago by ndrewpj

VBox.log ArchLinux 2009.08

comment:24 Changed 5 years ago by ndrewpj

VirtualBox 3.0.4 Host:Vista SP2 x86

comment:25 Changed 5 years ago by sandervl73

  • Summary changed from VM assertion (pVM->patm.s.pGCStateHC->fPIF == 1) to Arch Linux -> VM assertion (pVM->patm.s.pGCStateHC->fPIF == 1) -> fixed in SVN/3.0.6

Fixed in SVN.

comment:26 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.2.4 to VirtualBox 3.0.4

comment:27 Changed 5 years ago by danielkza

Any chance of a test compile for Windows? (if possible)

comment:28 Changed 5 years ago by frank

Sent.

comment:29 Changed 5 years ago by jvbarnet1

Hate to jump on the bandwagon (*jumps*). Could I get a copy of that test compile of SVN with the fix included. Haven't ben able to run the latest Arch Linux install.

Thanks.

comment:30 Changed 5 years ago by Romashka

Could you point to a changeset in the public SVN repo that fixes the bug? Can it be cleanly applied to vanilla OSE 3.0.4 or it depends on some other post-3.0.4 changes?

comment:31 Changed 5 years ago by sandervl73

It's r22152 and applies cleanly to the 3.0.4 tarball.

comment:32 Changed 5 years ago by Vins

Same problem here, Windows Vista Host, Archlinux 2.6.30 as guest. Wuold it be possible to get a Virtualbox 3.0.6 test build for Windows? Thanks!

comment:33 Changed 5 years ago by kopsis

I'm dead in the water due to the same problem (Arch 2.6.30 guest on WinXP host). Unless the release of 3.0.6 is imminent, access to an SVN build for Windows hosts would be *greatly* appreciated.

comment:34 Changed 5 years ago by teigaff

I noticed this problem since a month ago. Could not start Arch Linux 2009.08 guest on WinXP host. Is there a SVN Version for windows? And when, where? Thanks a lot for support.

comment:36 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use