VirtualBox

Ticket #2148 (closed defect: wontfix)

Opened 6 years ago

Last modified 6 years ago

Problems with http://download.virtualbox.org and wget

Reported by: x-drum Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.0 Keywords:
Cc: Guest type: other
Host type: other

Description

When downloading from  http://download.virtualbox.org via wget, files are saved/proposed with a different name, example for VirtualBox-1.6.6-Linux_x86.run:

url used:  http://download.virtualbox.org/virtualbox/1.6.6/VirtualBox-1.6.6-Linux_x86.run
filename: VirtualBox-1.6.6-Linux_x86.run?e=1220828399&h=76fb79eb5def450604fa23f5f7a237dd

this occurs only for all the files actually hosted on dlc-cdn-rd.sun.com.

There is a way to fix this issue? under Gentoo wget is used by default from portage to retrieve all the files needed for the installation of a specific package (in this example for virtualbox-bin-1.6.6), and when the files are saved under with different name the digest verification fails.

Attachments

wget.log Download (1.3 KB) - added by x-drum 6 years ago.
wget output

Change History

Changed 6 years ago by x-drum

wget output

comment:1 follow-up: ↓ 2 Changed 6 years ago by klaus

  • Status changed from new to closed
  • Resolution set to wontfix

This behavior cannot be changed, as it's part of handling the legal aspects of US export control. Well, it can, but neither involved party would appreciate that - it would mean stopping direct VirtualBox downloads entirely.

Also I fail to see that this is really a major problem. You can easily rename the file afterwards (as the '?' separator is obvious), or use wget -O. That means just minor changes to your script.

comment:2 in reply to: ↑ 1 Changed 6 years ago by x-drum

Replying to klaus:

This behavior cannot be changed, as it's part of handling the legal aspects of US export control. Well, it can, but neither involved party would appreciate that - it would mean stopping direct VirtualBox downloads entirely.

ok no problems at all when there are legal aspects involved.

Also I fail to see that this is really a major problem. You can easily rename the file afterwards (as the '?' separator is obvious), or use wget -O. That means just minor changes to your script.

the problem will afflict all the gentoo users installing PUEL licensed files (as said before portage uses wget to retrieve files), the problem is trivial but it's not easy to resolve since portage expects a the same filename declared in the SRC_URI variable.

By the way, to resolve this issue in PUEL ebuilds, the download will be restricted so the users will fetch all the needed files itself.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use