VirtualBox

Ticket #2137 (new defect)

Opened 6 years ago

Last modified 4 years ago

USB issues

Reported by: A20_user Owned by:
Priority: major Component: USB
Version: VirtualBox 2.0.0 Keywords: USB, high CPU load
Cc: Guest type: Windows
Host type: Windows

Description

Win XP SP3 Host, W2000 SP4 Guest with Additions, trying USB assignment for a multi card reader (USB 2.0 enabled). Needed to unplug and reconnect after V.B. driver installed automatically on Host, otherwise card reader was busy and could not be connected to Guest (message of V.B. when device clicked to checkmark it). Accessed by Guest. Unchecked it, Guest complained about prohibited removal, but it is at Host again. No crash like with Vista (see #2114). But the V.B.exe running Guest consumes 50 % of the 2 core CPU completely now, although inside Guest Task Manager shows 97 % idle.

Clean off&start, V.B. does not remember I un-checkmarked card reader, and again 50 % CPU already while Guest is waiting in login dialog. Strange - CPU fan runs only slowly. Clean off, USB off, start. No excessive CPU usage!

Trying USB 1.1 for Guest only, but device at Host and Host port are 2.0. Same 50 % CPU. Clean USB device eject from Guest, CPU 50 %. Card reader unplugged, 50%. It is VBoxSVC.exe which is hogging CPU! Plug in, the same. Guest clean off, VBoxSVC.exe 50 %. GUI closed, the same. Host reboot. (Task Manager did not show "User name" for processes directly after startup, seems to be it needs fome background service for this, which was still not running, although desktop was present.)

V.B. GUI started, VBoxSVC.exe 0 %. Again USB 2.0. Booting Guest, while in boot selector of W2000 50 % VirtualBox.exe (as already know from other tries). While in Login dialog, VirtualBox.exe changed between 10 and 50 %, now with Desktop it is 50 % most of the time. Guest clean off, no excessive CPU usage. Trying clean USB device removal in Guest again. It is still VirtualBox.exe at 50 %. Unplug. Still VirtualBox.exe at 50 %. This time VBoxSVC.exe stays at 0 %, ok. Remember: Guest was USB 2.0 this time, 1.1 previous try.

Again with USB 1.1, GUI and VBoxSVC.exe kept running between Guest starts. Plugin while Guest started. Login, VirtualBox.exe at 50 %, clean removal, unplug, VirtualBox.exe well below 10 %. Clean off (shutdown). No excessive CPU usage. Problem only partially reproducable.

Configured the Linux v.m. with USB 2.0 and cardreader. Booting rescue CD from DVD there. Found /dev/sda to sdd during startup, Guest is text display, top shows 0% CPU there, but VirtualBox.exe goes up and down between approx 10 and 50 %, I assign it fixed to CPU0 now and see a graph close to a sine wave now, from 30 to 100 % usage of this core, higher Task Manager refresh rate: it is longer at 100 %, shorter near 30 %, period is 6 to 7 seconds. Accessing (reading) a SDHC card in card reader seems to work, at least fdisk "p"rint. dd with 1M blocksize gets only 4.1 MByte/s (under Vista 7.3 MByte/s), no higher CPU usage than without dd. Unplugging card reader. CPU waveform unchanged. Plug in. Un-checking in V.B. menu. It appears at Host with the SDCH card inside. Same CPU wave. Guest "halt" command, Guest off, CPU near 0 %.

Disabled USB support and did same Guest startup. CPU near 0 % at command prompt. Clean off.

Activate USB (not 2.0) controller only, no devices attached to Guest. CPU near 0 % at command prompt. Cannot attach any of the 4 USB devices, because V.B. running Guest shows all as "Zustand: Beschäftigt" (busy) in menu - no, I can, just click. Try it with mouse at different Host port this time, Host installs "VirtualBox USB" for this port, too, but looks for it longer than before, mouse is again / still under Host control. Try clicking again "Zustand: gefangen" (no, mouse / keyboard were not captured by Guest, no, message box about beeing busy with earlier request, unplug & plug, "Zustand: nicht unterstützt", but click, "Devices" menu remains marked (pressed). This core is quite constant near 50 % with VirtualBox.exe. V.B. running Guest does no longer respond, seems to be busy internally, Process Monitor does not show any operations for it. Last message in *.log is "OHCI: USB suspended". Turn off by window close and Windows force-kill. CPU 0 %. But GUI shows machine still as running.

GUI terminated and started. It hangs with empty white window, but no CPU load, VBoxSVC.exe is running, GUI does not respond, force-kill-click. VBoxSVC still in background, usually terminates with last VirtualBox.exe. Killing it. GUI start, ok, machines are Ausgeschaltet (off), ok.

Looks like GUI hangs i VBoxSVC.exe hangs. Bad design, timeouts missing.

Change History

comment:1 Changed 4 years ago by mchuck

Not sure if this helps but check ticket #5343 - the solution is to add a blank USB filter to the virtual machine - this has worked for me with Vbox 3.2.6

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use