VirtualBox

Ticket #2108 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Bogus error message when changing settings on VirtualBox 2.0.0 => fixed in 2.0.2

Reported by: GabrielVlasiu Owned by:
Priority: minor Component: GUI
Version: VirtualBox 2.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

After changing some settings for a guest machine (which have a snapshot) and press OK (even if I do not modify anything) an error message is shown:

The snapshot folder of a machine with snapshots cannot be changed (please discard all snapshots first).
Result Code: NS_ERROR_FAILURE (0x80004005)
Component:   Machine
Interface:   IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}

Despite this error, changes are applied to guest.

Change History

comment:1 Changed 6 years ago by pcordes

This happens when I add a disk image to a new slot on the hard drive controller of a VM. Even worse, when my snapshot directory is not the default (e.g. I changed it to /data/users/peter/...) sometimes this results in snapshot directory being reset to the default (~/.Virtualbox/...), and the snapshots actually being lost. (Not present in the old /data directory, and just a ~12kB snapshot in the default directory.) WinXP in the VM bluescreens very early in the boot process after this happens, because I guess the 12kB snapshot isn't just an empty snapshot.

I've seen this error message even when changing a mounted floppy image from the settings menu.

comment:2 Changed 6 years ago by frank

  • Description modified (diff)

comment:3 Changed 6 years ago by frank

  • Description modified (diff)

comment:4 Changed 6 years ago by aquarius

I also see this constantly on Mac OS X with VirtualBox 2.0 when exiting VM details using "OK". Even if I only viewed my settings without changing anything.

My machine has a snapshot in non-standard location. (Luckily, until now I never lost it like pcordes)

comment:5 Changed 6 years ago by poetzsch

  • Summary changed from Bogus error message then changing settings on VirtualBox 2.0.0 to Bogus error message when changing settings on VirtualBox 2.0.0 => fixed in 2.0.2

The original bug report will be fixed in the 2.0.2 release (duplicate of #2064). According your first comment about lost snapshots: I couldn't reproduce this so fare. Could you open a second bug report after the 2.0.2 release if you see this behavior again?

comment:6 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use