VirtualBox

Opened 2 years ago

Last modified 18 months ago

#21061 new defect

Shared folder Automount not working properly Linux Mint 21 Cinnamon

Reported by: Munch Owned by:
Component: shared folders Version: VirtualBox 6.1.36
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Automount works perfectly in my older Linux Mint 20.3 Cinnamon VM. I installed Linux Mint 21 Cinnamon. But automount does not work properly. It mounts the folder and I gave permissions to my user to vboxsf But the sub folders or files are randomly locked without permissions to read/write. It seems some files/folder are owned by root, those works and some are unknown owner those don't work. Rebooting will randomly change which file/folder have root or unknown owner.

Latest VBox and guest additions is installed.

I tried disabling automount and doing a manual mount or adding to /etc/fstab and both work perfectly.

Attachments (3)

vbox.PNG (9.7 KB ) - added by Munch 2 years ago.
vbox.2.PNG (9.7 KB ) - added by Munch 2 years ago.
VBox.log (91.2 KB ) - added by Munch 18 months ago.

Download all attachments as: .zip

Change History (9)

by Munch, 2 years ago

Attachment: vbox.PNG added

by Munch, 2 years ago

Attachment: vbox.2.PNG added

comment:1 by Munch, 2 years ago

Note the folders in my shared folder screenshot. Two folders belong to root-vboxsf the other one belongs to nobody-nogroup

comment:2 by galitsyn, 23 months ago

Hi Munch,

I briefly looked into the issue and cannot spot it here so far. Could you please attach VBox.log and also let's make sure that correct VBox drivers are loaded on the guest side -- could you please also post the output of:

dmesg | grep -i vbox

from the guest side. By default, all the sub-folders and files within VBox share should be owned by root:vboxsf. This can be seen in /etc/mtab in guest.

Could you please also try VirtualBox & Additions 6.1.38?

comment:3 by Munch, 18 months ago

This is still an issue. But I have narrowed it down a bit.

  1. It's not an automount issue as such. The shared folder does mount. It's some kind of access issue.
  2. The folders and permissions are fine when copying files to it or reading from it using the file explorer. But as soon as qbittorrent tries to write to it those folders permissions corrupt and qbittorent is unable to write to it. At this point even the file explorer is unable to access it until I reboot.
  3. I have replicated this in several different linux distro's including Latest Mint, Ubuntu, Fedora and others.
  4. I have used different versions of qbittorrent including the one that works on Mint 20.3 on the other distro and they have this same issue.
  5. I have tried using a different bittorrent client i.e. BiglyBT and the issue is different as in none of the files it writes to the shared folder can ever be found. The folder permissions don't get corrupted as in qbittorent though.

I will supply the above log request soon

by Munch, 18 months ago

Attachment: VBox.log added

comment:4 by Munch, 18 months ago

Also lately on I just get Errored: Permission Denied in qbittorent when it starts to download the file to the shared folder.

Attached VBox.log as requested.

$ dmesg | grep -i vbox
[    0.001545] ACPI: RSDP 0x00000000000E0000 000024 (v02 VBOX  )
[    0.001548] ACPI: XSDT 0x00000000BFFF0030 00003C (v01 VBOX   VBOXXSDT 00000001 ASL  00000061)
[    0.001552] ACPI: FACP 0x00000000BFFF00F0 0000F4 (v04 VBOX   VBOXFACP 00000001 ASL  00000061)
[    0.001556] ACPI: DSDT 0x00000000BFFF0630 002353 (v02 VBOX   VBOXBIOS 00000002 INTL 20100528)
[    0.001561] ACPI: APIC 0x00000000BFFF0240 00007C (v02 VBOX   VBOXAPIC 00000001 ASL  00000061)
[    0.001563] ACPI: SSDT 0x00000000BFFF02C0 00036C (v01 VBOX   VBOXCPUT 00000002 INTL 20100528)
[    0.593104] ata2.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/133
[    0.615850] scsi 1:0:0:0: CD-ROM            VBOX     CD-ROM           1.0  PQ: 0 ANSI: 5
[    2.120149] ata3.00: ATA-6: VBOX HARDDISK, 1.0, max UDMA/133
[    2.121078] scsi 2:0:0:0: Direct-Access     ATA      VBOX HARDDISK    1.0  PQ: 0 ANSI: 5
[    4.517357] vboxguest: loading out-of-tree module taints kernel.
[    4.517484] vboxguest: module verification failed: signature and/or required key missing - tainting kernel
[    4.539146] vboxguest: Successfully loaded version 7.0.4 r154605
[    4.539178] vboxguest: misc device minor 123, IRQ 20, I/O port d040, MMIO at 00000000f0400000 (size 0x400000)
[    4.539179] vboxguest: Successfully loaded version 7.0.4 r154605 (interface 0x00010004)
[    7.377420] vboxvideo: loading version 7.0.4 r154605
[    7.441698] 13:08:30.420677 main     VBoxService 7.0.4 r154605 (verbosity: 0) linux.amd64 (Nov 16 2022 17:25:52) release log
[    7.441871] 13:08:30.420881 main     Executable: /opt/VBoxGuestAdditions-7.0.4/sbin/VBoxService
[    7.497459] vboxsf: g_fHostFeatures=0x8000000f g_fSfFeatures=0x1 g_uSfLastFunction=29
[    7.497706] vboxsf: Successfully loaded version 7.0.4 r154605
[    7.497743] vboxsf: Successfully loaded version 7.0.4 r154605 on 5.15.0-58-generic (LINUX_VERSION_CODE=0x50f4a)
Last edited 18 months ago by galitsyn (previous) (diff)

comment:5 by galitsyn, 18 months ago

Hi Munch,

Still cannot reproduce the issue here. Is there any chance that something (for example antivirus software) is blocking file on the Windows host side? Are you able to unmount share when it happens? Maybe there is something suspicious what catches you eye in guest dmesg?

comment:6 by Munch, 18 months ago

I run only windows defender and I checked it's history and it's not picking up or blocking anything. I am also able to unmount after the issue accurs.

To replicate

  1. A recent Linux based distro(I have tried over 5 different ones). I use Mint current one I use is 21.1 Cinnamon.
  2. qbittorrent, though I have replicated it in others 95% of my testing is with this. Recent tests are with v4.5.0 but replicated this on older versions too.
  3. qbittorrent download folder set to a virtualbox shared folder in the settings. I use a subfolder created in the shared folder. I also use another path for incomplete torrents also a subfolder in the shared folder.
  4. A windows host. Currently I have Windows 11 but same issue with 10.

You will encounter one of the following problems when downloading a torrent. It varies sometimes usually based on which distro I used and which bittorrent client and version thereof or sometimes just randomly:

  1. An immediate error with invalid permissions. Yes I have set the user permissions to vboxsf group. The permissions to those folders are now permanently destroyed even the file manager cannot access them until I reboot. However sometimes it will create the folders in those torrents
  2. It will silently download, but the file will be nowhere to be found. Not in the shared folder or anywhere on the Linux filesystem. Even when downloading it does not create the temp files in the downloading folder(also on the vbox share)
  3. It will appear to download but only at a few KB/s. I never let it complete as it makes no sense. I test this same torrent in my older Mint 20.3 distro which is the last one that works and it's fast. There is permanent disk access when this happens. I have qbittorent set to create the full size file upfront, I I believe it's trying to create that file on the share and it's not finishing.

On a fresh reboot the file manager can access those shared folder and copy to them just fine. But after I try and download something the permissions get screwed up sometimes and it no longer works.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use