VirtualBox

Opened 23 months ago

Closed 23 months ago

Last modified 2 weeks ago

#20904 closed defect (fixed)

Error "Failed to load R0 module /usr/lib/virtualbox/VBoxDDR0.r0: Unable to locate imported symbol 'memset' for module 'VBoxDDR0.r0' (VERR_SYMBOL_NOT_FOUND)." running a machine

Reported by: Carles Pina Estany Owned by:
Component: other Version: VirtualBox 6.1.34
Keywords: Cc:
Guest type: all Host type: Linux

Description

Debian Bullseye (version 11.3) with its standard kernel "Linux pinux 5.10.0-13-amd64 #1 SMP Debian 5.10.106-1 (2022-03-17) x86_64 GNU/Linux"

I've installed virtualbox-6.1_6.1.34-150636~Debian~bullseye_amd64.deb and on starting new machines or existing machines I get this error message:

Failed to load R0 module /usr/lib/virtualbox/VBoxDDR0.r0: Unable to locate imported symbol 'memset' for module 'VBoxDDR0.r0' (VERR_SYMBOL_NOT_FOUND).
Failed to load ring-0 module 'VBoxDDR0.r0' for device 'pci' (VERR_SYMBOL_NOT_FOUND).


Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
ConsoleWrap
Interface: 
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I've attached a log file.

Using virtualbox-6.1_6.1.32-149290~Debian~bullseye_amd64.deb all works well.

There isn't any extension pack installed when the problem happens.

Attachments (2)

error-failed-to-load-r0-module-Windows 10-2022-04-20-00-13-38.log (42.6 KB ) - added by Carles Pina Estany 23 months ago.
VBox.log (46.3 KB ) - added by Andre Robatino 23 months ago.
log file for Fedora 35 host attempting to start a Fedora 36 guest

Download all attachments as: .zip

Change History (29)

comment:1 by autopr3z, 23 months ago

Having the same issue on two different Bullseye machines. Guests were both Windows and Linux. Each host is running at least 5.15 or higher Linux kernel. It doesn't seem to matter whether the extensions pack is installed.

comment:2 by Andre Robatino, 23 months ago

Same problem with a Fedora 35 host. Attaching log file for when I attempt to start a Fedora 36 guest.

by Andre Robatino, 23 months ago

Attachment: VBox.log added

log file for Fedora 35 host attempting to start a Fedora 36 guest

comment:3 by Artem S. Tashkinov, 23 months ago

This is a critical issue which warrants a new bugfix release or a rerelease ASAP.

As it is 6.1.34 on Linux hosts is outright broken.

comment:4 by Artem S. Tashkinov, 23 months ago

00:00:00.636222 VBoxDDR0.r0 is importing memset which we couldn't find
00:00:00.636226 AssertLogRel /home/vbox/vbox-6.1.34/src/VBox/HostDrivers/Support/SUPLibLdr.cpp(263) int supLoadModuleResolveImport(RTLDRMOD, const char*, const char*, unsigned int, RTUINTPTR*, void*): <NULL>
00:00:00.636227 VBoxDDR0.r0 is importing memset which we couldn't find
00:00:00.636229 SUP: RTLdrGetBits failed for VBoxDDR0.r0 (/usr/lib/virtualbox/VBoxDDR0.r0). rc=VERR_SYMBOL_NOT_FOUND
00:00:00.636234 PDMLdr: pdmR3LoadR0U: pszName="VBoxDDR0.r0" rc=VERR_SYMBOL_NOT_FOUND szErr="Unable to locate imported symbol 'memset' for module 'VBoxDDR0.r0'"
00:00:00.636242 VMSetError: /home/vbox/vbox-6.1.34/src/VBox/VMM/VMMR3/PDMLdr.cpp(733) int pdmR3LoadR0U(PUVM, const char*, const char*, const char*); rc=VERR_SYMBOL_NOT_FOUND
00:00:00.636243 VMSetError: Failed to load R0 module /usr/lib/virtualbox/VBoxDDR0.r0: Unable to locate imported symbol 'memset' for module 'VBoxDDR0.r0'
00:00:00.636247 VMSetError: /home/vbox/vbox-6.1.34/src/VBox/VMM/VMMR3/PDMDevice.cpp(340) int pdmR3DevInit(PVM); rc=VERR_SYMBOL_NOT_FOUND
00:00:00.636248 VMSetError: Failed to load ring-0 module 'VBoxDDR0.r0' for device 'pci'
00:00:00.637164 ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={872da645-4a9b-1727-bee2-5585105b9eed} aComponent={ConsoleWrap} aText={Failed to load R0 module /usr/lib/virtualbox/VBoxDDR0.r0: Unable to locate imported symbol 'memset' for module 'VBo
xDDR0.r0' (VERR_SYMBOL_NOT_FOUND).
00:00:00.637167 Failed to load ring-0 module 'VBoxDDR0.r0' for device 'pci' (VERR_SYMBOL_NOT_FOUND)}, preserve=false aResultDetail=-609
00:00:00.637220 Console: Machine state changed to 'PoweredOff'
00:00:00.642236 Power up failed (vrc=VERR_SYMBOL_NOT_FOUND, rc=NS_ERROR_FAILURE (0X80004005))

comment:5 by Renda, 23 months ago

Just confirming, the same issue in this configuration:

  • Debian 11 incl. backports updates
  • virtualbox-6.1 6.1.34-150636~Debian~bullseye
$ uname -a
Kernel 5.16.0-0.bpo.4-amd64 #1 SMP PREEMPT Debian 5.16.12-1~bpo11+1 (2022-03-08) x86_64 GNU/Linux

Version 6.1.32 worked fine incl. the Extension pack on the same OS level.

Last edited 23 months ago by Renda (previous) (diff)

comment:6 by jamezrr, 23 months ago

Having the same issue with Kernel: Linux 5.10.0-13-amd64 and same error message above.

comment:7 by aureo, 23 months ago

Just adding the same issue here on Debian Bullseye , virtual box Version 6.1.34 r150636

comment:8 by galitsyn, 23 months ago

Hi guys,

Thanks for pointing to the issue. As a temporary workaround I would suggest to use VirtualBox-6.1.34-150636-Linux_amd64.run installer from https://download.virtualbox.org/virtualbox/6.1.34/.

Last edited 23 months ago by galitsyn (previous) (diff)

comment:9 by dubai, 23 months ago

Same error on all my Linux guests (Debian 11, Kali) on Linux gues (Debian 11). None of them open now. Started happening after a routine system restart.

in reply to:  8 ; comment:10 by jamezrr, 23 months ago

Replying to galitsyn:

Hi guys,

Thanks for pointing to the issue. As a temporary workaround I would suggest to use VirtualBox-6.1.34-150636-Linux_amd64.run installer from https://download.virtualbox.org/virtualbox/6.1.34/.

Version 6.1.34 r150636 (Qt5.15.2) but it is not working

in reply to:  10 comment:11 by Andre Robatino, 23 months ago

Replying to jamezrr:

Replying to galitsyn:

Hi guys,

Thanks for pointing to the issue. As a temporary workaround I would suggest to use VirtualBox-6.1.34-150636-Linux_amd64.run installer from https://download.virtualbox.org/virtualbox/6.1.34/.

Version 6.1.34 r150636 (Qt5.15.2) but it is not working

Using Fedora 35, same Qt version, the .run file works fine for me and is a cleaner workaround.

comment:12 by Lukáš Viktora, 23 months ago

Downgrade back to version 6.1.32-149290~Debian~bullseye was only solution to fix the issue.

in reply to:  8 comment:13 by bittin-, 23 months ago

Replying to galitsyn:

Hi guys,

Thanks for pointing to the issue. As a temporary workaround I would suggest to use VirtualBox-6.1.34-150636-Linux_amd64.run installer from https://download.virtualbox.org/virtualbox/6.1.34/.

That work around worked for me, when i had the same problem with the Arch Linux package updates of Virtualbox this morning

in reply to:  12 comment:14 by CharlieRAnimaMX, 23 months ago

Confirmed, Same problem Here (Fresh Install of Debian 11- with Testing Repositories "Bullseye-Bookworm").

Installer pakage Method for 6.1.34 Doesn't Work, But Back to Version : virtualbox-6.1_6.1.32-149290~Debian~bullseye_amd64.deb. Yes, temporarily solves the problem

Download here -> https://download.virtualbox.org/virtualbox/6.1.32/

Replying to zetneteork:

Downgrade back to version 6.1.32-149290~Debian~bullseye was only solution to fix the issue.

in reply to:  12 comment:15 by jamezrr, 23 months ago

Replying to zetneteork:

Downgrade back to version 6.1.32-149290~Debian~bullseye was only solution to fix the issue.

thanks this the solution to fix the issue.

comment:16 by acastan, 23 months ago

Same is true for Debian Testing, with kernel 5.16. VirtualBox 6.1.32 was working fine, but when upgraded to 6.1.34 , VirtualBox virtual machines stop working, with the same error messages:

Failed to load R0 module /usr/lib/virtualbox/VBoxDDR0.r0: Unable to locate imported symbol 'memset' for module 'VBoxDDR0.r0' (VERR_SYMBOL_NOT_FOUND).

Failed to load ring-0 module 'VBoxDDR0.r0' for device 'pci' (VERR_SYMBOL_NOT_FOUND).

comment:17 by Carles Pina Estany, 23 months ago

There also is some information also in https://forums.virtualbox.org/viewtopic.php?f=7&t=105815 (for for debugging / workaround, which I haven't tried: https://forums.virtualbox.org/viewtopic.php?f=7&t=105815#p516517, which I haven't tried).

comment:18 by tekstryder, 23 months ago

Downstream Arch Linux bug report: https://bugs.archlinux.org/task/74526

Confirmed Virtualbox is completely broken on both Arch with kernel 5.17.4, and Debian Bullseye with kernels 5.17.4, 5.15.35, and 5.10.0-13.

comment:19 by galitsyn, 23 months ago

Hi guys,

This issue should now be fixed. We just updated https://www.virtualbox.org/wiki/Linux_Downloads and now download links point to proper packages. Please feel free to give it a try.

Thank you!

comment:20 by Christian Hesse, 23 months ago

But the source tarball is unmodified. Where to find updated source tarball or patch?

comment:22 by Christian Hesse, 23 months ago

Thanks a lot, klaus! Just pushed a fixed version to Arch Linux repositories.

in reply to:  21 comment:23 by Carles Pina Estany, 23 months ago

Replying to klaus:

You should be able to use this as the patch: https://www.virtualbox.org/changeset?reponame=vbox&format=diff&new=94318%40trunk%2FConfig.kmk&old=94252%40trunk%2FConfig.kmk

Thanks very much - It works for me! (Debian Bullseye)

Last edited 23 months ago by Carles Pina Estany (previous) (diff)

comment:24 by acastan, 23 months ago

This morning upgrade fix the problem in Debian Testing with Kernel 5.16

comment:26 by galitsyn, 23 months ago

Resolution: fixed
Status: newclosed

The issue is now fixed. Closing.

comment:27 by solomon avery, 2 weeks ago

The issue with Debian Testing with Kernel 5.16 been fixed space bar clicker in this morning's update.

Last edited 2 weeks ago by solomon avery (previous) (diff)
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use