Opened 2 years ago

Last modified 2 years ago

#20786 new defect

Strange audio related VM lockups

Reported by: li200 Owned by:
Component: audio Version: VirtualBox 6.1.32
Keywords: Cc:
Guest type: all Host type: Linux


I am experiencing lockups related to audio playback in VirtualBox. To clarify, lockup means that Virtualbox locks up, not the guest; pressing the reset button in virtualbox does nothing. The window will not close unless I issue a "killall VirtualBoxVM", but the UI remains mostly responsive. This has been happening since around 6.1.24. 6.1.22 is the latest version that works fine. On the host, I am using ALSA without pulseaudio. I normally use a very customized asoundrc file, but even without my special ALSA configs, the issue still occurs.

On a WinXP guest, I am experiencing a complete freeze when attempting to move the volume slider and sometimes audio playback causes a freeze.

On a Ubuntu 16.04 guest (kernel 4.4), audio playback happens too fast/slow sporadically. When this happens, I see lines like these in dmesg on the guest. [ 9.025442] snd_intel8x0 0000:00:05.0: intel8x0_measure_ac97_clock: measured 55894 usecs (2880 samples) [ 9.025446] snd_intel8x0 0000:00:05.0: clocking to 44715 When that value (44715) is below 48k, audio is slow. When above, it's fast. Rebooting the VM seems to randomly change this "clocking to ..." value. Also, occasionally, after a long audio playback session with google chrome + youtube the VirtualBox instance will hang on shutdown (VM guest shuts down, but window remains open).

Attachments (1) (48.2 KB ) - added by li200 2 years ago.
A zip containing 2 log files. WinXP is the Windows XP VM, temp is the Ubuntu 16.04 VM.

Download all attachments as: .zip

Change History (5)

by li200, 2 years ago

Attachment: added

A zip containing 2 log files. WinXP is the Windows XP VM, temp is the Ubuntu 16.04 VM.

comment:1 by Willie, 2 years ago

I had the same problem. Fixed it by upgrading alsa-lib and alsa-utils to the latest version,

comment:2 by li200, 2 years ago

When you say "fixed", do you mean the sound playback speed issue or the intermittent lock-up issue, or both? Also, are you upgrading the ALSA packages on the host or the guest, or both? Thanks.

comment:3 by Willie, 2 years ago

Fixed the lockups, didn't have a playback speed issue. And I only updated the host alsa packages.

comment:4 by li200, 2 years ago

Makes sense. I think if you are using Windows guests or a linux guest with a newer kernel, you won't have playback speed issues. I think newer linux kernels seem to hardcode the clock value as a workaround for specific PCI ids (including the VBox audio device id), rather than measuring it on boot.

Anyhow, I'm on Linux Mint (based on Ubuntu), which makes it hard to upgrade the ALSA packages without building them manually, which then creates a mess of broken dependencies. I hope there exists a fix/workaround on the VirtualBox side, since 6.1.22 works perfectly fine. I also tried 6.1.34 today, and it seems like the issue still occurs.

Last edited 2 years ago by li200 (previous) (diff)
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use