VirtualBox

Ticket #2076 (closed defect: fixed)

Opened 10 years ago

Last modified 7 years ago

18 seconds delay to access shared folder under Windows XP since guest additions 1.6.0

Reported by: oxmosys Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Guest : Windows XP Pro SP3, guest additions 2.0, VT-x disabled Host : Linux Ubuntu 8.04.1 x64 Virtualbox : 2.0 amd64

When trying to access a shared folder, guest network and hard drive suddenly works pretty hard while explorer window seems to be frozen, waiting for a answer from the server.

Strangely, the shared folder icon shows no activity while it should, and network and hard drives icon shows a lot of activity, but they should be working! It takes 18 seconds before explorer.exe is actually able to list the shared folder content. After this, everything works correctly until Windows XP is rebooted.

This bug appeared in guest additions 1.6.0, and is still not fixed in guest additions 2.0. guest additions 1.5.6 are fine and don't have this problem.

Attachments

Windows XP.xml Download (8.4 KB) - added by oxmosys 10 years ago.
vboxsf.zip Download (314.9 KB) - added by sunlover 10 years ago.
Shared folders driver and dll for VBox.2.0.6.
VBox.log Download (166.0 KB) - added by oxmosys 10 years ago.
VBox.2.log Download (147.0 KB) - added by oxmosys 10 years ago.
VBox.log #2

Change History

Changed 10 years ago by oxmosys

comment:2 Changed 10 years ago by sunlover

What is the content of the guest Windows registry keys: HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\HWOrder and HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order ?

comment:3 Changed 10 years ago by oxmosys

With 1.5.6 guest additions : VBoxSF,RDPNP,WebClient With guest additions uninstalled : RDPNP,WebClient With 2.0 guest additions : VBoxSF,RDPNP,LanmanWorkstation,WebClient

comment:4 Changed 10 years ago by oxmosys

Setting back both windows registry key to VBoxSF,RDPNP,WebClient as they were in 1.5.6 does not change anything, the problem is still there.

comment:5 Changed 10 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

See defect #1728.

comment:6 Changed 10 years ago by oxmosys

  • Status changed from closed to reopened
  • Resolution duplicate deleted

comment:7 Changed 10 years ago by oxmosys

ticket 1728 is resolved, but this bug is still not fixed, so it's not a duplicate of ticket 1728 and it is still confirmed with 2.0.4 version of virtualbox with guest additions.

Changed 10 years ago by sunlover

Shared folders driver and dll for VBox.2.0.6.

comment:8 Changed 10 years ago by sunlover

  • Version changed from VirtualBox 1.6.0 to VirtualBox 2.0.6

oxmosys, could you please test the attached shared folders driver. Does this improve the situation with long delays? To instal the fix: copy VBoxMRXNP.dll to \windows\system32 on the guest in "Safe mode with command prompt" and VBox.SF.sys to \windows\system32\drivers. Thanks!

comment:9 Changed 10 years ago by oxmosys

Unfortunately, I can't definitively confirm if it fixes delays because I can't even connect to virtualbox shared folder with that version of the driver, it waits several seconds before saying that it does not find any network.

I verified that the files were correctly copied and there is no possible error, I'm using the drivers that you attached to the bug report.

I tested this on two fresh Windows XP guest installation, one with your driver overwriting 1.5.6 guest additions and one overwriting 2.0.4 guest additions, the result is the same.

comment:10 Changed 10 years ago by sunlover

These drivers would not work with 1.5.6 additions but they should work with 2.0.x. I'll send you an email with drivers, which are built with 2.0.x branch.

comment:11 Changed 10 years ago by oxmosys

Thanks! I received your email and tried again with the files you attached. This time, network shares didn't stop to work, but nothing improved, I still have the long delay when I try to access a share. I verified that the files in c:\Windows\system32 C:\Windows\system32\drivers were correctly copied, they're exactly the same size as the one in your email.

There is two copies of the files in your email (one in "debug" folder and one in "release" folder). This test has been achieved with the ones in "release" folder.

comment:12 Changed 10 years ago by oxmosys

Forgot to say that I only tried by overwriting 2.0.4 guest additions. 1.5.6 guest additions has been un-installed before doing these tests.

comment:13 Changed 10 years ago by sunlover

Please test with "debug" drivers and send me VBox.log. Thanks!

Changed 10 years ago by oxmosys

comment:14 Changed 10 years ago by oxmosys

I installed debug driver files correctly, stopped the machine, removed all Vbox.log files, started the machine, opened the share and shutdown the machine. VBox.log is attached. Thanks!

comment:15 Changed 10 years ago by sunlover

I've sent you another email with the debug version of the network provider dll.

Changed 10 years ago by oxmosys

VBox.log #2

comment:16 Changed 10 years ago by oxmosys

New VBox.log attached. The new .dll you sent by you through email does not have this bug.

comment:17 Changed 10 years ago by oxmosys

This bug is fixed with 2.1.4 guest additions!

comment:18 Changed 10 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use