VirtualBox

Ticket #2074 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Mouse integration does not work

Reported by: tompecina Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.0.0 Keywords: mouse integration
Cc: Guest type: Linux
Host type: Linux

Description

Mouse integration for Fedora 9/Fedora 9 (host/guest) stopped working in 2.0.0. Mouse seems to be stuck on the Trash Bin and does not respond correctly. Reinstallation of Guest Additions was no help, the only thing that solves the problem is to disable mouse integration. No problems with Win XP guest though.

Change History

comment:1 Changed 6 years ago by frank

That is not correct: AFAIR, mouse integration never worked for Fedora9 guests with VirtualBox. The reason is that we still had no time to adapt our guest additions to the Xorg 1.5 server.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1854.

comment:3 Changed 6 years ago by tompecina

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Fedora 9 is not using Xorg 1.5 (it will be part of F10), and mouse integration worked alright with VirtualBox <= 1.6.6. Besides, the supposedly duplicate ticket refers to a situation of the kernel module not compiling, which is not the case with F9.

comment:4 Changed 6 years ago by frank

No, the ticket refers to detected xorg 1.5 rcx, refusing to install the xorg modules. This has nothing to do with kernel modules, here the Xorg modules in /usr/lib/xorg/modules are meant. And here for my Fedora9, the X server reports:

$ X -version
X.Org X Server 1.4.99.901 (1.5.0 RC 1)
Release Date: 5 September 2007
X Protocol Version 11, Revision 0

And this version is not yet supported by VBox and never was.

Do we talk about different versions of Fedora9?

comment:5 Changed 6 years ago by tompecina

Ok, thanks for the explanation, the only mystery remains why mouse integration worked with previous versions of VBox, up to 1.6.6, and why the kernel module compilation did not fail (unlike in rawhide, where unsupported Xorg version is reported and no kernel module is created). There may be a problem with correct Xorg version detection (technicall, it is still 1.4).

I think everything will work out once Xorg 1.5 is supported.

comment:6 Changed 6 years ago by frank

I still doubt that mouse integration did ever work for you with any older version of VirtualBox. And an unsupported Xorg version does nothing in common with compilation of the kernel modules. The kernel modules (vboxadd and vboxdrv) are compiled in any case and should compile for Linux kernels up to 2.6.27. If the modules do not compile please attach the file /var/log/vboxadd-install.log to this defect.

To get Xorg with all features (dynamic resizing, mouse integration, seamless) working the two Xorg modules vboxmouse and vboxvideo have to be loaded by Xorg. AFAIR this will currently fail for the vboxmouse module because Xorg did some nasty changes and they even added a special case for VMware (which is kind of ugly in my opinion).

So shared folders, time synchronization and probably even the vboxvideo driver should work with Fedora9 but mouse integration will currently not and I'm pretty sure that it did never before with VBox.

comment:7 Changed 6 years ago by tompecina

You may actually be right, I realized that while I use VBox heavily with Win XP, I have been launching Fedora guests mainly for testing purposes and it was primarily in the text mode.

comment:8 Changed 6 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

Mouse integration will work in Fedora 9 guests in the upcoming 2.0.2 service release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use