VirtualBox

Ticket #20694 (closed defect: fixed)

Opened 6 months ago

Last modified 4 months ago

Problems launching VM with VirtualBox > 6.1.26 [fixed in 6.1.32]

Reported by: deckrider Owned by:
Component: VMM Version: VirtualBox 6.1.30
Keywords: VMMR0.r0 SUP_IOCTL_LDR_OPEN VERR_LDR_GENERAL_FAILURE E_FAIL 0x80004005 ConsoleWrap IConsole 872da645-4a9b-1727-bee2-5585105b9eed Cc:
Guest type: Linux Host type: Windows

Description

My 64-bit Ubuntu VM fails to launch with any version greater than VirtualBox 6.1.26. This is from a Windows 10 host:

Failed to open a session for the virtual machine Ubuntu.

Failed to load R0 module C:\Program Files\Oracle\VirtualBox/VMMR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_LDR_GENERAL_FAILURE).

Failed to load VMMR0.r0 (VERR_LDR_GENERAL_FAILURE).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Not sure which Component to select (ConsoleWrap is not in the list), so I chose "VMM" since I see that string in the above error message.

I have run VBoxBugReport.exe and will upload the tgz file it created.

Attachments

2021-11-27-16-10-32-bugreport.tgz Download (312.3 KB) - added by deckrider 6 months ago.

Change History

Changed 6 months ago by deckrider

comment:1 Changed 6 months ago by fth0

The Windows Hypervisor-enforced Code Integrity (HVCI) feature rejects the VirtualBox component VMMR0.r0 (*). A workaround is to disable HVCI aka Memory integrity as follows:

On your Windows host, go to Start > Settings > Update & security > Windows Security > Device security > Core isolation details, turn off Memory integrity and reboot the Windows host.

(*) In the Windows Event Log, under Applications and Service Logs\Microsoft\Windows\CodeIntegrity\Operational, an event with ID 3111 ("The file under validation did not meet the hypervisor-protected code integrity (HVCI) policy.") is logged.

comment:2 Changed 4 months ago by bird

6.1.32 should work better with HVCI. Please check it out.

comment:3 Changed 4 months ago by fth0

I can confirm that the issue is fixed in VirtualBox 6.1.32, BUT:

The performance of VirtualBox 6.1.32 in NEM mode (with Hyper-V), with and without HVCI, has fallen back to the performance of early 6.1.x versions. My Linux and Windows test VMs, which are completely up and running within 30 seconds using VT-x mode (no Hyper-V), now take ~2 (Linux) and ~5 (Windows) minutes to do the same in NEM mode. Especially the Windows VM is unbearably slow afterwards. IIRC, later VirtualBox 6.1.x versions needed 1 minute at max in NEM mode, so the VMs were at least usable.

comment:4 Changed 4 months ago by bird

We had some non-standard optimization that we were forced to drop in order to support both windows 11 and HVCI, but we'll see if can regain that eventually thru other tweaks. Don't hold your breath, though, as it will take some time.

comment:5 Changed 4 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Problems launching VM with VirtualBox > 6.1.26 to Problems launching VM with VirtualBox > 6.1.26 [fixed in 6.1.32]
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use