VirtualBox

Ticket #2066 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

virtualbox-2.0 the start fails with GTK Warning => fixed in 2.0.2

Reported by: Night Train Owned by:
Priority: blocker Component: other
Version: VirtualBox 2.0.0 Keywords: virtualbox2 ubuntu hardy 64 bit
Cc: Guest type: other
Host type: Linux

Description

hi guys

i installed virtualbox-2.0 from repository with synaptic on ubuntu hardy heron 8.04.1 64 bit without mistakes

when run the application I receive the following message:

user@user:~$ VirtualBox

(process:14944): Gtk-WARNING : This process is currently running setuid or setgid. This is not a supported use of GTK+. You must create a helper program instead. For further details, see:

 http://www.gtk.org/setuid.html

Refusing to initialize GTK+.

the previous versions of virtualbox worked correctly

thanks

Night Train

Change History

comment:1 Changed 6 years ago by aeichner

Do you use a QT theme which is using GTK+ to draw the GUI? Try to select another theme.

comment:2 follow-up: ↓ 3 Changed 6 years ago by FuturePilot

I had the same problem. I was using the Qgtkstyle Qt theme which does use GTK to draw. I opened the Qt4 config settings and changed it to Cleanlooks and VirutalBox works now. I hope this can be fixed because I really like the integration of Qgtkstyle.

comment:3 in reply to: ↑ 2 Changed 6 years ago by Night Train

the same for me after to have changed with qt-config

thanks

Night Train

comment:4 Changed 6 years ago by jbache

This is arguably not a bug at all. GTK+ refuses initializing if an application calls any of these functions (see  http://www.gtk.org/setuid.html). QGtkStyle can probably not work around this, but the solution pointed to by the error message is to launch virtualbox using gksudo or a similar tool: 'gksudo VirtualBox" and the app should start up with the correct priviliges removing the need to call setuid at all.

It seems VirtualBox tries to work around this by refusing to start up QGtkStyle at the moment though which seems like a problem however.

comment:5 follow-up: ↓ 6 Changed 6 years ago by jbache

Just a followup as I believe I commented a bit to fast here. ;) I modified QGtkStyle to gracefully fall back to QCleanlooks and print a warning in such cases rather than dumping the GTK+ error directly. A warning will be printed on startup, suggesting that users start the app using 'gksudo', 'kdesudo' or a similar tool.

comment:6 in reply to: ↑ 5 Changed 6 years ago by Night Train

why to use sudo? it would not be better without?

Night Train

comment:7 Changed 6 years ago by poetzsch

  • Summary changed from virtualbox-2.0 the start fails with GTK Warning to virtualbox-2.0 the start fails with GTK Warning => fixed in 2.0.2

comment:8 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use