VirtualBox

Ticket #20536 (closed defect: fixed)

Opened 11 months ago

Last modified 5 months ago

No VM will start on Windows 11 host => fixed in 6.1.28

Reported by: yann64 Owned by:
Component: other Version: VirtualBox 6.1.26
Keywords: Cc:
Guest type: all Host type: Windows

Description

Whatever the type of VM (Linux, OSX, Haiku(Other)), the exact same error happens:

Failed to get device handle and/or partition ID for 0000000001e26210 (hPartitionDevice=0000000000000ca5, Last=0xc0000002/1) (VERR_NEM_VM_CREATE_FAILED).

Code d'erreur : E_FAIL (0x80004005) Composant : ConsoleWrap Interface : IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Change History

comment:1 Changed 11 months ago by scottgus1

Please check out "VERR_NEM_VM_CREATE_FAILED: What do I do?"  https://forums.virtualbox.org/viewtopic.php?f=25&t=97412

comment:2 Changed 11 months ago by Delphi

The issue i had, in this context since after well awaited and beloved update to 22249 pre_release, is the error with the Host-Only Adaptor (Filter Error Message). And after deinstall no reinstall possible, sadly no message on rollback, but probably same issue.

After update with existing VM: VirtualBox Host-Only Ethernet Adapter' (VERR_INTNET_FLT_IF_NOT_FOUND).

Could remove and readd adaptor without error message, but no change.

Last edited 11 months ago by Delphi (previous) (diff)

comment:3 Changed 11 months ago by metalfirefox

Described this issue also in Ticket #20545

comment:4 Changed 11 months ago by Delphi

So acording to that my issue was different, reading #20545 (it is localhost-network and fixed with 6.1.27). As hypervisor off is a prereq anyway afaik to use VirtualBox with it's features and not be restricted further by HyperV.

comment:5 Changed 11 months ago by klaus

As stated in comment:1, the short term workaround for getting the currently available releases of VirtualBox to run on Windows 11 is by disabling Hyper-V/Windows Hypervisor entirely.

We plan to release a maintenance version next month which fixes the root cause (not requiring the workaround any more), and we hope that we will have a test build available at the time Windows 11 is officially released.

This ticket will be updated as further information becomes available.

comment:6 follow-up: ↓ 7 Changed 10 months ago by xpusostomos

I have all the Hyper-V checkboxes under "Turn Windonws features on or off", unchecked (off), and yet I can't install Windows 11, Microsoft has blocked it... regardless that I rarely use virtualbox. So that's screwed up.

comment:7 in reply to: ↑ 6 Changed 10 months ago by bkmeneguello

Replying to xpusostomos:

I have all the Hyper-V checkboxes under "Turn Windonws features on or off", unchecked (off), and yet I can't install Windows 11, Microsoft has blocked it... regardless that I rarely use virtualbox. So that's screwed up.

This should fix your problem:

bcdedit /set hypervisorlaunchtype auto

Version 0, edited 10 months ago by bkmeneguello (next)

comment:8 follow-up: ↓ 9 Changed 10 months ago by Yashii

I got two Virtualbox errors while updating to win11 and they are the same." Your PC requires the latest version of this app". I thought it might be a bug since it's showing two similar errors. Well, Currently I didn't have had use of Virtualbox so I deleted it and out of two only one error got removed. I check my PC for some other version of Virtualbox but it isn't there. And now I am stuck.

comment:9 in reply to: ↑ 8 Changed 10 months ago by sayak

Replying to Yashii:

I got two Virtualbox errors while updating to win11 and they are the same." Your PC requires the latest version of this app". I thought it might be a bug since it's showing two similar errors. Well, Currently I didn't have had use of Virtualbox so I deleted it and out of two only one error got removed. I check my PC for some other version of Virtualbox but it isn't there. And now I am stuck.

Is it possible you have 2 installations of virtualbox? Maybe by chocolatey or something?

comment:10 Changed 10 months ago by mertmurat

Applied all suggested work arounds and disabling hyper both in command prompt and windows settings however still can not start VM. Is there any other suggestions or fixes?

comment:11 Changed 10 months ago by mertmurat

Applied all suggested work arounds and disabling hyper both in command prompt and windows settings however still can not start VM. Is there any other suggestions or fixes?

comment:12 Changed 10 months ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from No VM will start on Windows 11 host to No VM will start on Windows 11 host => fixed in 6.1.28

This incompatibility with the Windows Hypervisor related interface in Windows 11 (host) should be fixed with VirtualBox 6.1.28.

Using the Windows Hypervisor (Hyper-V) is working again. However, the performance is unchanged, i.e. still very noticeably lower than with VirtualBox's own hypervisor code, so it can make sense to disable Hyper-V. You decide.

comment:13 follow-up: ↓ 14 Changed 10 months ago by kaykay96

Hi Team, even after getting the latest version 6.1.128 I am failing to install VirtualBox in windows 11. It keeps giving me this error: Installation failed! Error: Fatal error during installation

comment:14 in reply to: ↑ 13 Changed 10 months ago by supirman

Replying to kaykay96:

Hi Team, even after getting the latest version 6.1.128 I am failing to install VirtualBox in windows 11. It keeps giving me this error: Installation failed! Error: Fatal error during installation

In my case, VBoxUSB.inf installation causes the error. Unselecting the USB Driver installation option should make VirtualBox installation successful.

Last edited 10 months ago by supirman (previous) (diff)

comment:15 Changed 5 months ago by Anton North

Hi, this is in reply to this page that brings you to this bug

 https://support.microsoft.com/en-us/topic/kb5007125-compatibility-hold-when-you-upgrade-to-windows-11-with-oracle-virtualbox-installed-ea84b50c-77f5-473c-99a8-81c2b7b53d35

My problem was that Windows 11 was not letting me install. It kept saying that VirtualBox required the latest app.

Nowhere in my PC was VirtualBox installed. Hyper V was not activated. No online articles helped.

It turns out that LinuxLive USB creator was the problem.  https://www.linuxliveusb.com/

It uses VirtualBox but is NOT obvious. Hopefully this will help someone else who can't figure out why they get a VirtualBox error when it is not installed. I'm sure it is a corner case. But it was frustrating.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use