VirtualBox

Ticket #205 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Slash and question mark not working on ABNT2 keyboard on Linux

Reported by: KhaoticMind Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.8 Keywords: abnt2 linux
Cc: Guest type: other
Host type: other

Description

I've an Brazilian ABNT2 keyboard and it works flawlessly on my Kubuntu 6.10 system. But when i to launch a VM with the VirtualBox or the VBoxSDL front ends i can't use the "/?"(slash question) key. I works ok if I use remote conection (RDP).

I've checked bug #2 and tried to copy a keyboard.c from wine 0.9.33 to replace src/VBox/Frontends/VirtualBox/src/linux/keyboard.c and recompile the source, but it still doesn't work.

Change History

comment:1 Changed 7 years ago by michael

If you feel comfortable with building VirtualBox yourself, try checking out the current SVN snapshot, which should support that key. I just checked up the documentation for Brazilian keyboards, and the current SVN will probably not support the keypad "." key on your keyboard. I have checked in a fix for the last issue which should be in the OSE SVN repository by tomorrow.

comment:2 Changed 7 years ago by KhaoticMind

Yeap! Fixed on last SVN. Works like a charm ;) All the keypad keys are working all right as well :)

Thanks!

comment:3 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use