VirtualBox

Ticket #20395 (new defect)

Opened 6 months ago

Centos 7 i386 causes serious malfunctions when booted with ncpus>1

Reported by: rincebrain Owned by:
Component: other Version: VirtualBox 6.1.22
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

I had occasion to try testing something on CentOS 7 i386. So I fetched CentOS-7-i386-NetInstall-2009.iso, and tried booting it on my Win10 host running VB 6.1.22, and strange behavior ensued. So I tried a premade 7 2009 image, which did the same, and a premade 7 2003 image, which did either the same thing or aborted.

First, it flooded with BUG: Bad page state in process swapper. Then, after a bit, the strangest behavior ensued - it started pegging multiple cores on the host, attempting to do anything with the VM window or other VB windows became infeasible (I needed to use Task Manager to kill the VM ultimately, the times it didn't abort and crash on its own) and my Caps Lock light started oscillating furiously, which continues even if it ultimately gets into the graphical login screen.

Running with n=1 cores, it seems to work fine.

Since Debian buster i386 works fine on this host, it's not impossible for it to be a flaw in what CentOS 7 is doing, but if it works on real hardware, then not working in a VM still seems like a flaw in the VM?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use