VirtualBox

Ticket #20165 (closed defect: duplicate)

Opened 20 months ago

Last modified 16 months ago

WIndows 10 VM crashes with BSOD after Linux kernel upgrade

Reported by: garcia556 Owned by:
Component: other Version: VirtualBox 6.1.16
Keywords: Cc:
Guest type: other Host type: other

Description

After starting Windows 10 VM in a few minutes it crashes and restarts. The issue started to happen after upgrading kernel from 5.4 to 5.8 on Ubuntu 20.04.

Host OS + kernel info:

VERSION="20.04.1 LTS (Focal Fossa)"
5.8.0-41-generic #46~20.04.1-Ubuntu SMP Mon Jan 18 17:52:23 UTC 2021 x86_64

VirtualBox is 6.1.16, it is is installed via Ubuntu-located package, not the Oracle one:

VBoxManage -v
6.1.16_Ubuntur140961

Ubuntu kernel package version is 5.8.0-41.

This issue is not present on 5.4 kernel package which is 5.4.0-65. It's not big deal to switch back to 5.4 however I've seen similar issue on Ubuntu 20.10 there 5.8 is default kernel.

Exact log error message is the following:

00:04:24.806578 GIM: HyperV: Guest indicates a fatal condition! P0=0x1e P1=0xffffffff80000002 P2=0xfffff800046ff793 P3=0xffffa4048810213e P4=0x7010008004002001
00:04:24.806776 GIMHv: BugCheck 1e {ffffffff80000002, fffff800046ff793, ffffa4048810213e, 7010008004002001}
00:04:24.806778 KMODE_EXCEPTION_NOT_HANDLED
00:04:24.806778 P1: ffffffff80000002 - exception code - STATUS_DATATYPE_MISALIGNMENT
00:04:24.806779 P2: fffff800046ff793 - EIP/RIP
00:04:24.806779 P3: ffffa4048810213e - Xcpt param #0
00:04:24.806780 P4: 7010008004002001 - Xcpt param #1
00:04:28.341712 VMMDev: vmmDevHeartbeatFlatlinedTimer: Guest seems to be unresponsive. Last heartbeat received 4 seconds ago
00:04:31.947777 AHCI#0: Reset the HBA
00:04:31.947820 VD#0: Cancelling all active requests
00:04:31.948373 AHCI#0: Port 0 reset
00:04:31.949421 VD#0: Cancelling all active requests
00:04:42.427919 VMMDev: Guest Log: VBoxGuest: BugCheck! P0=0x1e P1=0xffffffff80000002 P2=0xfffff800046ff793 P3=0xffffa4048810213e P4=0x7010008004002001
00:04:42.428206 GIM: HyperV: Reset initiated through MSR
00:04:42.428260 Changing the VM state from 'RUNNING' to 'RESETTING'

This is a known issue for such kernel and VirtualBox version setup:  https://forums.virtualbox.org/viewtopic.php?f=7&t=99789  https://forums.virtualbox.org/viewtopic.php?f=2&t=99028  https://forums.virtualbox.org/viewtopic.php?f=7&t=101353

Ther error itself is Windows-related, it is basically a BSOD. But it is obviously related to host environment change.

Attachments

vbox_crash.log Download (178.2 KB) - added by garcia556 20 months ago.
crash log

Change History

Changed 20 months ago by garcia556

crash log

comment:1 Changed 20 months ago by hottobar

Testing an otherwise crashing VM on a AMD Ryzen 9 3900X based system instead of an Intel i5-1135G7 based one won't cause this exception.

See this forum thread:  https://forums.virtualbox.org/viewtopic.php?f=7&t=101667

comment:2 Changed 17 months ago by LievenV

I have the same problem with VirtualBox running on openSUSE 15.2 after a kernel update from 5.3.18 to 5.12.2. I have tried different VirtualBox versions (currently 6.1.22), but there are always crashes and restarts of Windows 10 VM after some minutes.

VBox.log gives this:

00:02:11.951435 GIM: HyperV: Guest indicates a fatal condition! P0=0x1e P1=0xffffffff80000002 P2=0xfffff8046720b69e 
P3=0x97490daf P4=0x0
00:02:11.951536 GIMHv: BugCheck 1e {ffffffff80000002, fffff8046720b69e, 97490daf, 0}
00:02:11.951537 KMODE_EXCEPTION_NOT_HANDLED
00:02:11.951537 P1: ffffffff80000002 - exception code - STATUS_DATATYPE_MISALIGNMENT
00:02:11.951537 P2: fffff8046720b69e - EIP/RIP
00:02:11.951537 P3: 0000000097490daf - Xcpt param #0
00:02:11.951538 P4: 0000000000000000 - Xcpt param #1
Last edited 17 months ago by LievenV (previous) (diff)

comment:3 Changed 16 months ago by klaus

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #20180 (I know this ticket is older but the other has more useful information including the workaround).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use