VirtualBox

Ticket #2010 (closed defect: worksforme)

Opened 6 years ago

Last modified 5 years ago

Linux kernel v2.6.21 built by myself cannot boot up correctly in the VirtualBox

Reported by: riker Owned by:
Priority: major Component: VMM
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I built a linux system from Linux kernel source v2.6.21 and run it inside the virtual macine of VirtualBox. I found it is failed to boot up in some conditions.

1). In AMD platform with AMD-V enable and the host operating system is Windows SP3, the VM is successful to boot up. Please refer the VBox_Log_01.txt

2). In AMD platform with AMD-V disable and the host operating system is Windows SP3, the VM is failed to boot up. Please refer the VBox_Log_02.txt

3). In Intel platform (P4) and the host operating system is Windows SP3, the VM is failed to boot up. Please refer the VBox_Log_03.txt

Why is the root cause of above issue? Is any configuration incorrect in the Linux kernel configuration? How and what kernel configuration is required to change for this? Thanks!

Attachments

VBox_Log_01.txt Download (45.7 KB) - added by riker 6 years ago.
VBox_Log_02.txt Download (44.6 KB) - added by riker 6 years ago.
VBox_Log_03.txt Download (36.2 KB) - added by riker 6 years ago.

Change History

Changed 6 years ago by riker

Changed 6 years ago by riker

Changed 6 years ago by riker

comment:1 Changed 6 years ago by riker

One more information to share. I run the same VM by QEMU and VMWare. Both of them could execute the VM successfully.

comment:2 Changed 6 years ago by frank

  • Component changed from other to VMM

Can you explain failed to boot better? If you only see a black window you probably have a framebuffer enabled. In that case, disable the framebuffer by removing the vga= parameter as well as splash quiet parameters from the kernel command line and to be able to see the last kernel messages.

comment:3 Changed 6 years ago by riker

After displaying the message, "Umcompressing Linux ... OK, booting the kernel", the VM is freezed.

comment:4 Changed 6 years ago by frank

Could you post your kernel command line please?

comment:5 Changed 6 years ago by riker

First, the kernel command line of GRUB is "kernel /boot/bzImage root=/dev/hda1 ro". Secondly, the next message of "Uncompressing Linux ... OK, booting the kernel" is "initializing container subsys cpu". This is got by QEMU to run the same VM. So, the VM seems to be freezed during above two messages. I hope this is helpful for identifying the problem.

comment:6 Changed 6 years ago by riker

Today, I found that the kenerl image could be executed successfully when I build the kernel without CGL feature. I will try to make some tries to evaluate the difference of kerenl parameter and let share the information to improve Virtualbox soon.

comment:7 Changed 6 years ago by frank

Which kernel config option is that in detail?

comment:8 Changed 6 years ago by riker

After long-term tests, I found that the problem would be happened when configuring the kernel with CONFIG_PREEMPT_HARDIRQS=y and without CONFIG_COMPAT_VDS0.

CONFIG_PREEMPT_HARDIRQS=y # CONFIG_COMPAT_VDS0 is not set

Others are kept as the default. If I change the kernel parameters as below

# CONFIG_PREEMPT_HARDIRQS is not set CONFIG_COMPAT_VDS0=y

The created kernel could be executed successfully in Virtualbox. Because the original kernel is no problem for VMWare and QEMU. So, I hope to share this information to improve Virtualbox better. Thanks a lot.

comment:9 Changed 6 years ago by riker

The previous message is not well formated.

For the failed case, the configuration is shown as below.

CONFIG_PREEMPT_HARDIRQS=y
# CONFIG_COMPAT_VDS0 is not set

For the success case, the configuration is shown as below.

# CONFIG_PREEMPT_HARDIRQS is not set
CONFIG_COMPAT_VDS0=y

comment:10 Changed 6 years ago by frank

Thank you for this information!

comment:11 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

I guess the problem is not relevant anymore.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use