VirtualBox

Ticket #20 (closed enhancement: wontfix)

Opened 7 years ago

Last modified 14 months ago

[feature-request] Win9x (95/98/98SE/Me) support as Guest OS

Reported by: Technologov Owned by:
Priority: minor Component: other
Version: VirtualBox 1.3.2 Keywords:
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

Please support Win9x as a guestOS (primarily 98 is needed).

Plz do so for the folowing reasons:

a) Those OSes are still widely used b) Virtualization software (such as this) is heavily used for software QA purposes of backward-compatibility. Win9x is a supported platform for large number of software (both commercial and OSS), so it cut costs considerably. This is very big market that both VMware and VirtualPC supports well. c) It's still needed by legacy software that cannot be run on newer OSes that isn't updated anymore. d) For Windows-networks simulation, Win9x has lower memory and CPU requirements. This also helps if you have not-so-powerful host. e) help desks - consumer support for Win9x is still a requirement for many corporations and ISPs. Virtualization really helps here.

Currently, it installs, but fails to run, in both normal and safe modes it crashes on first boot. I would like to see this issues resolved, and later see Guest OS integration for Win9x.

Change History

comment:1 follow-up: ↓ 3 Changed 7 years ago by Technologov

In middle of Win98 setup screen goes black. Also the setup goes VERY SLOW (over 2 hours).

-Alexey Eremenko

comment:2 Changed 7 years ago by sandervl73

  • Priority changed from major to minor

comment:3 in reply to: ↑ 1 Changed 7 years ago by MPvDdB

Replying to Technologov:

In middle of Win98 setup screen goes black.

Screensaver kicking in?

I did not have a problem installing it:

  • W98 SE guest on host SimplyMepis32 6.5 which is related to Ubuntu 6.06 LTS with Linux 2.6.15-27 headers
  • Also the setup goes VERY SLOW (over 2 hours).

I agree there

(did the install from the W98 SE CD with the hardware CD/DVD of this laptop mounted)

After first boot I found W98 guest really slow too.

But that changed after I had given the VBox 256 MB of RAM and 16 MB of VRAM instead of the defaults. These defaults (filled in automatically when I created the VBox settings with 64 MB RAM and 8 MB VRAM respectively may be choosen to <g> "conservative" and cause a lot of swapping in the VBox Win98 I suppose).

kindest regards from Leeuwarden, NL Peter van Dobben de Bruijn

comment:4 Changed 7 years ago by Technologov

In middle of Win98 setup screen goes black.

Screensaver kicking in?

Not sure about this one, but it doesn't happens on other emulators and real hardware.

Also 32 MB of RAM with 4 MB of VRAM is more than enough for Win98. Real Pentium2 with 32 RAM can run Win98 VERY quickly. So the problem is VBox, and not amount of RAM.

comment:5 Changed 7 years ago by MPvDdB

That the screensaver is not kicking in during install on other emulators and real hardware does not mean that it does not here. You complained about the very long and slow install. I noted long pauses where nothing appeared to be happening. Typically a situation a screensaver would kick in, if those other installs continuously work you would never see this.

About the RAM-requirements of Win98:

 http://support.microsoft.com/kb/182751/ l

According to Microsoft 16 MB is the minimum 24 MB recommended (<g> ever tried that?).

But that is not the point I made. What I experienced was alike you did very slow setup and also slow when I booted it. Until I moved the standard allocated memory (alotted to it by the VBox setup for Windows 98 - thus double what you mention) up to 256 MB (of this 512 MB laptop). Then this slowness imediately disappeared. i would also guess that a VBox Guest Windows 98 operates differently than a Windows 98 on a bare metal PC.

kindest regards from Leeuwarden, NL Peter van Dobben de Bruijn

comment:6 Changed 6 years ago by RobD

Please do support Win98, a reason to use Virtual Box is for old programs, some of which were written badly, and have conflicting dll needs (well all Windows is bad but *shrug*). I have some that won't run in Wine, they seem to track more modern software now, so virtualisation is very useful. No need to worry about drivers etc.

The alternative is to keep an old box around, and pray that it doesn't have hardware failure. It is also nice to have a low memory, low power solution.

BTW - I installed Win98SE, I found with 96MB I had screen crash, 128MB install completed. Have seen the "screen" display crash effect in another old fullscreen program, where I'd previously installed it.

Once Rain20 is installed the CPU utilisation is very low, I saw much higher with Debian Etch as guest OS, with 250 Hz kernel.

comment:7 Changed 6 years ago by frank

  • Guest type changed from other to Windows

comment:8 Changed 6 years ago by sh3rbs

Another plea for better support for Windows 9x. Installation is very slow and the stability is not good. Desperate need for additions for 9x as well.

comment:9 Changed 5 years ago by TiBeN

me too, wait for support of win98 for a long time. I really don't understand why WinXP run so nicely but not win98. Win98 is unusable. I understand that you have betters things to do, but please program this feature request in your tasklist. i'm sure a lot of people are waiting for it!! it's no logical that a so good virtualizing program that virtualbox is, has not a good support for this major serie of Operating system used by million of persons only 10 years ago and less. sorry about my poor english.

comment:10 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix
  • Description modified (diff)

There is just too much effort for too little benefit to support these old legacy operating systems.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use