Opened 3 years ago

Last modified 3 years ago

#19989 new defect

VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64.rpm does not install on Fedora 33

Reported by: Didier Owned by:
Component: installer Version: VirtualBox 6.1.16
Keywords: Cc:
Guest type: Linux Host type: Linux


VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64.rpm does not install on Fedora 33 with following error:

Erreur :

Problème: conflicting requests

  • nothing provides python(abi) = 3.8 needed by VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64

Test build installs and works fine on Fedora 33.

Change History (13)

comment:1 by Didier, 3 years ago

Fedora 33 Python3 version is python3-3.9.0-1.fc33.x86_64.

Same problem like with previous Fedora 32:

comment:2 by Andre Robatino, 3 years ago

The stable build in works fine as well.

in reply to:  2 comment:3 by Didier, 3 years ago

Replying to robatino:

The stable build in works fine as well.

I agree, problem is with require spec in rpm.

comment:4 by tazxsk, 3 years ago

I'd be interested in a dev build once this is sorted, I will use .run file till then. @fbatschu will you fix this?

tia Lubos

comment:5 by Didier, 3 years ago

Just for fun I just rebuilt my own working rpm for Fedora 33:

  • I installed the rpmrebuild package
  • I downloaded VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64.rpm
  • Using rpmrebuild, I edited the spec file included in VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64.rpm
  • In this spec file I replaced the line

Requires: python(abi) = 3.8 with Requires: python(abi) >= 3.8

It's all and now my own rpm works like a charm on Fedora 33 !

comment:6 by nixuser, 3 years ago

For people wanting to try the above, the command is:

rpmrebuild --edit-spec --package VirtualBox-6.1-6.1.16_140961_fedora32-1.x86_64.rpm

Which puts you in vi where you can make the edits.

Note Python2 is required.

The new RPM ends up in ~/rpmbuild/RPMS/x86_64/

comment:7 by jj, 3 years ago

Today 6.1.18 was realeased, but still not for Fedora 33 and still not for python > 3.8. With the help of the command rpmrebuild as mentioned above, I got it installed

looks like it runs fine now on Fedora 33

Please solve this "bug".

comment:8 by Klaus Espenlaub, 3 years ago

The initial version of a VirtualBox package for Fedora33 (effectively a test build, has seen limited testing...) is available at

The package has few changes relative to VirtualBox 6.1.18, and should work just fine in combination with the extension pack version 6.1.18.

It will eventually expire (in around 6 weeks from now IIRC), and we'll either provide an updated package or (if someone finds enough time) try to integrate some useful package into the repository.

comment:9 by ngrennan, 3 years ago

The 6.1.19 Fedora 33 rpm above installs and runs properly. My new blocker is I need a link to the 6.1.19 USB extpack.


comment:10 by ngrennan, 3 years ago

Nevermind. I found the link here.

Edit: Technically 142474 is a newer build than 142299, but it seems to work.

Last edited 3 years ago by ngrennan (previous) (diff)

comment:11 by Klaus Espenlaub, 3 years ago

Do you really need an extpack reporting version 6.1.19? That sounds very wrong. Version 6.1.18 from should work just fine.

comment:12 by ngrennan, 3 years ago

I had 6.1.18 Virtualbox installed with 6.1.18 extpack. I upgraded to 6.1.19 and maybe I just needed to reinstall the 6.1.18 extpack. But if that was the case, why did it not just keep the 6.1.18 extpack that I had before?

comment:13 by Klaus Espenlaub, 3 years ago

A bit difficult to tell from the distance without having all details clearly stated.

The extpack should stay where it is when the base package is reinstalled, as long as you stick to a certain package type.

This means if you used the 6.1.18 generic VirtualBox installer (which puts everything under /opt/VirtualBox) then the extension pack will be installed there. The RPM package expects (and puts) it under /usr/lib/virtualbox.

So that's probably the explanation why the extpack "disappeared". I suspect the originally installed extpack is still under /opt/VirtualBox. You could delete it (needs root privs) since it wouldn't be used by VirtualBox installed and updated using RPM packages.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use