VirtualBox

Ticket #19854 (closed defect: fixed)

Opened 13 months ago

Last modified 5 months ago

VM lockup when serial port is enabled in file mode to /dev/null

Reported by: Thomas Dreibholz Owned by:
Component: uart Version: VirtualBox 6.1.10
Keywords: UART, VM lock-up Cc:
Guest type: other Host type: other

Description

My VM has COM1 enabled, with data to file "/dev/null". It boots the RELEASE-12.1 FreeBSD installer CD (i.e.  https://download.freebsd.org/ftp/releases/ISO-IMAGES/12.1/FreeBSD-12.1-RELEASE-amd64-disc1.iso). The VM locks up during boot, with high CPU utilisation. Turning the COM1 port off, everything is okay.

Using a file (e.g. /tmp/test1.txt) for output of COM1 works as well.

Attachments

FreeBSD-VM.config Download (3.3 KB) - added by Thomas Dreibholz 13 months ago.
Output of "vboxmanage showvminfo -machinereadable" for the VM
Ubuntu-VM.config Download (3.4 KB) - added by Thomas Dreibholz 13 months ago.
Configuration of the Ubuntu VM

Change History

Changed 13 months ago by Thomas Dreibholz

Output of "vboxmanage showvminfo -machinereadable" for the VM

comment:1 Changed 13 months ago by Thomas Dreibholz

With some more testing, I got a reproducible scenario where the VirtualBox process locks up (not just the VM), i.e. the GUI is not reacting any more:

  • COM1 in VM configuration: enabled, but disconnected
  • Booting of a Ubuntu 20.04 VM, with additional kernel cmdline parameters: console=tty0 console=ttyS0,115200n8 (the idea is to have a normal console, as well as an additional console over COM1)
  • VM locks up during boot
  • Forcing VirtualBox to reset the VM via the VM's GUI
  • The VirtualBox GUI locks up as well

comment:2 Changed 13 months ago by Thomas Dreibholz

Note, I am using VirtualBox Version 6.1.12 r139181 (Qt5.12.8), i.e. the latest version from the  https://www.virtualbox.org website.

Version 0, edited 13 months ago by Thomas Dreibholz (next)

Changed 13 months ago by Thomas Dreibholz

Configuration of the Ubuntu VM

comment:3 Changed 12 months ago by aeichner

Not reproducible here, please try the latest 6.1 testbuild from Testbuilds, it contains some serial fixes. Please attach a VBox.log of the affected VM in case it still is reproducible.

comment:4 Changed 8 months ago by MWutzke

I am seeing similar lockups when using the 'Serial Port' option 'enabled ; disconnected'.

The key to the reproduction is that the issue is only seen when using 2 or more vCPU's for the VirtualBox machine instance. Using a single vCPU, the issue is not observed.

This issue is observed with a custom Linux kernel we generate, but I have also been able to reproduce it with the Ubuntu 20.10 live-server ISO as well when using either of these 2 kernel options:

  • linux /casper/vmlinuz console=ttyS0,115200 console=tty1,0 --
  • linux /casper/vmlinuz console=tty1,0 console=ttyS0,115200 --

When using the first option, the lockup occurs (generally) once the initial Language selection dialog occurs on the VGA. I suspect this is the same time that the user is prompted to select the interface style on the (disconnected) serial port.

I have reproduced this issue with on both Windows10 and Ubuntu 20.04 hosts as follows:

  • Windows 10 host: VirtualBox 2.1.16, 2.1.18
  • Ubuntu 20.04 host: VirtualBox 2.1.10, 2.1.19 (testing 142299)

Using the same machine with VirtualBox 5.2 or 6.0.24, and multiple vCPU's, the issue is not observed.

In addition to the VirtualBoxVM lockup, when using the VirtualBox VM debugger, the debugger locks up as well, and becomes unresponsive.

Last edited 8 months ago by MWutzke (previous) (diff)

comment:5 Changed 7 months ago by aeichner

The lock up in disconnected mode should be fixed in the next maintenance release. You can try the latest testbuild from here.

comment:6 Changed 7 months ago by MWutzke

I've just tried 6.1.19-142777-Linux_amd64, and my initial testing shows that this is resolved. Thanks for addressing this.

comment:7 Changed 5 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use