VirtualBox

Ticket #1979 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Restore Snapshot fails (VERR_SSM_LOAD_CONFIG_MISMATCH)

Reported by: user2304 Owned by:
Priority: major Component: other
Version: VirtualBox 1.6.4 Keywords: snapshot
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Restoring an WinXP SP3 guest snapshot fails:

Unable to restore the virtual machine's saved state
  from '/home/user/.VirtualBox/Machines/WinXP/Snapshots/{092dd3e2-b03e-4632-0cae-783b1981d2d2}.sav'. 
  It may be damaged or from an older version of VirtualBox. Please discard the saved state before
  starting the virtual machine.
VBox status code: -1825 (VERR_SSM_LOAD_CONFIG_MISMATCH).

Fehlercode: 0x80004005
Komponente: Console
Interface:  IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

Host is opensuse 11.0

Regards, User2304

Attachments

VBox.log Download (41.9 KB) - added by user2304 6 years ago.
Logfile
VBox.log.1 Download (39.7 KB) - added by bismark 6 years ago.
Startup from Clean State and Suspend
VBox.2.log Download (37.9 KB) - added by bismark 6 years ago.
Attempt to resume suspend VM
VBox.log.SAVE Download (9.7 KB) - added by Nao 6 years ago.
Saving state. (PCnet-FAST III enabled)
VBox.log.RESTORE Download (37.7 KB) - added by Nao 6 years ago.
Restoring state. (PCnet-FAST III enabled) (restore fails with subj error)
Venda.xml Download (28.7 KB) - added by Nao 6 years ago.
Config of VM after fail

Change History

Changed 6 years ago by user2304

Logfile

comment:1 Changed 6 years ago by frank

Which version of VBox created the snapshot?

comment:2 Changed 6 years ago by user2304

Update:

Using "Machine" > "Close..." and the option "Power off the machine + Revert to the current snapshot" seems to work, so i can restore at least the last snapshot.

It seems, that the problem just occurs with a powered-off machine and using the functions of the "Snapshot"-tab in the main-menu.

user2304

comment:3 Changed 6 years ago by user2304

@Frank:

Version 1.6.4

comment:4 Changed 6 years ago by bismark

I'm experiencing the same issue. Version 1.6.4 /w Guest Additions 1.6.0. I have attached two log files, one (Vbox.log.1) from the boot up from a clean state to suspending the machine, the second (VBox.log) from the failed restore of the suspending machine.

Changed 6 years ago by bismark

Startup from Clean State and Suspend

Changed 6 years ago by bismark

Attempt to resume suspend VM

comment:5 in reply to: ↑ description Changed 6 years ago by Nao

Same error with 1.6.6

comment:6 Changed 6 years ago by Nao

For me, error happens only if enabled "PCnet-FAST III" Network adapter. "PCnet-PCI II" works fine.

Changed 6 years ago by Nao

Saving state. (PCnet-FAST III enabled)

Changed 6 years ago by Nao

Restoring state. (PCnet-FAST III enabled) (restore fails with subj error)

Changed 6 years ago by Nao

Config of VM after fail

comment:7 Changed 6 years ago by ssawyer

Same problem with VBox 2.0 -- guest WinXP SP3; Host OS X 10.5.5

Goes away if I switch the card to PCnet-PCI II.

comment:8 Changed 6 years ago by frank

  • Description modified (diff)

comment:9 follow-up: ↓ 10 Changed 6 years ago by frank

ssawyer, this works fine here. Are you sure that only the type of the network card is responsible for triggering this bug? Could you try again using as few VM devices as possible (no sound, no shared folders and so on), only the network device to set to PCNet-Fast III or to PCNet-PCI II respectively to make 100% it is the network type. And please attach a VBox.log file from a missing restore as well.

Thank you!

comment:10 in reply to: ↑ 9 Changed 6 years ago by Nao

Replying to frank:

ssawyer, this works fine here. Are you sure that only the type of the network card is responsible for triggering this bug? Could you try again using as few VM devices as possible (no sound, no shared folders and so on), only the network device to set to PCNet-Fast III or to PCNet-PCI II respectively to make 100% it is the network type. And please attach a VBox.log file from a missing restore as well.

Thank you!

In my installation (Host:Linux 2.6.25, Guest:Windows XP SP2) bug occurs only if I change network card type to "PCNet-Fast III". I turned off all other devices and only changing network card type made sense.

comment:11 follow-up: ↓ 12 Changed 6 years ago by frank

Nao: Ok. And how easy can you reproduce the bug? Does it happen every time? Does it happen if you terminate the VM by saving the state and restore from this state later? I saw you are using the OSE version of VirtualBox 1.6.6. Did you compile the sources yourself or do you use some precompiled binary from a Linux distribution?

comment:12 in reply to: ↑ 11 Changed 6 years ago by Nao

Replying to frank:

Nao: Ok. And how easy can you reproduce the bug? Does it happen every time?

For virtualbox-ose-1.6.2 it happed every time. If I saved state and restored it immediately or later. When I upgrade to version 1.6.6, the bug still here.

Does it happen if you terminate the VM by saving the state and restore from this state later?

Yes. But not only. If I create snapshot and restore it - same error occurs. Then the "discard" button is only way to start VM.

I saw you are using the OSE version of VirtualBox 1.6.6. Did you compile the sources yourself or do you use some precompiled binary from a Linux distribution?

I comiled sources by myself. I use Gentoo distribution. I can install binary version of virtualbox-ose and test it too, but I think nothing will change.

comment:13 follow-up: ↓ 14 Changed 6 years ago by frank

Tested the 1.6.6 OSE version here as well, works. Please could you indeed check the PUEL version. And please make sure you started from a clean VM (that is, no snapshots).

comment:14 in reply to: ↑ 13 Changed 6 years ago by Nao

Replying to frank:

Tested the 1.6.6 OSE version here as well, works. Please could you indeed check the PUEL version. And please make sure you started from a clean VM (that is, no snapshots).

Bug don`t appears in 1.6.6 OSE and PUEL with new installation of Windows XP SP3.

My experiments with old "buggy" VM (XP SP2 guest):

  1. Discard all snapshots from VM
  2. Delete machine.
  3. Create new machine (with OSE) and attach old disk. Bug still here.
  4. Do all above steps with PUEL version. Bug still here.

I will try to install SP2 if I find it somewhere.

comment:15 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Ok, thank you for the experiment. This really sounds like a duplicate of #1887.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use