VirtualBox

Ticket #1938 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

invalid opcode (vmptrld) since 1.6.0

Reported by: walkerd Owned by:
Priority: major Component: VMM/HWACCM
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Since 1.6 was introduce there is bug which cause crash of vbox on linux if host system went in to standby mode. After resume:

Aug  9 11:06:10 opahapaka kernel: invalid opcode: 0000 [#3] PREEMPT SMP 
Aug  9 11:06:10 opahapaka kernel: Modules linked in: vboxdrv tun hci_usb iwl4965 snd_pcm_oss snd_mixer_oss snd_hda_intel
snd_usb_audio snd_pcm snd_timer snd_usb_lib snd_rawmidi snd_seq_device snd_hwdep snd soundcore snd_page_alloc mmc_block
cdc_acm usbhid usbkbd xfs usb_storage rfcomm l2cap uinput bluetooth arc4 ecb crypto_blkcipher cryptomgr crypto_algapi
nvidia(P) nvidiafb iwlcore pcmcia fb_ddc i2c_algo_bit sdhci i2c_i801 vgastate pcspkr uhci_hcd ohci1394 mac80211
ehci_hcd psmouse mmc_core ieee1394 yenta_socket rsrc_nonstatic pcmcia_core usbcore e1000 i2c_core cfg80211 [last unloaded: vboxdrv]
Aug  9 11:06:10 opahapaka kernel: 
Aug  9 11:06:10 opahapaka kernel: Pid: 16497, comm: VirtualBox Tainted: P  R   D  (2.6.25.10 #1)
Aug  9 11:06:10 opahapaka kernel: EIP: 0060:[<f8d3146a>] EFLAGS: 00210046 CPU: 0
Aug  9 11:06:10 opahapaka kernel: EIP is at 0xf8d3146a
Aug  9 11:06:10 opahapaka kernel: EAX: 00000000 EBX: 00000000 ECX: 2d06f000 EDX: 00000000
Aug  9 11:06:10 opahapaka kernel: ESI: 00000000 EDI: f8d85000 EBP: ecdf7ed0 ESP: ecdf7ebc
Aug  9 11:06:10 opahapaka kernel:  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Aug  9 11:06:10 opahapaka kernel: Process VirtualBox (pid: 16497, ti=ecdf6000 task=f0fbe570 task.ti=ecdf6000)
Aug  9 11:06:10 opahapaka kernel: Stack: 2d06f000 00000000 00000000 f8d85000 00200246 ecdf7f00 f8d2b3ca f8d85000 
Aug  9 11:06:10 opahapaka kernel:        f8d7bce0 c0285609 f12a4190 f8d17fa8 f8d85000 00000006 f8d859c0 f8d15110 
Aug  9 11:06:10 opahapaka kernel:        f8d85000 ecdf7f20 f8d32ebb f8d85000 00200282 f8d188ee f8d15110 f2a28800 
Aug  9 11:06:10 opahapaka kernel: Call Trace:
Aug  9 11:06:10 opahapaka kernel:  [<c0285609>] redo_fd_request+0x904/0xdb8
Aug  9 11:06:10 opahapaka kernel:  [<f8d17fa8>] supdrvIOCtl+0xe6e/0x12a2 [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d15110>] VBoxDrvLinuxIOCtl+0x0/0x15f [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d188ee>] rtMemAlloc+0x29/0x47 [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d15110>] VBoxDrvLinuxIOCtl+0x0/0x15f [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d156fb>] supdrvIOCtlFast+0x3f/0x4a [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d1513d>] VBoxDrvLinuxIOCtl+0x2d/0x15f [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<f8d15110>] VBoxDrvLinuxIOCtl+0x0/0x15f [vboxdrv]
Aug  9 11:06:10 opahapaka kernel:  [<c01697f8>] vfs_ioctl+0x1c/0x5f
Aug  9 11:06:10 opahapaka kernel:  [<c0169a6a>] do_vfs_ioctl+0x22f/0x241
Aug  9 11:06:10 opahapaka kernel:  [<c0131575>] do_gettimeofday+0xf/0x29
Aug  9 11:06:10 opahapaka kernel:  [<c0169aa8>] sys_ioctl+0x2c/0x44
Aug  9 11:06:10 opahapaka kernel:  [<c0103c76>] sysenter_past_esp+0x5f/0x85
Aug  9 11:06:10 opahapaka kernel:  =======================
Aug  9 11:06:10 opahapaka kernel: Code: 75 11 89 f0 8b 1c 24 8b 74 24 04 8b 7c 24 08 89 ec 5d c3 8b 9f 48 e0 00 00
31 f6 8b 8f 44 e0 00 00 89 da 89 c8 89 d0 31 d2 50 51 <0f> c7 34 24 73 05 be 5f f0 ff ff 83 c4 08 85 f6 78 c5 31 f6 c6 
Aug  9 11:06:10 opahapaka kernel: EIP: [<f8d3146a>] 0xf8d3146a SS:ESP 0068:ecdf7ebc
Aug  9 11:06:10 opahapaka kernel: ---[ end trace 68831b3a78f1d3e7 ]---
Aug  9 11:06:10 opahapaka kernel: done.

In 1.5.6 it is stable.

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by frank

  • Description modified (diff)
  • Summary changed from invalid opcode: 0000 1.6.4, 1.6.2, 1.6.0 to invalid opcode (vmptrld) since 1.6.0

To be completely sure: Starting/stopping VBox sessions work fine as long you don't suspend/resume the host system? And when you start a VM after host resume you get the above error reproducible? Or do you try to suspend/resume while a VM is running?

comment:2 in reply to: ↑ 1 Changed 6 years ago by walkerd

Replying to frank:

To be completely sure: Starting/stopping VBox sessions work fine as long you don't suspend/resume the host system? And when you start a VM after host resume you get the above error reproducible? Or do you try to suspend/resume while a VM is running?

I try it whine VM is running. In 1.5.6 it was without problem. In 1.6.0 I observed the same problem also when VM was sleeping. With 1.6.4 I haven't try with sleeping VM. And now I am already back on 1.5.6.

comment:3 Changed 6 years ago by frank

Oh, so this is actually a duplicate of #1567, right?

comment:4 follow-up: ↓ 5 Changed 6 years ago by frank

You activated VT-x for that VM. I doubt that this worked for 1.5.6, at least not suspend+resume while VT-x is active. Actually the error code means that the VMX root mode is not enabled.

comment:5 in reply to: ↑ 4 Changed 6 years ago by walkerd

VT-x is enabled all the time. I am now again on 1.5.6, VT-x is active and it works. Without problems. I am using the same configuration for 1.5 and 1.6.

comment:6 follow-up: ↓ 7 Changed 6 years ago by frank

Can you attach a VBox.log file of 1.5.6, just to make sure that VT-x is actually enabled for this session? Note that even if you enable VT-x for session it is not 100% sure that VT-x support is actually used.

comment:7 in reply to: ↑ 6 Changed 6 years ago by walkerd

comment:8 follow-up: ↓ 9 Changed 6 years ago by frank

Ok, you convinced me :)

comment:9 in reply to: ↑ 8 Changed 6 years ago by walkerd

Thank you, I started to have doubts about myself :)

comment:10 Changed 6 years ago by frank

  • Component changed from other to VMM/HWACCM

comment:11 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #1660 .

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use