VirtualBox

Ticket #1927 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Mounting loop device with file on vboxfs causes kernel oops

Reported by: janica Owned by:
Priority: minor Component: shared folders
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I try mount filesystem with command:
mount -a
and I have not mounted directories /media/disk_e and /home/janica/PIM mount command will freeze and in dmesg I will find kernel oops.

Here is my /etc/fstab:

#-------------------------------------------------------------------
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=ae29e22a-d727-4d91-a7da-42df9945419e /               ext3    relatime,errors=remount-ro 0       1
# /dev/sda5
UUID=c2bfc077-6764-4904-83dc-b4fda12e81be none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/media/disk_e/PIM.img   /home/janica/PIM ext3   loop    2       0
d_drive         /media/disk_d   vboxsf  defaults        0       0
e_drive         /media/disk_e   vboxsf  defaults        0       0
#//10.0.2.2/projects    /media/disk_e   cifs    uid=1000,gid=6,auto,rw,guest,file_mode=0770,exec        0       0
LABEL=HOME      /home           ext3    defaults        0       0
#-------------------------------------------------------------------

Here is part of dmesg about kernel oops:

-------------------------------------------------------------------
[  244.690496] BUG: unable to handle kernel paging request at virtual address ff
ffffff
[  244.691764] printing eip: c0221165 *pde = 0047e067 *pte = 00000000
[  244.692112] Oops: 0000 [#1] SMP
[  244.694479] Modules linked in: binfmt_misc af_packet rfcomm l2cap bluetooth p
pdev ipv6 cpufreq_ondemand cpufreq_stats freq_table cpufreq_conservative cpufreq
_userspace cpufreq_powersave sbs container sbshc video output dock vboxvfs nls_c
p437 cifs iptable_filter ip_tables x_tables loop aes_i586 dm_crypt dm_mod lp snd
_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dumm
y parport_pc parport evdev psmouse serio_raw snd_seq_oss snd_seq_midi snd_rawmid
i ac battery snd_seq_midi_event snd_seq pcspkr snd_timer snd_seq_device button s
nd i2c_piix4 soundcore i2c_core snd_page_alloc vboxadd ext3 jbd mbcache sg sr_mo
d cdrom sd_mod floppy ehci_hcd ohci_hcd ahci usbcore e1000 ata_piix pata_acpi at
a_generic libata scsi_mod thermal processor fan fbcon tileblit font bitblit soft
cursor fuse
[  244.696107]
[  244.696715] Pid: 5861, comm: loop0 Not tainted (2.6.24-19-generic #1)
[  244.696930] EIP: 0060:[<c0221165>] EFLAGS: 00010082 CPU: 0
[  244.697425] EIP is at __percpu_counter_add+0x25/0xb0
[  244.697580] EAX: ffffffff EBX: 00000000 ECX: 00000000 EDX: 00000001
[  244.697759] ESI: d4ccd494 EDI: d9abed7c EBP: 00000008 ESP: d44c1e80
[  244.697991]  DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
[  244.698210] Process loop0 (pid: 5861, ti=d44c0000 task=d6660000 task.ti=d44c0
000)
[  244.698370] Stack: d945c0b5 c1295da0 d4ccd494 00000001 00000000 c01b39ec 0000
0008 d6c94bb8
[  244.698463]        d6c94bb8 00000000 00000000 c1295da0 d4ccd3f0 c0173c55 0000
0000 c1295da0
[  244.698838]        c01ae066 d4ccd494 d4ccd494 d9abece0 c1295da0 d7bfa900 c016                                                          d95e 00000000
[  244.699201] Call Trace:
[  244.699726]  [<c01b39ec>] __set_page_dirty+0x9c/0x160
[  244.700101]  [<c0173c55>] set_page_dirty+0x25/0xa0
[  244.700390]  [<c01ae066>] simple_write_end+0x76/0xf0
[  244.700824]  [<c016d95e>] pagecache_write_end+0x5e/0x100
[  244.701491]  [<d8e6ecfa>] do_lo_send_aops+0x17a/0x1e0 [loop]
[  244.702447]  [<d8e6e5a0>] transfer_none+0x0/0xb0 [loop]
[  244.702969]  [<d8e6ea49>] loop_thread+0x339/0x470 [loop]
[  244.704841]  [<d8e6eb80>] do_lo_send_aops+0x0/0x1e0 [loop]
[  244.705586]  [<c0140c40>] autoremove_wake_function+0x0/0x40
[  244.705990]  [<d8e6e710>] loop_thread+0x0/0x470 [loop]
[  244.706296]  [<c0140982>] kthread+0x42/0x70
[  244.706463]  [<c0140940>] kthread+0x0/0x70
[  244.706804]  [<c0105677>] kernel_thread_helper+0x7/0x10
[  244.707304]  =======================
[  244.707407] Code: bc 27 00 00 00 00 83 ec 14 89 5c 24 04 89 74 24 08 89 7c 24                                                           0c 89 c7 89 6c 24 10 8b 40 14 64 8b 1d 08 60 47 c0 8b 6c 24 18 f7 d0 <8b> 1c 98                                                           89 1c 24 8b 03 89 c3 89 c6 c1 fe 1f 01 d3 89 ea 11 ce
[  244.708090] EIP: [<c0221165>] __percpu_counter_add+0x25/0xb0 SS:ESP 0068:d44c                                                          1e80
[  244.708658] ---[ end trace 8f8c7777ebae6040 ]---
-------------------------------------------------------------------

Guest is Ubuntu Linux
lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.1"
uname -a
Linux vljanica 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686 GNU/Linux

Host is Windows XP SP3 with all patches (32-bit)

Change History

comment:1 Changed 6 years ago by frank

I cannot reproduce this problem, tested two several guests (among them Ubuntu hardy with the same kernel). What happens if you execute the mount commands separately? That is

mount.vboxsf e_drive /media/disk_e
mount -t ext3 -o loop /media/disk_e/PIM.img /home/janica/PIM

? Same kernel panic?

comment:2 Changed 6 years ago by janica

The same problem after trying mount disk separatly.
If you cannot reproduce problem, we have diferenct conditions: Shared folder disk_e is full disk e: with FAT32 filesystem.

I have 2 virtual disks, one is file on ext2 partition accessible from windows, second disk is direct access to disk for few partitions.

comment:3 Changed 4 years ago by Technologov

Is this still relevant for VBox 3.x ?

-Technologov

comment:4 Changed 4 years ago by janica

I tested last version and everything worked OK. But this time I have not tha same configuration. Shared folder was disk with NTFS filesystem.

I thinks, this bug can be closed

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use