VirtualBox

Ticket #1918 (closed enhancement: fixed)

Opened 6 years ago

Last modified 4 years ago

Support "differencing" disks, or don't delete immutable disk temp file on closedown

Reported by: sugarmonster Owned by:
Priority: minor Component: virtual disk
Version: VirtualBox 1.6.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

I would like to create guests based on a "base" immutable disk image, plus changes. I know VBox already does this with immutable disks, but it then deletes the writes to a given session on closedown. I would like the option to persist these changes between sessions (preferably automatically so I don't have to check "save changes" every time).

The reason is speed and space: If I can create a base OS image and point guests at that, I have an "instant starting point" for a new guest without reinstalling the OS. If that guest then behaves like a normal PC from that point onwards I can install different apps etc without contamination. Plus it all happens for the disk cost of one base image + differences per guest.

Change History

comment:1 Changed 6 years ago by lapo

Also a problem with VirtualBox 2.0.2: I created an immutable "base", then (after installing a few things in the VM) I made "snapshot 1", then I shut off. On the next activation of the VM I had "base" content as opposed as "snapshot 1" content! OTOH if after the shutdown I do a "revert to snapshot" then it correctly boots "snapshot 1".

VM active: base > snap1 > current state (working) After shutdown: base > snap1 > current state (equals to base) After revert: base > snap1 > current state (equals to snap1)

I do agree that current-state of an immutable should be lost, but not if there is a snapshot in between the immutable and that current-state…

comment:2 Changed 5 years ago by mildred

Well, it seems already possible. Even for normal disks. I was able to get to a state where a disk had several children. Unfortunately I wasn't able to reproduce that :/

See this topic:  http://forums.virtualbox.org/viewtopic.php?p=43407

I guess adding that feature would be relatively easy. And that would help waiting for the issue #46 to be resolved.

comment:3 Changed 5 years ago by eFloh

Isn't this already possible? Simply create a hard disk, do your "base installation" and then create a snapshot. Now whenever you try to attach this base vdi to another virtual machine, it will use a new differencing image for each virtual machine. (this is signaled by showning the blue icon next to the selected vdi in the machine settings hard disk selection dialog)

comment:4 Changed 4 years ago by Technologov

Now this becomes partially possible with VBox 3.1 and it's Branching Snapshots feature.

I say, partially, because it is not transparent yet, and VMs can'e be exported with all the snapshots yet. But some progress is made.

-Technologov

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Already possible.

comment:6 Changed 4 years ago by jpschewe

What's the right way to do this then? I tried with immutable and that didn't work. Is it just to create the base and snapshot it, then attach multiple VMs to the base?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use