VirtualBox

Ticket #1916 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Host CPU usage spikes and guest stalling when using the Intel PRO/1000 T Server NIC

Reported by: alvarezp Owned by:
Priority: major Component: VMM
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Version is Virtualbox 1.6.2 (not OSE), running on Ubuntu Hardy, with Windows XP SP3 guest.

Guest runs for about 1 second and stalls for about 0.5 seconds. This is constant.

Attachments

VBox.log Download (28.0 KB) - added by alvarezp 6 years ago.
VBox.log for the machine.
host-cpu.png Download (448 bytes) - added by alvarezp 5 years ago.
Graphic showing the CPU usage of the VM after entering this misbehaving mode. Here, the VM is actiually idling. (The guest Task Manager shows CPU usage, though.)
VBox-network-inteldesktop-doesntstall.png Download (72.8 KB) - added by alvarezp 5 years ago.
Screenshot of the box working OK with the Intel PRO/1000 MT Desktop.
VBox-network-intelserver-stalls.png Download (72.2 KB) - added by alvarezp 5 years ago.
Screenshot of the virtual box stalling with the Intel PRO/1000 T Server. Notice the CPU consumption (system monitor parameters included) and the perfect straight lines in the Paint drawing (marked in red).
VBox-network-inteldesktop-doesntstall.log Download (44.2 KB) - added by alvarezp 5 years ago.
Log file regarding the non-stalling maching with Intel PRO/1000 MT Desktop.
VBox-network-intelserver-stalls.log Download (42.9 KB) - added by alvarezp 5 years ago.
Log about the guest stalling periodically with the Intel PRO/1000 T Server.

Change History

Changed 6 years ago by alvarezp

VBox.log for the machine.

comment:1 Changed 6 years ago by alvarezp

After a reboot, it stopped doing it, but it started once again after a while of being running.

comment:2 Changed 6 years ago by frank

Please could you check if this still happens with VBox 1.6.6 or 2.0.2?

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please check the latest version (2.0.4) and reopen this ticket if the problem still persists.

comment:4 Changed 5 years ago by alvarezp

  • Status changed from closed to reopened
  • Resolution fixed deleted

Yes, it still happens on VBox 2.0.4, Ubuntu 8.04.

It starts by stopping like 5 or 10% every 1.5 seconds, and it then starts growing to about 33%.

I noticed during that "stopping", the host is using 100% of a CPU.

comment:5 Changed 5 years ago by sandervl73

Which process uses so much CPU? How much memory do you have on your host?

comment:6 Changed 5 years ago by alvarezp

It's not a per-process thing on the guest. I can close everything and open Paint and drawing is a nightmare, because clicking and mouse movement gets misinterpreted.

I took a sample of my CPU on the host using the system monitor applet on GNOME (host-cpu.png). You can see the exact usage. This is one of the worst cases. I can see that it is not 33%, but it is still a lot. During the peaks, the VM doesn't recognize any mouse input. Right after each peak, the VM processes all pending mouse clicks. However, the VM will get the position for each clicks where the mouse is *after* the peak, not during the actual click. This means that if I click on (X,Y) during the peak (the VM is stalled) and 0.2 second after the VM returns back, and the mouse is on (X+30,Y+40), the VM will receive a click on (X+30, Y+40) instead of (X,Y).

If you open an MS Paint window, select "line" and do a drag, you might notice the stall. I'll try to prepare a video to show this.

HOST

  • OS: Ubuntu Hardy, fully updated.
  • CPU: Pentium 4 3.4 GH, w/HyperThreading.
  • RAM: 1.5 GB.

GUEST

  • OS: Windows XP
  • RAM: 512 MB

Changed 5 years ago by alvarezp

Graphic showing the CPU usage of the VM after entering this misbehaving mode. Here, the VM is actiually idling. (The guest Task Manager shows CPU usage, though.)

comment:7 Changed 5 years ago by alvarezp

By the way, in the graphic, each pixel wide is 100 milliseconds.

comment:8 Changed 5 years ago by alvarezp

At this moment, the Guest RAM is set to 384 MB and the problem still happens.

More info: Guest Additions, v1.4.

comment:9 Changed 5 years ago by alvarezp

I noticed that even if the guest operating system is working properly, there is this 1.5-second probe. It usually takes unnoticeable little CPU, but it still exists.

Uninstalling Guest Additions makes the 1.5-second probe go away.

Installing them back, makes the 1.5-second probe come back. So new conclusions is that the stall always exists but it just gets worse and worse over time, and it only happens if Guest Additions is installed.

I also tried disabling every possible Windows service and killing every application. The 1.5-second probe is still there.

comment:10 Changed 5 years ago by alvarezp

Any news on this issue? Any other particular information that I can provide to help diagnosis?

comment:11 Changed 5 years ago by alvarezp

Still happening on 2.1.0 with updated Guest Additions.

comment:12 Changed 5 years ago by alvarezp

It looks like changing the virtual network card from the Intel PRO/1000 T Server to the Intel PRO/1000 MT Desktop minimizes/eliminates the problems.

I changed it, and I don't see the 1.5-second-interval spikes in my CPU utilization anymore.

Will leave it running for a while to see if the "problem-intensification-over-time" behavior makes it more evident.

comment:13 Changed 5 years ago by frank

  • Version changed from VirtualBox 1.6.2 to VirtualBox 2.1.0

Interesting finding. Could you attach a VBox.log file of the same VM session, one time with the server model (the stops occur), the other time with the desktop model (the stops don't occur)? We would like to find out the reason for this problem.

Changed 5 years ago by alvarezp

Screenshot of the box working OK with the Intel PRO/1000 MT Desktop.

Changed 5 years ago by alvarezp

Screenshot of the virtual box stalling with the Intel PRO/1000 T Server. Notice the CPU consumption (system monitor parameters included) and the perfect straight lines in the Paint drawing (marked in red).

Changed 5 years ago by alvarezp

Log file regarding the non-stalling maching with Intel PRO/1000 MT Desktop.

Changed 5 years ago by alvarezp

Log about the guest stalling periodically with the Intel PRO/1000 T Server.

comment:14 Changed 5 years ago by alvarezp

I think it would be appropriate to update the title for this ticket to something like "Host CPU usage spikes and guest stalling when using the Intel PRO/1000 T Server NIC".

comment:15 Changed 5 years ago by alvarezp

Confirmed on another PC, Intel Core 2 Duo, and it happens the same. Interval here for the peaks is 2.3 seconds.

Similar setup: Debian Sid on host, Windows XP SP2 on guest. VirtualBox 2.1.0.

comment:16 Changed 5 years ago by frank

Thank you. Please could you attach the output of dmesg on the host after the vboxdrv module was loaded?

comment:17 Changed 5 years ago by sandervl73

  • Summary changed from Guest stops 33% of every 1.5 seconds. to Host CPU usage spikes and guest stalling when using the Intel PRO/1000 T Server NIC

comment:18 Changed 5 years ago by frank

And please could you attach the two VBox.log files (with/without stalls) for the Core 2 Duo system as well?

comment:19 Changed 5 years ago by frank

  • Component changed from other to VMM

comment:20 Changed 5 years ago by frank

Please could you do the following test:

  • switch back to the server version of the E1000 network device (which stalls on your Pentium D)
  • edit the script /etc/init.d/vboxdrv and change the following line:
    if ! modprobe vboxdrv force_async_tsc=1 > /dev/null 2>&1; then
    
    (note the additional force_async_tsc parameter)
  • reload the kernel driver:
    /etc/init.d/vboxdrv restart
    
  • start the VM

Do you still experience the stalls?

comment:21 Changed 5 years ago by alvarezp

The force_async_tsc=1 did not help. I only applied it to the "modprobe vboxdrv" line. I did not restart the computer, only the vboxdrv service, having the VM stopped. This was tested on the day-to-day computer that gives me trouble (the P4)

comment:22 Changed 5 years ago by frank

  • Host type changed from other to Linux

comment:23 Changed 5 years ago by frank

Please could you attach the output of dmesg on the host?

comment:24 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use