VirtualBox

Ticket #1915 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Cannot Access Shared Folders on WinXP Host / WinXP Guest

Reported by: WCarvalho Owned by:
Priority: blocker Component: shared folders
Version: VirtualBox 1.6.4 Keywords: Create Access Shared Folders
Cc: Guest type: Windows
Host type: Windows

Description

Hi!!!

I can't create or access Shared Folders anymore...

I tried it on several ways, installing and uninstalling the Guest Additions... changing the Ethernet model... reinstalling the Guest Additions...

After one and half hour, Have no Success...

Sorry guys but, for me, it's a BLOCKER status. I can't access or compile my projects...

Downgrading to v1.6.3...

Best Wishes,

WCarvalho

Attachments

install.log Download (2.9 KB) - added by WCarvalho 6 years ago.
from Guest Additions v1.6.4 (host/guest WinXP)
VBoxGuest.reg Download (2.5 KB) - added by WCarvalho 6 years ago.
Registry Exported Key
VBoxService.reg Download (2.4 KB) - added by WCarvalho 6 years ago.
Registry Exported Key
VBoxSF.reg Download (948 bytes) - added by WCarvalho 6 years ago.
Registry Exported Key
NetworkProvider.reg Download (800 bytes) - added by WCarvalho 6 years ago.

Change History

comment:1 Changed 6 years ago by frank

Would be nice if you could provide more information. What does that mean can't create or access shared folders anymore? How do you create shared folders, using the GUI (VM settings) or during runtime from the menu? Are the 'VirtualBox Shared Folders' shown in the Folders list when you do 'Map network drive ...' and press Browse in the next dialog?

comment:2 Changed 6 years ago by WCarvalho

Hi Frank... ;-)

Well...

1) the old version (1.6.3) of G.A. (Guest Additions) don't work with 1.6.4. The Shared Folders cannot connect into Host;

2) So What I Did? I uninstall old version of G.A. and install new 1.6.4 G.A. - Shared Folders isn't present on "Map Network Drive..." and "VirtualBox Shared Folders" too;

3) Trying to access shared folder through Windows Explorer, like "\vboxsvc\public" didn't work too;

4) After all what I explain above, I tried to uninstall and install G.A., changing the ethernet model and a lot of combos but have no success.

Ah! I tried to create/access Shared Folders through Command Line and GUI.

  • about 1.6.3: after downgrade to 1.6.3, the Shared Folders is there...

If you need any help and I can help, let me know... ;-)

Best regards,

WCarvalho

comment:3 Changed 6 years ago by pentagonik

I'm just curious: Where did you get a 1.6.3 version from? This must be some developer release then.

Furthermore, doing a "\vboxsvc\public" won't work. A "\vboxsrv\public" or "\vboxsvr\public" will do it. So please go to the cmd line and type "net use s: \vboxsrv\public".

If this doesn't help, please re-install the 1.6.4 G.A using "/l" (for logging into install.log) as command line parameter when executing the setup and attach the log as a file here.

comment:4 Changed 6 years ago by WCarvalho

Well... pentagonik

Have no success...

The install.log has been attached...

about 1.6.3: I received it version to do some tests after help to solve the issue: BSOD 8E on compiling delphi/visual C++ sources from shared folders.

Let's solve it ones... ;-)

Regards,

WCarvalho.

Changed 6 years ago by WCarvalho

from Guest Additions v1.6.4 (host/guest WinXP)

comment:5 Changed 6 years ago by frank

Which detailed version was that (the 5 digits are important as they name our internal SVN revision)...

comment:6 Changed 6 years ago by pentagonik

With which user you are working? Does it have admin rights?

1. Open the registry (type "regedit.exe" into the command line).
2. Go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services".
3. Verify, that the keys "VBoxGuest", "VBoxSF" and "VBoxService" are there.
4. Export each of the three keys above by right clicking on them and click
   on "Export". Upload the files to our board / bugtracker later!
5. Open the service manager (type "services.msc" into the command line).
6. Look up the entry "VBoxService". Is it started? What's its status?
7. With the Explorer go to "<Windows-Directory>\system32".
8. Look up the file versions (right click on the file, 
   "Properties" -> "Version" -> "Product Version" in item name table below) 
   of these files:
   
   <Windows-Directory>\system32\VBoxMRXNP.dll
   <Windows-Directory>\system32\VBoxService.exe
   <Windows-Directory>\system32\drivers\VBoxSF.dll
   
9. Include these file versions into your next report.

comment:7 Changed 6 years ago by WCarvalho

Hi pentagonik ... :-)

0) My rights for each machine is Administrator; 1) OK; 2) OK; 3) There's no one of that keys; 4) Cannot export because 3); 5) OK; 6) There's no VBoxService on Services List or on Registry; 7) OK; 8) There's no one of that files; 9) Cannot report because 8).

PS: I tried to install on 3 machines (Host/Guest WinXP), with Administrator Rights... two of them are Brazilian Portuguese SP3 and another one US SP3.

PS2: Have the .MSI all files and policies to install that missing files on right place and registry keys?

PS3: I'd a deep scan and haven't found it files: <Windows-Directory>\system32\VBoxMRXNP.dll <Windows-Directory>\system32\VBoxService.exe (VBoxSVC.exe ?) <Windows-Directory>\system32\drivers\VBoxSF.dll

Next step? ;-)

comment:8 Changed 6 years ago by pentagonik

Hm, I forgot to mention that you have to do all the 9 steps above in your VM, not on your host :-) Could you try again, please?

comment:9 Changed 6 years ago by szombatha

Hello!

I have same problem with VB v1.6.4. My host is WinXP, and VM too. My VM not contain VBoxService.exe.

comment:10 Changed 6 years ago by WCarvalho

Hello pentagonik ;-)

0) Again, :-) my rights for the machine is Administrator; 1) OK; 2) OK; 3) OK, is there!; 4) OK! Exported and uploaded; 5) OK; 6) Is there! status: RUNNING; start: AUTOMATIC; 7) OK; 8) Is there! (except VBoxSF.DLL - I think it must be ".sys". misstype?)

  • VBoxMRXNP.DLL is v1.6.4.33808
  • VBoxService.exe is v1.6.4.33808
  • VBoxSF.sys is v1.6.4.33808 (have .SYS - not .DLL)

9) Report done! (on guest) :-)

Changed 6 years ago by WCarvalho

Registry Exported Key

Changed 6 years ago by WCarvalho

Registry Exported Key

Changed 6 years ago by WCarvalho

Registry Exported Key

comment:11 Changed 6 years ago by pentagonik

@szombatha: Please install the Guest Additions in your VM again; this time using the command line: "VBoxGuestAdditions /l". After the installation you'll find a "install.log" in the installation directory (usually in C:\Program Files\Sun\xVM VirtualBox Guest Additions\). Please post this log here then.

comment:12 Changed 6 years ago by pentagonik

@WCarvalho: Thanks for the information. Yes, VBoxSF.sys is correct, not VBoxSF.dll. This still doesn't work? In addition, please do the following:

1. Go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control".
2. Export the key "NetworkProvider" (like in step 4). Upload the files to our board / bugtracker later!

comment:13 Changed 6 years ago by WCarvalho

ready on! ;-)

Uploaded!

Changed 6 years ago by WCarvalho

comment:14 Changed 6 years ago by pentagonik

@WCarvalho: Seems all okay to me. So to provide me more information about your problem, please send me an e-mail to pentagonik at sun dot com. I'll then send you a debug version of the Shared Folders.

comment:15 Changed 6 years ago by frank

Some users report that installing the Windows guest additions a second time solves the problem.

comment:16 Changed 6 years ago by pentagonik

I still cannot reproduce the problem here; nevertheless, I'm on it with the support of WCarvalho.

comment:17 in reply to: ↑ description Changed 6 years ago by aaronwang

Replying to WCarvalho:

Hi!!!

I can't create or access Shared Folders anymore...

I tried it on several ways, installing and uninstalling the Guest Additions... changing the Ethernet model... reinstalling the Guest Additions...

After one and half hour, Have no Success...

Sorry guys but, for me, it's a BLOCKER status. I can't access or compile my projects...

Downgrading to v1.6.3...

Best Wishes,

WCarvalho

I have the same problem. Uninstall Guest Additions, restart Guest OS, and Install Guest Additions again will resolve thie problem.

comment:18 Changed 6 years ago by skc

Hello,

I also have the same problem. Here is my post in the forum:  http://forums.virtualbox.org/viewtopic.php?t=8483

Host & Guest : Windows XP Pro SP2. VB 1.6.4
Single PC connected to external DSL modem/router

-Guest configuration (as requested by Frank Mehnert in my forum post):
Windows XP Pro CD with slipstreamed SP2.
No windows updates or patches.
No windows components added.
No other software installed.
English language (did not install or activate any language)

All fairly standard setup:

  • Enable : IO APIC, VT-x/AMD-V
  • Disabled SATA Controller
  • Network Adapter 0 : Enabled, PCnet-FAST III (Am79C973), NAT, Cable Connected

Could not share folder (transient or permanent)
I used the GUI and also tried VboxManage and 'Net' commands in the host and guest. In the guest, windows explorer, under “My Networking Places” > “Entire Network” > “VirtualBox Shared Folders”, there is Nothing. I understand that the shared folders would show up there. I read the instructions carefully and followed it using the GUI and the command line but Nothing appeared under VirtualBox Shared Folders. Installing Guest Additions 1.6.2 solved the problem. Even after installing 1.6.4 on top of 1.6.2 still works fine.

comment:19 Changed 6 years ago by WCarvalho

Hi Guys...

I'm trying somethings here to help pentagonik...

Some tests give me a tip for a workaround...

Install the old G.A. (Guest Additions) v1.6.2 could fit on it...

After that, DO NOT UNINSTALL it... install v1.6.4 over it...

Some guys have success installing G.A. twice... but don't work for me and others...

Well... best regards,

WCarvalho

comment:20 Changed 6 years ago by WCarvalho

PS: Be sure you have G.A. v1.6.2 working fine with Shared Folders before install G.A. v1.6.4...

comment:21 Changed 6 years ago by emn8w8

Hi,

As requested I'm adding my comments to this ticket.. Host = openSuse Linux 11.0 kernel 2.6.25.11-0.1-default x86_64 VirtualBox 1.6.4 Guest = Microsoft Windows XP Professional version 2002 Dutch language SP2 applied No software that intervenes with the registry No virusscanner, Windows firewall disabled, no other firewall. VM configuration =

  • Base mem 1024Mb
  • Video mem 128 Mb
  • ACPI enabled
  • IO APIC enabled
  • VT-x/AMD-V disabled
  • PAE/NX enabled
  • Dynamic VDI
  • Audio: Host driver ALSA Audio driver, Controller ICH AC97
  • Network: Adapter 0, PCnet-FAST III (NAT)
  • Serial Ports: Port 0, COM1, disconnected, Port 1, COM2, disconnected
  • USB: disabled
  • Shared Folders: 1
  • Remote display: disabled

what happened is: Upgraded VirtualBox from 1.6.2.-> 1.6.4 But started the Windows client with GuestAdditions 1.6.2 still installed. Connectivity with shared folders was o.k Upgraded GuestAdditions 1.6.2 -> 1.6.4 (but just by installing it over 1.6.2, so not removing/uninstalling the older version the appropriate way.) This resulted in the loss of connectivity with the shared folders. Uninstalled the GuestAdditions altogether (via Configuration -> Software -> Uninstall, reinstalled GuestAdditions 1.6.2 and the connectivity with the shared folders was restored.

If more info is needed I'll be happy to send it, but since the problem can be easily worked around this is no big issue to me....

Best regards, Erik

comment:22 Changed 6 years ago by WCarvalho

The issue seems to be only with couple HOST WinXP and GUEST WinXP...

comment:23 Changed 6 years ago by emn8w8

errr...apparently not....:-) I'm experiencing the same problem on a Linux host with a windows guest...

Best regards, Erik

comment:24 Changed 6 years ago by chemist109

Stumbled on this while trying to find a solution for the same problem on my boss's computer. He upgraded from an earlier version (1.5.6, I believe) to 1.6.4 and can't get shared folder access.

Tried installing guest additions multiple times as suggested by some others with this problem. No success.

Host: Linux- Kubuntu 8.04 (64 bit)
Guest: Windows XP

comment:25 Changed 6 years ago by aaronwang

1.Unistall Guest Additions. 2.Restart Guest OS. 3.Install Guest Additions again. 4.Restart Guest OS.

Now, Shared Folders work well.

comment:26 Changed 6 years ago by WCarvalho

aaronwang,

It thread has been opened because uninstall/install G.A. (again and again) isn´t working for everyone...

Regards,

WCarvalho

comment:27 Changed 6 years ago by garfus

I can't see Shared Folders from a Windows XP Guest using a Windows Vista Host. However, Shared folders work fine when using an Ubuntu Guest from the same Windows Visa Host. It would seem that the problem is consistently occurring on Windows XP Guests, regardless of the Host type.

comment:28 follow-up: ↓ 29 Changed 6 years ago by anders2209

Z:\driver\VBoxGuest\VBoxService.exe is missing from guest additions iso' 1.6.2 and 1.6.4 but is in 1.6.0 - No wonder the shared folder function does not work.

comment:29 in reply to: ↑ 28 Changed 6 years ago by anders2209

Just forget my statement - I don't know what the hell I'm talking about - Sorry.

comment:30 Changed 6 years ago by cornbread

can you share the folder on the host and then mount in the guest with \10.0.2.2\sharename ?

comment:31 Changed 6 years ago by anders2209

I don't know if you are adressing me, Cornbread but if you are, then yes, I can actually access a share created on the host - This might be enough for me, I not quite sure yet, but for now thank you very much :-)

comment:32 Changed 6 years ago by cornbread

anders2209 Great!

This goes along with my bug: #1822, except mine will blue screen half the time if using \vboxsvr\share.

There have been guest additions issues since 1.6.0 and they are still not sorted out... even if you get \vboxsvr\share working it will be much slower than \10.0.2.2\share (at least in my experience)

comment:33 Changed 6 years ago by frank

If you map the shared folder to a specific drive it should be notably faster that sharing over network. We are aware of some pending issues with shared folders and this is one reason for delaying the 1.6.6 release.

comment:34 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use