VirtualBox

Ticket #1913 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

xargs bug causing problems with rpm installation

Reported by: nlsteffens Owned by:
Priority: major Component: installer
Version: VirtualBox 1.6.4 Keywords: xargs rpm install scriptlet failed
Cc: Guest type: Windows
Host type: Linux

Description

There is an xargs bug in fedora core 8 (and possible other releases) which has been resolved in fedora rawhide (the latest development as of the date of this posting;  http://fedoraproject.org/wiki/Releases/Rawhide).

Running 'xargs' on the command line produces the error:


xargs: xargs.c:445: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed. Aborted


See the bug report here:  https://bugzilla.redhat.com/show_bug.cgi?id=439593

When an rpm upgrade or install of virtualbox is run on fedora core 8, this error is thrown:


rpm -ihv VirtualBox-1.6.4_33808_fedora8-1.i586.rpm Preparing... ########################################### [100%] /var/tmp/rpm-tmp.70344: line 19: 3722 Broken pipe find /lib/modules -name "vboxdrv\.*" 2> /dev/null

3723 Aborted | xargs rm -f 2> /dev/null

error: %pre(VirtualBox-1.6.4_33808_fedora8-1.i386) scriptlet failed, exit status 134 error: install: %pre scriptlet failed (2), skipping VirtualBox-1.6.4_33808_fedora8-1

find /lib/modules -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2> /dev/null Aborted


This error is caused by this line in the rpm script: find /lib/modules -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2> /dev/null

This can be resolved by using exec instead of xargs in the rpm script.

To view the script, use: rpm --scripts -qp VirtualBox-1.6.4_33808_fedora8-1.i586.rpm

To workaround this problem, add this line

INSTALL_NO_VBOXDRV=1

to file

/etc/default/virtualbox

If this file does not exist then create it and add the line above. This workaround can be found in the rpm script.

Regards,

Nick Steffens

Change History

comment:1 Changed 6 years ago by nlsteffens

Refer to the forum post here:  http://forums.virtualbox.org/viewtopic.php?p=31380#31380

The xargs bug has been fixed in Fedora although I can not explain why I was getting this error.

I upgraded findutils from version findutils-4.2.31-2.fc8 to version findutils.i386 1:4.4.0-1.fc10 from the development repo.

yum --enablerepo=development update findutils

This has fixed the problem with xargs.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This was fixed in 1.6.6 in a slightly different way.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use