VirtualBox

Ticket #19061 (closed defect: invalid)

Opened 19 months ago

Last modified 18 months ago

Shared folders directory removal fails

Reported by: Daniel Pielmeier Owned by:
Component: shared folders Version: VirtualBox 6.0.14
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Coming from bugs #18345 and #18569 I was told to open an individual ticket.

The problem occurs currently with version 6.0.14 and does not with 5.2.32.

In my example the user running VirtualBox has full control on the shared folder of the host (Windows 10 Enterprise, 1803). The user within the Linux guest (Ubuntu 18.04.02 LTS) is in the vboxfs group. The shared folder is mounted with the following options: rw,nodev,relatime,iocharset=utf8,uid=0,gid=999,dmode=0770,fmode=0770,tag=VBoxAutomounter

On the guest within a shell the user is able to create and and delete files and directories:

~/shared$ mkdir test
~/shared$ rmdir test
~/shared$ touch file
~/shared$ rm file

However under some conditions directory removal fails.

Within the guest there is OpenFOAM running. One application namely  foamListTimes which should remove files and directories fails to remove directories. I think it executes the rmdir function from  POSIX.C

The output I get from foamListTimes is:

bool Foam::rm(const Foam::fileName&) : Removing : "/home/openfoam/OpenFOAM/projects/debug/transient/processor3/4/fluid_water/U.gz"
bool Foam::rm(const Foam::fileName&) : Removing : "/home/openfoam/OpenFOAM/projects/debug/transient/processor3/4/fluid_water"
--> FOAM Warning : 
    From function bool Foam::rmDir(const Foam::fileName&)
    in file POSIX.C at line 1103
    failed to remove directory "/home/openfoam/OpenFOAM/projects/debug/transient/processor3/4/fluid_water"
--> FOAM Warning : 
    From function bool Foam::rmDir(const Foam::fileName&)
    in file POSIX.C at line 1073
    failed to remove directory "fluid_water" while removing directory "/home/openfoam/OpenFOAM/projects/debug/transient/processor3/4"

So it successfully removes the files within the directory "U.gz" but then fails to remove the directory "fluid_water" itself.

Change History

comment:1 Changed 18 months ago by fbatschu

This is very likely something similar to

Ticket #18776 (accepted defect) Vagrant shared folders unable to install Package Management Plugins (Composer, PHP)
https://www.virtualbox.org/ticket/18776

Hoewever we lack a reproducable test case and there is no investigation into the application OpenFOAM where exactly and how exactly it fails. It can fail to remove directories for an arbitrary number of reasons.

from:  https://github.com/OpenFOAM/OpenFOAM-5.x/blob/master/src/OSspecific/POSIX/POSIX.C

                    if (!rmDir(path))
                    {
                        WarningInFunction
                            << "failed to remove directory " << fName
                            << " while removing directory " << directory
                            << endl;

Yeah whatever. Would be nice if coding would include proper error reporting from the OS. Not sure where this routine "rmDir()" lives.

Not much we can do about this for now.

Last edited 18 months ago by fbatschu (previous) (diff)

comment:2 Changed 18 months ago by fbatschu

  • Status changed from new to awaitsfeedback

comment:3 Changed 18 months ago by Daniel Pielmeier

Okay, I am trying to reach out to the developers of OpenFOAM. Maybe they can shed light on this issue.

comment:4 Changed 18 months ago by Daniel Pielmeier

ReinerB who also commented on Ticket #18569 has opened Ticket #19086 which is most likely the same issue. Although it was created after my ticket is has been acknowledged as an issue. So it probably makes more sense to close this one and track this issue in #19086.

comment:5 Changed 18 months ago by fbatschu

since we don't know anything about this case we cannot prove whether or not it's a duplicate of Ticket #19086 but it could be, similar to Ticket #18776

comment:6 Changed 18 months ago by fbatschu

  • Status changed from awaitsfeedback to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use