VirtualBox

Ticket #19059 (closed defect: invalid)

Opened 19 months ago

Last modified 18 months ago

VboxLinuxAdditions.run file corrupt

Reported by: abrasax Owned by:
Component: guest additions Version: VirtualBox 6.0.14
Keywords: installation Cc:
Guest type: Linux Host type: Windows

Description

The crux of the issue:

The VBoxLinuxAdditions.run file is missing an EOF character which is causing the next file on the media, VBoxGuestAdditions-x86.tar.bz2, to be included in the file contents. Fortunately, Linux is smart enough to realize that this is wrong and doesn't execute the file. Instead, it opens the file(s) in a text editor where you are instructed to fix it. At first, I thought I might be able to fix it. But upon further investigation, it turns out that I do not know how to fix it.

Steps to reproduce (although they shouldn't really be necessary):

  1. I installed VirtualBox 6.0.14 from the publicly released media.
  2. I created a new VM and installed Debian 10.1
  3. I logged into the new VM and immediately mounted the VirtualBox Guest Additions using the Devices menu option.
  4. When Debian asked what I wanted to do with the new media, I opted to open in the file manager.
  5. I then double-clicked on VBoxLinuxAdditions.run to begin installation as I have done countless times in the past (with older versions).
  6. Instead of running, the file was opened in a text editor and helpful dialog explained that invalid characters were detected in the file and that I needed to fix this before it could be executed.
  7. I scrolled down a ways and saw where the UTF-8 text file (shell script, obv) changed into a binary file. See attached screenshot.

Attachments

vb-bug.png Download (162.9 KB) - added by abrasax 19 months ago.
Screenshot of file corruption

Change History

Changed 19 months ago by abrasax

Screenshot of file corruption

comment:1 Changed 19 months ago by abrasax

Just for the sake of clarity, I'd like to add an elaboration to the steps to reproduce:

1a. I installed the Guest Additions using the dialog that pops up when you run VB for the first time after a new install. The dialog downloaded and installed Guest Additions and then I opted to delete the installer file. No errors were reported.

comment:2 Changed 18 months ago by janitor

  • Status changed from new to closed
  • Resolution set to invalid

The file is not corrupt. This is a self-extracting archive and is exactly as intended.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use