VirtualBox

Ticket #18872 (new defect)

Opened 3 years ago

Last modified 22 months ago

I cannot enable second monitor

Reported by: Benmaxrei Owned by:
Component: GUI/multiview Version: VirtualBox 6.0.10
Keywords: multi monitor Cc:
Guest type: Linux Host type: Windows

Description

I set 2 displays in preferences. Linux starts with one. When I right click on the screen icon in the status bar, I see the second virtual display. Unfortunately, nothing happens when I click on "Enable".

linux xrandr

Screen 0: minimum 1 x 1, current 1920 x 975, maximum 8192 x 8192
Virtual1 connected primary 1920x975+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1920x975      60.00*+
   2560x1600     59.99  
   1920x1440     60.00  
   1856x1392     60.00  
   1792x1344     60.00  
   1920x1200     59.88  
   1600x1200     60.00  
   1680x1050     59.95  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      60.02  
   1280x800      59.81  
   1152x864      75.00  
   1280x768      59.87  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
Virtual2 disconnected (normal left inverted right x axis y axis)
Virtual3 disconnected (normal left inverted right x axis y axis)
Virtual4 disconnected (normal left inverted right x axis y axis)
Virtual5 disconnected (normal left inverted right x axis y axis)
Virtual6 disconnected (normal left inverted right x axis y axis)
Virtual7 disconnected (normal left inverted right x axis y axis)
Virtual8 disconnected (normal left inverted right x axis y axis)

linux systemctl status vboxadd.service:

● vboxadd.service
   Loaded: loaded (/opt/VBoxGuestAdditions-6.0.11/init/vboxadd; enabled; vendor preset: enabled)
   Active: active (exited) since Wed 2019-08-28 10:31:45 CEST; 10min ago
  Process: 737 ExecStart=/opt/VBoxGuestAdditions-6.0.11/init/vboxadd start (code=exited, status=0/SUCCESS)
 Main PID: 737 (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 4915)
   Memory: 216.7M
   CGroup: /system.slice/vboxadd.service
           ├─1231 VBoxClient --vmsvga
           └─1232 VBoxClient --vmsvga

Aug 28 10:31:42 ubuntu vboxadd[737]: modules.  This may take a while.
Aug 28 10:31:42 ubuntu vboxadd[737]: VirtualBox Guest Additions: To build modules for other installed kernels, run
Aug 28 10:31:42 ubuntu vboxadd[737]: VirtualBox Guest Additions:   /sbin/rcvboxadd quicksetup <version>
Aug 28 10:31:42 ubuntu vboxadd[737]: VirtualBox Guest Additions: or
Aug 28 10:31:42 ubuntu vboxadd[737]: VirtualBox Guest Additions:   /sbin/rcvboxadd quicksetup all
Aug 28 10:31:45 ubuntu useradd[1166]: failed adding user 'vboxadd', data deleted
Aug 28 10:31:45 ubuntu useradd[1167]: failed adding user 'vboxadd', data deleted
Aug 28 10:31:45 ubuntu vboxadd[737]: VirtualBox Guest Additions: Running kernel modules will not be replaced until
Aug 28 10:31:45 ubuntu vboxadd[737]: the system is restarted
Aug 28 10:31:45 ubuntu systemd[1]: Started vboxadd.service.

Change History

comment:2 Changed 3 years ago by socratis

Actually, I would point to the beginning of the thread in the forums:  https://forums.virtualbox.org/viewtopic.php?f=3&t=93941

I also tied that thread to the ticket...

comment:3 Changed 3 years ago by Benmaxrei

Still don't work with 6.1.0 beta_1.

When i activate the second monitor, the first one scales to minimun resolution.

comment:4 Changed 3 years ago by Samir_Berlin

I can confirm this annoying bug.

A workaround for me is to use guest additions from older version, but then some guest additions features do not work like copy paste. But since i need 2 Displays badly I have to work without that.

Since this bug was introduced with version 6.0.10 would it not be rather simple to track down?

comment:5 Changed 3 years ago by mMerlin

I encountered what seems to the the same problem in version 6.1.4 r136177 with a Fedora 31 host and also a Fedora 31 guest machine. After searching, this is the closest and most current reference I could find. In the spirit of trying to narrow down the cause of the problem, I tried changing some of the VM guest settings. I found one that worked.

Change the Graphics Controller on the Display tab from VMSVGA to VBoxSVGA. That gives a warning about invalid settings, but it actually works. With that setting, start the VM. Once it is up, the View menu, Virtual Screen 2, enable check box works.

From other reading, it might be necessary to also increase the video memory available to the VM.

I do not know what limitations might be introduced by changing the graphics controller, but this DOES work. And points to the VMSVGA graphics controller as a place to have a closer look at for the actual problem.

Version 0, edited 3 years ago by mMerlin (next)

comment:6 Changed 2 years ago by j dr

I have got the same problem here.

Host: Windows 10 (1909), VirtualBox v6.1.14

Guest Setup:

  • Ubuntu Mate 20.04 LTS
  • VMSVGA
  • 2 displays
  • Guest Additions 6.1.14 installed and active

Effect:

  • Guest starts up with one display enabled only
  • After login, sometimes xrandr error message displayed as stated in initial description above
  • When I enable second display (> View > Virtual Screen 2 > Enable) a new VM window is displayed but disappears instantly. Second attempt to enable second display the same way succeeds.
  • When I run the VM with VBoxSVGA instead, 2 displays are shown as expected but mouse pointer has horizontal offset

comment:7 Changed 22 months ago by lberteau

Last edited 22 months ago by lberteau (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use