VirtualBox

Ticket #18820 (new defect)

Opened 16 months ago

Last modified 11 months ago

No sound on 5.2.32 Linux guest on Linux host

Reported by: nauved Owned by:
Component: audio Version: VirtualBox 5.2.32
Keywords: no sound Cc:
Guest type: Linux Host type: Linux

Description

I first reported this issue on July 18 here:  https://forums.virtualbox.org/viewtopic.php?f=7&t=93940

For the following weeks I tried playing with various configurations including .asoundrc and asoundrc.conf, the VB audio settings and tools like alsamixer and not a peep. It was extremely frustrating

Sound worked just fine on a quick boot up in qemu. I was about to give up on VB when someone with the identical problem replied to the above thread reporting that reverting to 5.2.18 corrected it. Doing so corrected the issue for me also.

There are logs attached to the above-mentioned thread. I was also emailing various logs and command output to someone for assistance so may have something else useful in history.

Here are my system specs:

Host: Devuan Jessie 32 bit

Guests: Devuan ascii and Devuan Beowulf also 32 bit, of course.

I was using these VMs for package testing and had not previously tested audio.

Thanks you and hope that you can find the bug and correct it.

Attachments

VBox.log.zip Download (29.7 KB) - added by nauved 16 months ago.
Requested AudioDebug log

Change History

comment:1 Changed 16 months ago by pentagonik

Could you please supply the verbose VBox.log file as shown here: https://www.virtualbox.org/wiki/AudioDebug

Also, did you give this a try on !VBox 6.0.10 (latest) yet?

Thank you!

comment:2 Changed 16 months ago by nauved

It will be a few days before I can get around to providing that log (if I even decide to go there). And I don't understand how a wav could be created if there is no audio output at all. I am probably missing something obvious.

In the 5.2.32 VM, 'aplay -v /usr/share/sounds/alsa/Rear_Center.wav' produces no sound, does not complete and does not return to prompt. Controls on media players like quod libet and online controls for mp3 or mp4 in browser are non-functional. VLC shows a moving timeline but is completely silent.

I cannot test 6.0.10 because I only see a 64 bit deb which will not run on a 32 bit host. Is VB dropping 32 bit support?

Changed 16 months ago by nauved

Requested AudioDebug log

comment:3 Changed 16 months ago by nauved

I was stunned that all the .wav files captured the audio streams though one was a little softer and not as clear.

In the "Diagnosis" section of the instruction page, the choices do not include "no sound" under the heading "Playback in running VM" and indeed while the .wavs were being captured, there was complete silence in the running application(s).

Also note that the requirement that "Audio: Verbose logging enabled" be present was not met. Instead I found "Audio: Verbose logging for driver 'ALSAAudio' enabled"

comment:4 Changed 13 months ago by hercc

Hi. I have a similar problem with gentoo fork version. I have opened two threads  https://forums.virtualbox.org/viewtopic.php?f=7&t=95560&p=462786#p462786  https://forums.gentoo.org/viewtopic-t-1104042.html

However, I can add that it is enough for me to downgrade to 5.2.2x (not sure .24 or .26) to fix the problem. Maybe this information will help to solve the problem faster.

comment:5 Changed 13 months ago by hercc

Solution: VBoxManage setextradata global VBoxInternal2/Audio/ALSAAudio/BufferSizeMs="100"

https://www.virtualbox.org/ticket/18342

Last edited 13 months ago by hercc (previous) (diff)

comment:6 Changed 11 months ago by socratis

@nauved

Did the solution that 'hercc' proposed work for you?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use