VirtualBox

Ticket #18758 (closed defect: invalid)

Opened 20 months ago

Last modified 19 months ago

Guest DNS not configured using Host DNS configurations

Reported by: heyhujiao Owned by:
Component: network/NAT Version: VirtualBox 6.0.8
Keywords: DNS Cc:
Guest type: Linux Host type: Linux

Description

The DNS nameserver is not configured correctly as the /etc/resolv.conf file only contains VirtualBox's own DNS nameserver which is 10.0.2.3.

Using NAT, the host's DNS configurations should also be resolved and appended to the /etc/resolv.conf file in the guest.

Change History

comment:1 Changed 20 months ago by socratis

  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved in the forums, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

Plus a discussion and analysis on the bug tracker is going to help me, you, and potentially a future drive-by user or two. Not so in the forums, many more tend to benefit...

  1. VirtualBox cannot directly edit files in your guest, like "/etc/resolv.conf".
  1. Did you read the User Manual, ch. 8.8.2.1 NAT Networking Settings? And the command:
    VBoxManage modifyvm "<UUID|VMname>" --natdnshostresolver<1-N> on|off
    
    doesn't do what you want?

From the ch. above:

--natdnsproxy<1-N> on|off: Makes the NAT engine proxy all guest DNS requests to the host's DNS servers. See Section 9.10.5, “Enabling DNS Proxy in NAT Mode”.


comment:2 Changed 19 months ago by janitor

  • Status changed from new to closed
  • Resolution set to invalid

Your host is probably configured to use 127.0.1.1 or 127.0.0.53 or whatever is the current fashion for the listening address of dnsmasq. When guest uses 10.0.2.3 as its nameserver, the requests are actually forwarded to the host's resolver (at the artisanal loopback address).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use