VirtualBox

Ticket #18753 (closed defect: fixed)

Opened 13 months ago

Last modified 7 months ago

Linux Host: VMs on Virtualbox 6.0.x are running abnormaly slow on modern AMD Processors

Reported by: Sanders Owned by:
Component: other Version: VirtualBox 6.0.8
Keywords: Cc:
Guest type: all Host type: other

Description

For some reason VirtualBox 6.0.x has suddenly become very, very slow running on modern AMD hardware and Linux.

Any VM Guest being it Linux or Windows has become completely inpracticable.

In my case I run on a "AMD Ryzen 7 1800X Eight-Core Processor" and VirtualBox struggles to run anything.

I'm not sure when this might have started as in the same computer I remember VirtualBox 5.2 being blazingly fast.

KVM in the same hardware flies in comparison.

This is my CPU info:

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 23
model           : 1
model name      : AMD Ryzen 7 1800X Eight-Core Processor
stepping        : 1
microcode       : 0x8001138
cpu MHz         : 2195.009
cache size      : 512 KB
physical id     : 0
siblings        : 16
core id         : 0
cpu cores       : 8
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 13
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid aperfmperf pni pclmulqdq monitor ssse3 fma cx16 sse4_1 sse4_2 movbe popcnt aes xsave avx f16c rdrand lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw skinit wdt tce topoext perfctr_core perfctr_nb bpext perfctr_llc mwaitx cpb hw_pstate sme ssbd sev ibpb vmmcall fsgsbase bmi1 avx2 smep bmi2 rdseed adx smap clflushopt sha_ni xsaveopt xsavec xgetbv1 xsaves clzero irperf xsaveerptr arat npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold avic v_vmsave_vmload vgif overflow_recov succor smca
bugs            : sysret_ss_attrs null_seg spectre_v1 spectre_v2 spec_store_bypass
bogomips        : 7185.38
TLB size        : 2560 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 43 bits physical, 48 bits virtual
power management: ts ttp tm hwpstate eff_freq_ro [13] [14]

This is my LSPCI:

00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Root Complex
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) I/O Memory Management Unit
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:03.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:03.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe GPP Bridge
00:04.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:07.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:07.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) PCIe Dummy Host Bridge
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Internal PCIe GPP Bridge 0 to Bus B
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 59)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 5
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 6
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Data Fabric: Device 18h; Function 7
01:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] 300 Series Chipset USB 3.1 xHCI Controller (rev 02)
01:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] 300 Series Chipset SATA Controller (rev 02)
01:00.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 43b2 (rev 02)
02:00.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 300 Series Chipset PCIe Port (rev 02)
02:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 300 Series Chipset PCIe Port (rev 02)
02:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] 300 Series Chipset PCIe Port (rev 02)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X] (rev c7)
06:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 580]
07:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 145a
07:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) Platform Security Processor
07:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) USB 3.0 Host Controller
08:00.0 Non-Essential Instrumentation [1300]: Advanced Micro Devices, Inc. [AMD] Device 1455
08:00.2 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)
08:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

I've tried to disable Audio, 3D acceleration, change VGA, remove USB, etc, nothing makes a big difference.

I've tried VMs running Windows XP, Windows 8.1, CentOS 7.x, Debian 9, Ubuntu 16.04, 18.04... They are all unusable.

Attached the vmlog for my Debian 9 test vm

Also below there are the links to forum entries where I have done more troubleshooting, and another forum entry where someone details having performance problems too with an AMD Threadripper CPU.

 https://forums.virtualbox.org/viewtopic.php?f=7&t=93748

 https://forums.virtualbox.org/viewtopic.php?f=7&t=93320

Please, let me know if I can provide with any more information.

Attachments

VBox.log.zip Download (34.4 KB) - added by Sanders 13 months ago.
VBox Log from a Debian 9 vm which is running abnormally slow.
dmidecode.log.zip Download (3.3 KB) - added by Sanders 13 months ago.
Dmidecode output from my computer, just in case it could provide any required extra info.
VBox.18753.log.tar.gz Download (18.7 KB) - added by pgnd 8 months ago.

Change History

Changed 13 months ago by Sanders

VBox Log from a Debian 9 vm which is running abnormally slow.

Changed 13 months ago by Sanders

Dmidecode output from my computer, just in case it could provide any required extra info.

comment:1 Changed 13 months ago by Sanders

Forgot to add I run VirtualBox under Ubuntu 18.04.2 with Kernels and Kernel 5.1.17, also tried with Kernel 4.18.0-25 but made no difference.

comment:2 follow-up: ↓ 3 Changed 13 months ago by socratis

Related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=7&t=93748

You forgot to update the thread in the forums, done it for you, linked the two... ;)

comment:3 in reply to: ↑ 2 Changed 13 months ago by Sanders

Replying to socratis:

Related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=7&t=93748

You forgot to update the thread in the forums, done it for you, linked the two... ;)

Thanks! :-)

comment:4 Changed 11 months ago by snow-jlove

Watching.

comment:5 Changed 10 months ago by jwhite

Just another me too; identical circumstances. Working well with 5.X on Intel, switched to a Ryzen motherboard, and all guest operations just felt like molasses. Installing a VM takes over an hour, whereas it used to be 5 minutes. Problems have persisted through to 6.1.

comment:6 follow-up: ↓ 7 Changed 8 months ago by BBQigniter

I'm in the same boat. Also tried with Fedora 31 because first I thought the Ubuntu 18.04 installation had some problem.

Host is latest Window 10 with latest Virtualbox

also found this thread:  https://forums.virtualbox.org/viewtopic.php?f=2&t=93766

and yes, the more cores you set the slower the guest gets. Will try to upload logs later this day

# edited: typo

Last edited 8 months ago by BBQigniter (previous) (diff)

comment:7 in reply to: ↑ 6 Changed 8 months ago by BBQigniter

Replying to BBQigniter:

I'm in the same boat. Also tried with Fedora 31 because first I thought the Ubuntu 18.04 installation had some problem.

Host is latest Window 10 with latest Virtualbox

also found this thread:  https://forums.virtualbox.org/viewtopic.php?f=2&t=93766

and yes, the more cores you set the slower the guest gets. Will try to upload logs later this day

# edited: typo

I'm absolutely baffled and cannot reproduce my problem anymore after I turned on my PC at home again and started the vm like yesterday (also after reboots of host and guest i had lag and performance problems - only after switching to 2 cpus it was ok). Currently it even runs with 4 CPUs as expected. No lag in seamless mode on two 4k monitors. Yesterday i constantly had lag etc. iowait sometimes was very high in the vm.

i'll further observe my vm the next few days

wtf?!

comment:8 Changed 8 months ago by socratis

You know what's the best "medicine" for a bug?

Try to reproduce it!!!

:D

Changed 8 months ago by pgnd

comment:9 Changed 8 months ago by pgnd

I'm seeing similar exteremely laggy perf with Win10 guests on 3 linux VB 6.1.0 hosts, each with Ryzen 7 3700X CPUs, UEFI boot, and linux kernel 5.4.5-24.g47eef04-default.

Same VB ver6.1.0, with older CPUs -- AMD PhenomII X4s, runs with no lags.

Log attached ...

EDIT:

as @BBQigniter mentions, here "the more cores you set the slower the guest gets." as well ...

EDIT2:

as point of reference, from click-to-login on Win10 guest with valid credentials it takes ~57 seconds to reach/display desktop. From desktop, click-on-Win10 menu takes ~25 seconds for the menu to expand/appear.

This is for current VB config with 4 cores enabled + 12GB RAM (32GB total)

where,

> free
                total        used        free      shared  buff/cache   available
  Mem:       32770944    17120932    11697356      218996     3952656    14973388
  Swap:       8388604           0     8388604

with VB already running.

Last edited 8 months ago by pgnd (previous) (diff)

comment:10 Changed 7 months ago by PGNd

  • Status changed from new to awaitsfeedback

@Sanders

I know you reported against 6.0.8, but there are now several reports of this issue persisting into 6.1.x.

Could you perhaps bump your report from Version 6.0.8 -> 6.1.0? Saves opening up a new bug that distracts ...

comment:11 Changed 7 months ago by birdy

This could be a dupe of #19152 which is already being investigated by a member of the team and a regression range has already been established.

comment:12 Changed 7 months ago by aeichner

  • Status changed from awaitsfeedback to closed
  • Resolution set to fixed

As #19151 was fixed and this looks like the same or at least similar issue please try again with the latest release and reopen if this is still an issue providing new VBox.log files.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use