VirtualBox

Ticket #18567 (closed defect: fixed)

Opened 3 months ago

Last modified 2 months ago

mouse is eratic in Windows 10 after update 6.04 >>> 6.06 -> fixed in releases after April 26 2019

Reported by: Jurg Owned by:
Component: other Version: VirtualBox 6.0.6
Keywords: mouse windows 10 Cc:
Guest type: Windows Host type: Linux

Description

VirtualBox 6.04 was update to 6.06 (including installing Extention Pack in Linux (Mint with kernel 4.15)/VBox and guest additons in Windows 10). After this update to 6.06 the mouse was behaving eratic in Windows 10:

  1. When moving the mouse or clicking left the right sub menu opened sometimes at the mouse sometimes in the upper left corner.
  2. Left clicking only accidentally worked (about ones in 5 to 10 times).
  3. Captured mouse or not did both not function and fullscreen or not either.
  4. Sometimes the hostkey message appeared when only trying to click with the mouse in Windows.
  5. Rebooting host/guest did not help.
  6. Problems started allready before extention pack and guest additions where installed.
  7. Nothing else changed except this update to 6.06, with 6.04 all worked fine.

Seems to me that the mouse driver/communication was disturbed.

Change History

comment:1 Changed 3 months ago by proof

Also in Windows 7 with last updates and current vbox additions.

EDIT: My host is a Windows 10 Host.

Last edited 3 months ago by proof (previous) (diff)

comment:2 Changed 3 months ago by Jurg

Downgrading to Virtualbox 5.2 solved (temporarily) the problem.

comment:3 follow-up: ↓ 4 Changed 3 months ago by reinhard

I have got the same problems after updating from 6.0.4 to 6.0.6

host: Linux Mint 18.3 guest: Win 7 ulitmate with 6.0.6 guest addition

everything up to date

so I tried to re-install 6.0.6, but did not help. After removing 6.0.6 and installing 6.0.4 all worked fine (as before)

comment:4 in reply to: ↑ 3 Changed 3 months ago by notandor

Also on Fedora 5.0.7-200.fc29.x86_64 w w7 6.0.4|6 ga

Difficult to shutdown guest. Trick is mouse works in scaled mode.

Last edited 3 months ago by notandor (previous) (diff)

comment:5 Changed 3 months ago by socratis

I gathered all the reporters in a discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=1&t=92742

Please let's continue there. I need you to read the instructions and post your logs.

See:  https://forums.virtualbox.org/viewtopic.php?f=1&t=92742#p446628

comment:6 Changed 3 months ago by michael

Subscribe.

comment:7 Changed 3 months ago by socratis

Michael, you should subscribe to the discussion in the forums... ;)

comment:8 Changed 3 months ago by seeker

I have the same problem, when I upgraded from 6.0.4 to 6.0.6; my mouse buttons do not work on the Windows 10 guests, however, only on my primary monitor in full screen or seamless mode. I have a five monitor set up and the guests work normally on the other 4 monitors (including in full screen and seamless modes). This is an inconvenience that I hope is corrected soon. Thanks, jps

comment:9 Changed 3 months ago by socratis

I've compiled a table of what I believe is the source of the problem. I just need to to confirm the following and/or fill in the missing gaps:

  • Host: Complete details. Version/Build/Revision/Bits. Win10 is not an OS, it's a family.
  • Guest: Same as the host.
  • Monitors: How many, HiDPI or not, and where/how do you lose the mouse.

Fill the information in the forums, easier for me to compile them all together:  https://forums.virtualbox.org/viewtopic.php?f=1&t=92742

Last edited 3 months ago by socratis (previous) (diff)

comment:10 Changed 3 months ago by таз

Subscribe

comment:11 follow-ups: ↓ 12 ↓ 14 Changed 3 months ago by michael

Please try the 6.0.x test builds at revision 130207 (exactly that revision):

https://www.virtualbox.org/wiki/Testbuilds

comment:12 in reply to: ↑ 11 ; follow-up: ↓ 13 Changed 3 months ago by zzeroo

Replying to michael:

Please try the 6.0.x test builds at revision 130207 (exactly that revision):

https://www.virtualbox.org/wiki/Testbuilds

@michael revision 130207 works for me.

Host:

  • Lenovo P71
  • Linux p71-smueller 5.0.9-arch1-1-ARCH #1 SMP PREEMPT Sat Apr 20 15:00:46 UTC 2019 x86_64 GNU/Linux
  • Xserver with nvidia binary drivers (version 418.56)

Guest:

  • Windows 10 Pro 1903

Monitors:

  • 2x4k

Rev 130207 fixes also unviewable icons from the menubar of running guests

Last edited 3 months ago by zzeroo (previous) (diff)

comment:13 in reply to: ↑ 12 Changed 3 months ago by blubber

Replying to zzeroo:

Problem seems to be resolved in testbuild 130207 on Linux 64 host with Linux guest (Android x86 8.1 r1 guest).

  • Mouse works fine.
  • After left click, the mouse cursor sometimes "hangs" for a while every now and then, however will move regularly again after some mouse moves.
  • Mouse cursor acceleration seems to be slower than in host system.

-> All in all... Well done, thank you!

comment:14 in reply to: ↑ 11 Changed 3 months ago by TheDcoder

Replying to michael:

Please try the 6.0.x test builds at revision 130207 (exactly that revision):

I can confirm that revision 130207 is working properly with my Windows 10 Pro (Version 10.0.17134 Build 17134) guest on Fedora 29 host.

comment:15 Changed 3 months ago by michael

  • Summary changed from mouse is eratic in Windows 10 after update 6.04 >>> 6.06 to mouse is eratic in Windows 10 after update 6.04 >>> 6.06 -> fixed in releases after April 26 2019

Thanks for testing.

comment:16 Changed 3 months ago by FreddyW

I can confirm that 6.0.7 r130207 works on Fedora 30 as well (windows 10 and fedora 30 lxde guests).

However, the issue appears to be back in 6.0.97 r130208. Which is odd, since it was build a few minutes after rev. 130207 if the installer output is to be believed:

VirtualBox Version 6.0.7 r130207 (2019-04-23T16:44:11Z) installer

VirtualBox Version 6.0.97 r130208 (2019-04-23T17:04:36Z) installer

comment:17 Changed 3 months ago by michael

That is expected, sorry about that. I initially made the change to 6.0 only as a single test change which I reverted immediately afterwards. I am updating the test builds now. When that is done they should all contain the fix.

comment:18 Changed 3 months ago by FreddyW

No problem, thanks for the clarification. Can't wait for the official release ...

comment:19 Changed 2 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:20 Changed 2 months ago by gefr

I had the same behaviour after switching from 6.0.4 to 6.0.8 (or 6.0.6)

After switching from 6.0.4 to 6.0.8 the mouse position was incorrect. After switching from full screen (1600x900) to another resolution by <ctrl>F the mouse pointer is shown in the wrong position.The same appears after booting in 1024x768 and switching to 1600x900. Switching back to the "original" screen resolution shows the correct mouse pointer postion again.

Upgrading Windows to May, 17, 2019 brought no improvements.

Switching back to 6.0.4 is no work-around because the re-installation of 6.0.4 does not force windows to ask for the re-installation of the network-adapters (Netzwerkapter in German). I assume, i am working with parts of 6.0.8 after downgrading to 6.0.4

Going to version Build 130207 is not possible because this version is no longer available.

So i am stuck.

Host: windows 10 Guest: Linux Mint Xfce 64 Bit 19.1 (guest additions correspond to VB version)

I can provide appropriate log files for 6.0.8 and 6.0.4 (after downgrade).

Last edited 2 months ago by gefr (previous) (diff)

comment:21 Changed 2 months ago by FreddyW

I just tried my windows 10 VM and have no problems whatsoever with the mouse pointer anymore with 6.0.8. For what it is worth, I use VBoxSVGA as Graphics Controller with the pointing device set to USB Tablet.

comment:22 Changed 2 months ago by michael

A couple of people also confirmed in the forum thread (see above) that this is now fixed. @gefr Could you please go to that thread to ask people subscribed to it if what you are seeing is really the same as what they are or something else? I am guessing that it is either something to do with the way your system is set up, or a different problem.

comment:23 Changed 2 months ago by gefr

I described the problem in detail in the forum:  https://forums.virtualbox.org/viewtopic.php?f=1&t=92742#p446441

Sorry for selecting the wrong place

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use