VirtualBox

Ticket #1856 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Vista 64 host: "failed to create the host network interface" E_FAIL (0x80004005)

Reported by: nicminus Owned by:
Priority: major Component: network
Version: VirtualBox 1.6.2 Keywords: host network interface tap driver
Cc: Guest type: Linux
Host type: Windows

Description

I am unable to create a host network interface, either from the command line or through the gui.

I'm running Vista 64 and Virtualbox 1.6.2.

When I attempt to create the interface, it asks me where to find the TAP driver; I manually select VBoxTAP.sys in C:\Program Files\Sun\xVM VirtualBox\drivers\network\.

-- C:\Program Files\Sun\xVM VirtualBox>vboxmanage createhostif "VM1 external" VirtualBox Command Line Management Interface Version 1.6.2 (C) 2005-2008 Sun Microsystems, Inc. All rights reserved.

0%...FAILED [!] Full error info present: true , basic error info present: true [!] Result Code = E_FAIL (0x80004005) - Unspecified error [!] Text = SetupDiCallClassInstaller (DIF_INSTALLDEVICE) failed (0x000000 05) [!] Component = Host, Interface: IHost, {81729c26-1aec-46f5-b7c0-cc7364738fdb}

[!] Callee = <NULL>, {00000000-0000-0000-0000-000000000000} -- GUI:

SetupDiCallClassInstaller (DIF_INSTALLDEVICE) failed (0x00000005).

Result Code: E_FAIL (0x80004005) Component: Host Interface: IHost {81729c26-1aec-46f5-b7c0-cc7364738fdb}

--

Seems similar to Ticket #1146, but no solution was posted there.

Hope someone can help, this is causing me a lot of trouble.

-- nic

Change History

comment:1 Changed 6 years ago by nicminus

I reinstalled Vista 64 and VirtualBox, and was able to add host interfaces without trouble.

I'm not sure what was causing the problem. The main differences between my old Vista install and my new install were:

  • User Access Control was turned off on the original install
  • Original install was running in test mode to allow the installation of unsigned drivers

Ticket should probably be closed now, but this information may be useful to others who experience similar problems.

comment:2 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Kind of hard to say what exactly is the cause, but thanks for pointing it out here. I'll close it now.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use