VirtualBox

Ticket #1853 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

No sound on XP guest when changing focus on both FullScreen apps

Reported by: Stahn Owned by:
Priority: major Component: audio
Version: VirtualBox 1.6.2 Keywords: fullscreen
Cc: Guest type: Windows
Host type: Windows

Description

I'm on XP SP3, running an XP SP3 guest machine, the guest (VirtualBox) is on a second monitor. I installed the Guest Additions, load up a Video file (.avi) on Shared Folders, put on FullScreen (Host Key+F). All Ok. Then I load up a Fullscreen application (like a game) on the host (first monitor), and then the sound on the guest (second monitor) is muted. If I click again on the guest, the sound is on. Got no problems with VMware Workstation.

In the VM settings, Audio is enabled, Host Audio Driver is on Windows Direct Sound, and Audio Controller is ICH AC97. Tested with SB16, no luck.

Change History

comment:1 Changed 5 years ago by Gagtech

I have a similar issue, but it happens when you either show the desktop, or change the focus to another 3D application... It seems to function OK if I leave it up, and just put it in the background. But if I actually minimize the window, it stops working.

Windows XP SP3 on host and guest as well. Version 2.1.4

My other settings are similar to the creators post, but I am not running in dual screen mode. They are both on the same desktop.

Here's how I can reproduce the issue:

Play some music on the guest OS. Minimize all your windows so that you can see your desktop. The music should still play. Now click on your host OS desktop. The music stops. If you bring up the VBOX window again, the music will resume. So its acting as if it mutes the guest OS when focus is completely lost.

This will also happen when I run a 3D application.

comment:2 Changed 4 years ago by alank

I am having this issue with 3.0.8. Playing a video in the guest (Windows XP) has no sound. Sometimes, clicking on a window in the Host OS (Windows 7) and then clicking on the guest window will fix it. Sometimes it won't.

comment:3 Changed 4 years ago by Giora

Its still the same for v3.2.8 T_T

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5578. Well, this ticket is older but the other ticket contains more information :)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use