VirtualBox

Ticket #18511 (closed defect: invalid)

Opened 8 months ago

Last modified 8 months ago

[buster] [virtualbox] Copy paste not working -> not a VirtualBox issue

Reported by: Federico M. Owned by:
Component: other Version: VirtualBox 6.0.4
Keywords: debian buster 10 Cc:
Guest type: Linux Host type: all

Description

Dear Sir/Madam,

I installed Debian Buster (choosing lxde IDE) on virtualbox (both 5.2 and 6.0).

The copy paste function does not work. You cannot copy text, you cannot copy files in file explorers.

It did not work even when installing the VB add-ons. Sharing clipboard or not does not change anything.

I think it is a major incompatibility bug for the new Debian release (Debian 9 obviously works).

Do you mind investigating?

Thanks and best regards,

F.M.

Attachments

journalctl.rar Download (18.0 KB) - added by Federico M. 8 months ago.
lsmod.rar Download (1.2 KB) - added by Federico M. 8 months ago.
MachineLogs.rar Download (52.7 KB) - added by Federico M. 8 months ago.
No_copy.mp4 Download (271.9 KB) - added by Federico M. 8 months ago.
Video of the issue

Change History

comment:1 Changed 8 months ago by socratis

Federico M., the bugtracker is for bugs, not for discussions or help.

  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved in the forums, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

Plus a discussion and analysis on the bug tracker is going to help you, me, and potentially a future drive-by user or two. Not so in the forums, many more tend to benefit...

So, if you can, please open a new thread in the  Linux Guests section of the forums. Please be sure to mention that you came from the bug tracker and include the ticket number.

  1. You were supposed to follow these steps when you filed the bug, and provide a VBox.log:

    Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

comment:2 Changed 8 months ago by michael

You might also, after installing the Additions, provide the output of lsmod and journalctl.

comment:3 Changed 8 months ago by Federico M.

I will provide more logs: sorry if my bug report in not clear.

I noticed the problem on both VB 5.2 and 6.0, also on Windows 10 and Ubuntu 16 hosts.

Changed 8 months ago by Federico M.

Changed 8 months ago by Federico M.

Changed 8 months ago by Federico M.

comment:4 Changed 8 months ago by Federico M.

I want to underline that in my opinion this problem is not related to a specific host (Windows/Linux) nor a specific VB version (I reproduce with 5.2 and 6.0).

In addition, the copy paste is not completely broken: if I copy-paste very quickly (less than 500ms), it can work sometimes. If the elapse between the copy and the paste is more than 1s, there is no chance that it will work (it is like the copy information is cleaned). And, I have not been able to copy files in a graphic explorer yet (maybe I am not so quick...).

Last edited 8 months ago by Federico M. (previous) (diff)

comment:5 Changed 8 months ago by socratis

comment:6 Changed 8 months ago by michael

That sounds to me like there might be something in the Debian guest grabbing the clipboard. Could you try investigating that?

Changed 8 months ago by Federico M.

Video of the issue

comment:7 Changed 8 months ago by michael

I checked the forum discussion and the video, and it appears you mean copying and pasting inside of the guest, not VirtualBox's shared clipboard functionality. Does removing the Guest Additions altogether make any difference? If not then you should probably go to a Debian or LXDE support channel.

comment:8 Changed 8 months ago by michael

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from [buster] [virtualbox] Copy paste not working to [buster] [virtualbox] Copy paste not working -> not a VirtualBox issue

Socratis pointed out that you said in the forums that it happens without the Additions installed. So I will close this ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use