VirtualBox

Ticket #18454 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

Guest additions can't be built on Linux 4.4.168 because of API change -> duplicate of #18454

Reported by: IlyaK Owned by:
Component: guest additions Version: VirtualBox 6.0.4
Keywords: Cc:
Guest type: Linux Host type: all

Description

Linux bug:  https://bugzilla.kernel.org/show_bug.cgi?id=202365

People can't build guest additions and create patches by their selves

 https://www.linuxquestions.org/questions/slackware-14/virtualbox-fails-to-build-drivers-for-kernel-4-4-172-a-4175647407/

Error:

/tmp/vbox.1/r0drv/linux/memobj-r0drv-linux.c:1113:18: error: too many arguments to function 'get_user_pages'

rc = get_user_pages(pTask, /* Task for fault accounting. */

Change History

comment:1 Changed 2 years ago by socratis

Duplicate of #18315.

comment:2 Changed 2 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Guest additions can't be built on Linux 4.4.168 because of API change to Guest additions can't be built on Linux 4.4.168 because of API change -> duplicate of #18454

Thanks Socratis. Please try the current test builds which should fix the problem and report on #18315.

https://www.virtualbox.org/wiki/Testbuilds

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use