VirtualBox

Ticket #18379 (reopened defect)

Opened 16 months ago

Last modified 12 months ago

New OS/2 shared folders feature locks up the guest => Fixed in SVN

Reported by: Rafcio Owned by:
Component: shared folders Version: VirtualBox 6.0.4
Keywords: Cc:
Guest type: other Host type: Windows

Description

After adding the new shared folders installable file system (VBoxSF.IFS) the guest GUI started to lock up just a second after VBoxService is executed from STARTUP.CMD. The mouse cursor still moves, so this is not a hard lock, but any interaction with GUI is impossible. The guest has to be powered off. The only workaround is to comment out the IFS statement in CONFIG.SYS.

Attachments

VBox.log Download (161.4 KB) - added by Rafcio 16 months ago.

Change History

Changed 16 months ago by Rafcio

comment:1 Changed 16 months ago by socratis

Does this have any relationship to #18376?

comment:2 Changed 16 months ago by Rafcio

Nope. The other ticket looks completely unrelated. Here, I can't even get to mapping a drive, because the GUI is not responding after VBoxService is started.

comment:3 Changed 15 months ago by bird

  • Summary changed from New OS/2 shared folders feature locks up the guest to New OS/2 shared folders feature locks up the guest => Fixed in SVN

I think it's the same issue, just different manifestations. Found KernStrToUcs to clobber ES with a HPFS-only eCS 2.1 guest. Test builds with revision number 129269 or higher includes the fix.

comment:4 Changed 15 months ago by socratis

Just out of curiosity, was this a 6.0.0, a .2 or a .4 regression?

comment:5 Changed 15 months ago by Rafcio

I think it was in 6.0.0

comment:6 Changed 13 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 12 months ago by Rafcio

Well, if the fix made it to 6.0.6 it wasn't that as the problem was still there. I didn't test with 6.0.8, but to me it's clear that the issue wasn't fixed. It needs to be reopened.

comment:8 Changed 12 months ago by Rafcio

  • Status changed from closed to reopened
  • Resolution fixed deleted
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use