VirtualBox

Ticket #18331 (closed defect: duplicate)

Opened 10 months ago

Last modified 7 months ago

Restoring 32bit Windows XP VM Saved State Fails => Fixed in SVN

Reported by: DaveD Owned by:
Component: other Version: VirtualBox 6.0.2
Keywords: Cc:
Guest type: Windows Host type: Linux

Description (last modified by janitor) (diff)

VM boots cleanly, and creates snapshot, .sav file is about 100M (not always same size), . When restoring VM from a saved state snapshot, it will always fail with the following:

00:00:02.244370 !!Assertion Failed!!
00:00:02.244370 Expression: !VMCPU_FF_IS_SET(pVCpu, VMCPU_FF_INTERRUPT_PIC)
00:00:02.244371 Location  : /build/virtualbox/src/VirtualBox-6.0.2/src/VBox/VMM/VMMR3/PDM.cpp(1006) int pdmR3LoadExec(PVM, PSSMHANDLE, uint32_t, uint32_t)
00:00:02.244387 Stack     :
00:00:02.244387 00007fbbbd936617 VBoxRT.so + 0x164617
00:00:02.244388 

Guest Additions are current. I have recreated snapshot without any effect on the problem. This worked correctly with the same VM under 5.2.22 and before.

host os: arch linux kernel 4.20.3 guest os: windows xp 32bit

Attachments

VBox.log Download (75.2 KB) - added by DaveD 10 months ago.
VBox.2.log Download (163.8 KB) - added by mhanor 10 months ago.
VBox_xp_sav.log Download (127.9 KB) - added by DaveD 10 months ago.
VBox-CentOS7host-XPguest.log Download (72.5 KB) - added by gapost 9 months ago.

Change History

Changed 10 months ago by DaveD

comment:1 Changed 10 months ago by mhanor

Confirmed for Windows 10 1803 host.

Changed 10 months ago by mhanor

comment:2 Changed 10 months ago by socratis

Perhaps a duplicate of #18263 (Restoring 32bit Windows7 VM Saved State Fails), or #18265 (Win7 in VB 6.0.0 fails on resume on 97%)?

comment:3 Changed 10 months ago by mhanor

I've tried to reproduce the crash with a Windows 7 32 bit VM, standard VM setting, but I couldn't.

comment:4 Changed 10 months ago by DaveD

error message is different then #18263 and resume reach 100% before throw the error. In my case, win xp, the odd thing is .sav file size, it's about 1/10 (100M) of memory assigned to vm (1GB), seem something get wrong during memory state saving. In attachment VBox.log of saved state, far as i can see i'ts all ok

Last edited 10 months ago by DaveD (previous) (diff)

Changed 10 months ago by DaveD

comment:5 Changed 10 months ago by PeterMottens

I have version 6.0.4 and a Win XP VM:

Steps to reproduce: Create a save point for Win XP guest, close the VM, restore

Expected:Guest VM is restored and runs

Actual:Restore progress bar get close to 100%, error message pops up

Log:

00:00:01.794930 Expression: !VMCPU_FF_IS_SET(pVCpu, VMCPU_FF_INTERRUPT_PIC)
00:00:01.794931 Location  : /home/vbox/vbox-6.0.4/src/VBox/VMM/VMMR3/PDM.cpp(1006) int pdmR3LoadExec(PVM, PSSMHANDLE, uint32_t, uint32_t)
00:00:01.794947 Stack     :
00:00:01.794947 00007ffa8fef3d2c VBoxRT.so + 0x16cd2c

Last edited 10 months ago by PeterMottens (previous) (diff)

comment:6 Changed 10 months ago by DaveD

I've done new tests on 6.0.4

  • xp restore (fresh install + guest additions) NOT WORKING

00:00:02.244370 !!Assertion Failed!! 00:00:02.244370 Expression: !VMCPU_FF_IS_SET

  • windows 10 restore (fresh install + guest additions) WORKING
Last edited 10 months ago by DaveD (previous) (diff)

comment:7 Changed 9 months ago by gapost

Confirm for CentOS 7.6.1810 host.

Changed 9 months ago by gapost

comment:8 Changed 9 months ago by Jacques Marques

Confirm for Ubuntu 18.04 host

comment:9 Changed 8 months ago by janitor

  • Description modified (diff)

comment:10 Changed 8 months ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate
Last edited 8 months ago by janitor (previous) (diff)

comment:11 Changed 7 months ago by bird

  • Summary changed from Restoring 32bit Windows XP VM Saved State Fails to Restoring 32bit Windows XP VM Saved State Fails => Fixed in SVN
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use