VirtualBox

Ticket #18281 (new enhancement)

Opened 2 years ago

Feedback of /sbin/vboxconfig on failing module load not always helpful

Reported by: karl-philipp.richter Owned by:
Component: other Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: other Host type: Linux

Description

Failing of /sbin/vboxconfig due to failing module load results in the feedback

$ sudo /sbin/vboxconfig
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Starting VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.

However, dmesg doesn't reliably show the reason for the failure, in my case it contains no new message in comparison to dmesg executed right before running /sbin/vboxconfig whereas sudo modprobe -vvv vbox* shows the reason for the failure:

modprobe: INFO: ../libkmod/libkmod.c:364 kmod_set_log_fn() custom logging function 0x560016357ee0 registered
modprobe: DEBUG: ../libkmod/libkmod-index.c:755 index_mm_open() file=/lib/modules/4.18.0-13-generic/modules.dep.bin
modprobe: DEBUG: ../libkmod/libkmod-index.c:755 index_mm_open() file=/lib/modules/4.18.0-13-generic/modules.alias.bin
modprobe: DEBUG: ../libkmod/libkmod-index.c:755 index_mm_open() file=/lib/modules/4.18.0-13-generic/modules.symbols.bin
modprobe: DEBUG: ../libkmod/libkmod-index.c:755 index_mm_open() file=/lib/modules/4.18.0-13-generic/modules.builtin.bin
modprobe: DEBUG: ../libkmod/libkmod-module.c:556 kmod_module_new_from_lookup() input alias=vboxdrv-module-signing, normalized=vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:562 kmod_module_new_from_lookup() lookup modules.dep vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod.c:574 kmod_search_moddep() use mmaped index 'modules.dep' modname=vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:566 kmod_module_new_from_lookup() lookup modules.symbols vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:570 kmod_module_new_from_lookup() lookup install and remove commands vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:574 kmod_module_new_from_lookup() lookup modules.aliases vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod.c:434 kmod_lookup_alias_from_alias_bin() use mmaped index 'modules.alias' for name=vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:578 kmod_module_new_from_lookup() lookup modules.builtin vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod.c:501 lookup_builtin_file() use mmaped index 'modules.builtin' modname=vboxdrv_module_signing
modprobe: DEBUG: ../libkmod/libkmod-module.c:583 kmod_module_new_from_lookup() lookup vboxdrv_module_signing=0, list=(nil)
modprobe: FATAL: Module vboxdrv-module-signing not found in directory /lib/modules/4.18.0-13-generic

Please note that I'm requesting a fix for the feedback of the script, not the issue shown in the output of modprobe.

experienced with 6.0.0 r127566 (Qt5.11.1) on Ubuntu 18.10

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use