VirtualBox

Ticket #1822 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

XP Guest Additions issue

Reported by: cornbread Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 2.0.2 Keywords: XP, Shared folders,
Cc: Guest type: Windows
Host type: Linux

Description

I am running 5 Ubuntu boxes 4 are Hardy and 1 is gutsy all with XP SP2 Guests.

When I install or updated to virtualbox 1.6.2 I had to install guest additions several times to get network shares working.

For example: I had my Documents folder shared in 1.5.6 on a gutsy box and a net use script that mounted upon login. As soon as I upgraded to 1.6.2 and installed guest additions the net use script wouldn't work. I knew this problem existed from my other boxes and installed them again, no worky, again, no worky, and finally the 4TH TIME my net use script mounted it automatically.

Thank you for your product.

Attachments

sf_fix.reg Download (788 bytes) - added by pentagonik 6 years ago.
Fix for network problems
Screenshot.png Download (37.8 KB) - added by cornbread 6 years ago.
video issues randomly happens.
Xp-2008-07-23-12-31-51.log Download (30.1 KB) - added by cornbread 6 years ago.
log right after a crash trying to go from full screen back to windowed mode
Xp-2008-07-23-11-16-15.log Download (36.1 KB) - added by cornbread 6 years ago.
2nd log
Xp-2008-07-23-11-00-48.log Download (45.6 KB) - added by cornbread 6 years ago.
Xp-2008-07-21-21-49-20.log Download (39.7 KB) - added by cornbread 6 years ago.
guestadditions.png Download (257.8 KB) - added by cornbread 6 years ago.
1.6.4 just switched from full screen and it kills my icon layout back to 640x480 woo
GAY.png Download (19.9 KB) - added by cornbread 6 years ago.
Virtualbox doing it's thing
2.0.png Download (11.6 KB) - added by cornbread 6 years ago.
woo

Change History

Changed 6 years ago by pentagonik

Fix for network problems

comment:1 Changed 6 years ago by pentagonik

I've attached a "sf_fix.reg" file to this defect. Please save this file on your guests hard drive, double click on it and say "Yes" if it asks to write to the registry.

After a reboot, the net use script should working again. This issue will be fixed in the next release of VBox.

comment:2 Changed 6 years ago by frank

  • Component changed from other to guest additions

comment:3 Changed 6 years ago by cornbread

This fix didn't work for speed wise. I have to share the folder and then change my scripts to net use x: \10.0.2.2\SharedFolder

Otherwise to open a simple word document sometimes takes a whole minute.

I am also getting a BSOD on some print shares... I'll attach a screenshot. My aunt is telling me she is getting a black screen with small dots on it (she sent me a screen)

Changed 6 years ago by cornbread

video issues randomly happens.

Changed 6 years ago by cornbread

log right after a crash trying to go from full screen back to windowed mode

Changed 6 years ago by cornbread

2nd log

Changed 6 years ago by cornbread

Changed 6 years ago by cornbread

comment:4 Changed 6 years ago by cornbread

So to summarize issues with guest additions:

Network issues with sharing (extremely slow with \vboxserver share) so fix is to share in host and mount with \10.0.2.2\sharename

Video issues black screens at random (screenshot attached)

Bluescreens with some printer shares

Will restart gdm sometimes when switching from or to full screen mode.

comment:5 Changed 6 years ago by klaus

A test with Additions r33126 was reported to show a BSOD.

comment:6 Changed 6 years ago by Jamie Jackson

I'm getting something very similar, and it *might* be related.

Ubuntu 8.10 host VirtualBox 1.6.2 from Sun site Windows XP SP2 guest

Steps to reproduce: Start VirtualBox & start "xp1" VM In "xp1" vm, Start >> Run "\xboxsvr\anothershare"; click ok I get the same sort of vm screen as the attached screenshot.

Other operations trigger the issue, too, but this is a pretty reliable one. Other triggers are mainly ones that access or try to access network shares (not just \vboxsvr\* shares).

I don't know what happens to the VM. I don't know if it's a graphics only problem, or what, but sending ctrl-alt-del doesn't do anything to it. I don't seem to, or don't know how, to recover the session aside from rebooting the vm. However, I suppose the vm is unresponsive anyway, even under the graphic weirdness.

I'd assume that this is sort of equivalent to a BSOD, though I haven't seen a proper BSOD, just the black screen with rainbow streaks (same as attached png).

Additions r33126 didn't work for me either (thanks, though, klaus).

Not sure where to go from here, nor how to troubleshoot.

comment:7 Changed 6 years ago by Jamie Jackson

Forgot to mention that this problem is not particular to 1.6.2. The reason I tried 1.6.2 is I was having the same problem (recently) in 1.6.0 (also the sun package).

Sorry about the lack of <br> above, but I guess it's still legible.

comment:8 Changed 6 years ago by cornbread

Also on another note the guest resolution auto-resize function has never worked right since 1.5.4. I had issues with additions 1.6.3 and 1.6.0 and just reinstalled 1.5.4 and instantly realized better handling of guest window resizing.

comment:9 Changed 6 years ago by pentagonik

Please try again with 1.6.4. If you still get errors, please report back here.

comment:10 Changed 6 years ago by cornbread

Still having network issues. The video issues will take a while to fully test. can not mount \vboxsvr\Documents on one box and on the others it is still slower to access files than using \10.0.2.2\Documents.

Changed 6 years ago by cornbread

1.6.4 just switched from full screen and it kills my icon layout back to 640x480 woo

comment:11 Changed 6 years ago by Jamie Jackson

So far, so good with 1.6.4: No more black, streaky freezes.

comment:12 Changed 6 years ago by cornbread

Ok huge issues still now instead of nice black screens and reboots on print. I'm also getting achingly slow usage from \vboxsvr\share and going to \10.0.2.2\share reboots without fail! I'm attaching a screenshot for your viewing pleasure.....

Changed 6 years ago by cornbread

Virtualbox doing it's thing

comment:13 Changed 6 years ago by frank

When did this BSOD happen, during boot or reboot?

comment:14 Changed 6 years ago by cornbread

it causes a reboot. It happens when I use my network to access a share on the host sometimes when using \vboxsvr\share and everytime when using \10.0.2.2\share. The funny thing is that 1.6.0 if I remember correctly was the opposite. I tried a different network adapter FAIL.

comment:15 Changed 6 years ago by serberus

Just adding I also experienced a BSOD in Windows Vista when it first booted when restoring the Window from a minimized state. This has only happened once - I've been running Virtual box for approximately two weeks.

My host OS is Ubuntu 8.04 running VirtualBox 1.6.4 and Windows Vista SP1 with guest additions installed. I didn't have any applications open in Vista at the time as it had just booted. I had just upgraded to IE8 beta 2 though.

Would it help to attach my VB log file?

comment:16 Changed 6 years ago by frank

All: Did 1.6.6 fix the problem for you?

comment:17 Changed 6 years ago by cornbread

No and 2.0 didn't either. I have attached a screenshot again. I am going to upgrade to 2.02 today but I don't think it's been fixed in that either.

Changed 6 years ago by cornbread

woo

comment:18 Changed 6 years ago by cornbread

When is this going to be fixed? I have 2.0.2 and it has happened to me twice within the last week? What's the deal? It's been doing this since 1.6.0. Is this on the roadmap to be fixed? Is there work being done to fix it?

comment:19 Changed 6 years ago by sunlover

Disable the WebClient? service in the guest. See  http://forums.virtualbox.org/viewtopic.php?t=2155&start=0&postdays=0&postorder=asc&highlight=mrxdav especially the last comment.

comment:20 Changed 5 years ago by frank

  • Version changed from VirtualBox 1.6.2 to VirtualBox 2.0.2

Did that help?

comment:21 Changed 5 years ago by cornbread

Lol no

comment:22 Changed 5 years ago by sandervl73

  • Priority changed from blocker to critical

comment:23 Changed 4 years ago by sunlover

Similar issues have been fixed some time ago. Please use VirtualBox 3.0.12 or 3.1 beta (  http://forums.virtualbox.org/viewtopic.php?f=15&t=24827 ). Make sure to install corresponding guest additions.

comment:24 Changed 4 years ago by Technologov

No response, please close.

-Technologov

comment:25 Changed 4 years ago by frank

Well, let's wait for at least 4 weeks for a response.

comment:26 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use