VirtualBox

Ticket #1820 (closed defect: duplicate)

Opened 6 years ago

Last modified 3 years ago

Mouse pointer disappears over text if host is controlled by Remote Desktop

Reported by: tommytao Owned by:
Priority: major Component: RDP
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

Host: WinXP SP2
Guest: WinXP SP2 (with Guest addtions installed)
VirtualBox 1.6.2

Issue: Disappearing mouse pointer over text, if host is controlled by Remote Desktop

Steps to re-create:

  1. Remote Desktop to host
  2. Start VirtualBox's Guest
  3. Start notepad in Guest OS
  4. Point to text input area, mouse cursor disappeared

Things to note:

The issue will not happen if Guest OS's mouse pointer is other than default (such as "beam_r.cur") ...

Is it a bug ? can it be fixed ?

Thanks very much for help [[BR]]

Ref:

 http://abhijeetmaharana.com/blog/2008/02/23/virtualbox-disappearing-mouse-pointer-over-text/

Change History

comment:1 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Description modified (diff)
  • Summary changed from Disappearing mouse pointer over text, if host is controlled by Remote Desktop ... ! to Mouse pointer disappears over text if host is controlled by Remote Desktop

comment:2 Changed 6 years ago by frank

  • Component changed from other to RDP

Actually the RDP protocol does not allow to transfer the complete mouse cursor information. AFAIR, there is no alpha channel.

comment:3 Changed 4 years ago by dpo

Is this a duplicate of #1058?

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Probably.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use