VirtualBox

Ticket #18115 (reopened defect)

Opened 20 months ago

Last modified 4 months ago

VBoxSVC segfault when ending Windows guest

Reported by: deller Owned by:
Component: VMM Version: VirtualBox 5.2.20
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

When cleanly shutting down Windows guests (on a CentOS Host), which were started with:

VBoxManage startvm MACHINENAME -type vrdp

I see afterwards in the Linux syslog this kind of crash:

VBoxSVC[5805]: segfault at 0 ip (null) sp 00007ffc9097f068 error 14 in VBoxSVC[400000+4de000]

The crash is reproducible, and has been there since a long time (all of 5.2.x VirtualBox versions).

Attachments

VBox.log Download (136.9 KB) - added by deller 20 months ago.
VBox log file
VBoxSVC.log Download (8.1 KB) - added by deller 20 months ago.
VBoxSVC log file

Change History

comment:1 Changed 20 months ago by socratis

Logs? Crash dumps? Anything?

At a minimum, you were supposed to follow these steps when you filed the bug, and provide a VBox.log:

Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

Changed 20 months ago by deller

VBox log file

comment:2 Changed 20 months ago by deller

VBox.log file is now attached.

comment:3 Changed 20 months ago by deller

I have to admit, that one usually doesn't even notice this crash. It happens *after* the virtual machine has shut down cleanly, so IMHO it's not even a "critical" bug (although it's a crash), because it seems it has no negative effect on the guest or host itself. Looking at the VBox.log file doesn't even seem to indicate that a crash happened at all (at least I don't see any indication for a crash).

Changed 20 months ago by deller

VBoxSVC log file

comment:4 Changed 20 months ago by deller

Added VBoxSVC log file

comment:5 Changed 20 months ago by deller

I did some more debugging, and I noticed, that it's not required to start/stop a VM to trigger this bug.

Instread, running this trivial command gives the same crash as well:

/usr/lib/virtualbox/VBoxManage list hdds

It doesn't matter if I run "list hdds" or "list dvds", all output is OK, but at the end a crash happens which is always the same.

When running it with gdb, I don't see a crash and sadly can't get a backtrace:

[Thread 0x7ffff7f4b700 (LWP 19842) exited]
[Thread 0x7ffff7eca700 (LWP 19863) exited]
[Thread 0x7ffff7fcc700 (LWP 19841) exited]
[Inferior 1 (process 19831) exited normally]

Very strange....

Last edited 20 months ago by janitor (previous) (diff)

comment:6 Changed 20 months ago by socratis

So pretty much anything that involves VBoxSVC... Hmm...

comment:7 Changed 4 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still an issue with a recent VirtualBox release.

comment:8 Changed 4 months ago by deller

  • Status changed from closed to reopened
  • Resolution obsolete deleted

Re-opening this bug.
It still happens with latest VirtualBox-5.2-5.2.38_136252_el7-1.x86_64 on CentOS Linux release 7.7.1908.
dmesg says:

[11910.314697] vboxnetflt: 0 out of 95134 packets were not sent (directed to host)
[11920.920223] VBoxSVC[3242]: segfault at 0 ip           (null) sp 00007ffde76c9e98 error 14 in VBoxSVC[400000+4dd000]
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use