VirtualBox

Ticket #18056 (new defect)

Opened 4 years ago

Last modified 4 years ago

Linux VM fails to PXE boot on MacOS host

Reported by: sorin Owned by:
Component: network Version: VirtualBox 5.2.20
Keywords: macos Cc:
Guest type: Linux Host type: other

Description

Virtualbox (5.2.18) + extensions installed on a 2017 iMac with MacOS (OSX) 10.14 Mojave and it seems impossible to make the VM get an IP address from my DHCP server during PXE booting.

I tried all possible combinations for configuring the network adapter for the VM but still it fails to get the DHCP IP. I even checked the DHCP server logs and I am sure that the IP used by the VM never reached it.

The config I was expecting to be working:

Bridged Adapter: en0 (this is the LAN of the iMac) Adapter Type: one of Intel ones (but tried all 6 possible alternatives) Promiscous Mode: deny MAC Address: a generated one Cable Connected: Checked.

I am not sure if this problem is specific to MacOS Mojave or the Ethernet board in iMac as I did not had the chance to test with other versions.

Initially posted on  https://forums.virtualbox.org/viewtopic.php?f=8&t=89792

Change History

comment:1 Changed 4 years ago by socratis

Thanks for posting the related forum discussion so that I can link the two.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use